summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-11-05 15:05:51 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-11-05 15:05:51 +0000
commit3a1f2f62b6dd4a5912504afb94c19d19625c0357 (patch)
treedaee0c537a11d87d1279c95da2948bfe9f19a690 /net-analyzer/fail2ban/fail2ban-0.8.4-r1.ebuild
parentMasking fail2ban revbump for testing (diff)
downloadhistorical-3a1f2f62b6dd4a5912504afb94c19d19625c0357.tar.gz
historical-3a1f2f62b6dd4a5912504afb94c19d19625c0357.tar.bz2
historical-3a1f2f62b6dd4a5912504afb94c19d19625c0357.zip
Bugfix revision. Fixes bug 260337,283629,301139,315073,343955. Thanks to Robert Trace <bugzilla-gentoo@farcaster.org>, Harley Peters <harley@thepetersclan.com> for the patches.
Package-Manager: portage-2.2.0_alpha3_p8/cvs/Linux x86_64
Diffstat (limited to 'net-analyzer/fail2ban/fail2ban-0.8.4-r1.ebuild')
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.8.4-r1.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/net-analyzer/fail2ban/fail2ban-0.8.4-r1.ebuild b/net-analyzer/fail2ban/fail2ban-0.8.4-r1.ebuild
new file mode 100644
index 000000000000..166a2e13f09e
--- /dev/null
+++ b/net-analyzer/fail2ban/fail2ban-0.8.4-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fail2ban/fail2ban-0.8.4-r1.ebuild,v 1.1 2010/11/05 15:05:51 hwoarang Exp $
+
+EAPI=2
+
+PYTHON_DEPEND="2"
+
+inherit distutils eutils
+
+DESCRIPTION="Bans IP that make too many password failures"
+HOMEPAGE="http://fail2ban.sourceforge.net/"
+SRC_URI="mirror://sourceforge/fail2ban/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="net-misc/whois
+ virtual/mta
+ net-firewall/iptables"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-hashlib.patch \
+ "${FILESDIR}"/${P}-sshd-breakin.patch
+ distutils_src_prepare
+}
+
+src_install() {
+ distutils_src_install
+
+ diropts -m 0755 -o root -g root
+ dodir /var/run/${PN}
+ keepdir /var/run/${PN}
+
+ newconfd files/gentoo-confd fail2ban
+ newinitd files/gentoo-initd fail2ban
+ dodoc ChangeLog README TODO || die "dodoc failed"
+ doman man/*.1 || die "doman failed"
+
+ # Use INSTALL_MASK if you do not want to touch /etc/logrotate.d.
+ # See http://thread.gmane.org/gmane.linux.gentoo.devel/35675
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}-logrotate ${PN} || die
+}
+
+pkg_preinst() {
+ has_version "<${CATEGORY}/${PN}-0.7"
+ previous_less_than_0_7=$?
+}
+
+pkg_postinst() {
+ if [[ $previous_less_than_0_7 = 0 ]] ; then
+ elog
+ elog "Configuration files are now in /etc/fail2ban/"
+ elog "You probably have to manually update your configuration"
+ elog "files before restarting Fail2ban!"
+ elog
+ elog "Fail2ban is not installed under /usr/lib anymore. The"
+ elog "new location is under /usr/share."
+ elog
+ elog "You are upgrading from version 0.6.x, please see:"
+ elog "http://www.fail2ban.org/wiki/index.php/HOWTO_Upgrade_from_0.6_to_0.8"
+ fi
+}