summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-05-15 13:25:52 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-05-15 13:25:52 +0000
commitf5a32ff22f360d3760f4ed971a56d811a62a1a15 (patch)
tree3defacac91c8d468e43a5382ef3608d60f55b66c /net-analyzer/libnasl/libnasl-2.3.1.ebuild
parentMoved using toolchain-funcs instead of gcc. Removed the two makefiles which a... (diff)
downloadhistorical-f5a32ff22f360d3760f4ed971a56d811a62a1a15.tar.gz
historical-f5a32ff22f360d3760f4ed971a56d811a62a1a15.tar.bz2
historical-f5a32ff22f360d3760f4ed971a56d811a62a1a15.zip
Version bump for bug 78497
Package-Manager: portage-2.0.51.21-r1
Diffstat (limited to 'net-analyzer/libnasl/libnasl-2.3.1.ebuild')
-rw-r--r--net-analyzer/libnasl/libnasl-2.3.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-analyzer/libnasl/libnasl-2.3.1.ebuild b/net-analyzer/libnasl/libnasl-2.3.1.ebuild
new file mode 100644
index 000000000000..4ce64d04eeed
--- /dev/null
+++ b/net-analyzer/libnasl/libnasl-2.3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/libnasl/libnasl-2.3.1.ebuild,v 1.1 2005/05/15 13:25:51 ka0ttic Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A remote security scanner for Linux (libnasl)"
+HOMEPAGE="http://www.nessus.org/"
+SRC_URI="ftp://ftp.nessus.org/pub/nessus/experimental/nessus-${PV}/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64 ~ppc64"
+IUSE=""
+
+DEPEND="=net-analyzer/nessus-libraries-${PV}"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ export CC=$(tc-getCC)
+ econf || die "configuration failed"
+ # emake fails for >= -j2. bug #16471.
+ emake -C nasl cflags
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "Install failed libnasl"
+ dodoc COPYING
+}