summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKyle Manna <nitro@gentoo.org>2002-08-04 20:56:23 +0000
committerKyle Manna <nitro@gentoo.org>2002-08-04 20:56:23 +0000
commit776bcb2803f82bdf100a7de9b06ee1796ef031cd (patch)
treecff13aa77b548e80c7b2583a9a20c0d17f7bcf90 /net-analyzer/net-snmp
parentdigest cleanup (thanks repoman) (diff)
downloadhistorical-776bcb2803f82bdf100a7de9b06ee1796ef031cd.tar.gz
historical-776bcb2803f82bdf100a7de9b06ee1796ef031cd.tar.bz2
historical-776bcb2803f82bdf100a7de9b06ee1796ef031cd.zip
Fixes bug #5882.
Diffstat (limited to 'net-analyzer/net-snmp')
-rw-r--r--net-analyzer/net-snmp/ChangeLog8
-rw-r--r--net-analyzer/net-snmp/files/digest-net-snmp-5.0.2a-r11
-rw-r--r--net-analyzer/net-snmp/net-snmp-5.0.2a-r1.ebuild63
3 files changed, 71 insertions, 1 deletions
diff --git a/net-analyzer/net-snmp/ChangeLog b/net-analyzer/net-snmp/ChangeLog
index d915607c1ff8..c82ad10c231e 100644
--- a/net-analyzer/net-snmp/ChangeLog
+++ b/net-analyzer/net-snmp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/net-snmp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/ChangeLog,v 1.2 2002/07/23 22:19:15 nitro Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/ChangeLog,v 1.3 2002/08/04 20:56:23 nitro Exp $
+
+*net-snmp-5.0.2a-r1 (4 Aug 2002)
+
+ 4 Aug 2002; Kyle Manna <nitro@gentoo.org> net-snmp-5.0.2a-r1.ebuild:
+
+ Closed bug #5882, manually recreate the symlink.
*net-snmp-5.0.2a (23 Jul 2002)
diff --git a/net-analyzer/net-snmp/files/digest-net-snmp-5.0.2a-r1 b/net-analyzer/net-snmp/files/digest-net-snmp-5.0.2a-r1
new file mode 100644
index 000000000000..f392eb21731a
--- /dev/null
+++ b/net-analyzer/net-snmp/files/digest-net-snmp-5.0.2a-r1
@@ -0,0 +1 @@
+MD5 18f137c812b62955123a03b35a7e2c0f net-snmp-5.0.2a.tar.gz 2201724
diff --git a/net-analyzer/net-snmp/net-snmp-5.0.2a-r1.ebuild b/net-analyzer/net-snmp/net-snmp-5.0.2a-r1.ebuild
new file mode 100644
index 000000000000..2f9ec2736dd8
--- /dev/null
+++ b/net-analyzer/net-snmp/net-snmp-5.0.2a-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/net-snmp-5.0.2a-r1.ebuild,v 1.1 2002/08/04 20:56:23 nitro Exp $
+
+S=${WORKDIR}/${P%[a-z]}
+DESCRIPTION="Software for generating and retrieving SNMP data"
+SRC_URI="mirror://sourceforge/net-snmp/${P}.tar.gz"
+HOMEPAGE="http://net-snmp.sourceforge.net/"
+
+DEPEND="virtual/glibc <sys-libs/db-2
+ >=sys-libs/zlib-1.1.4
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ kerberos? ( >=app-crypt/krb5-1.2.5 )"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86"
+
+src_compile() {
+ local myconf disable_sec_services
+
+ use ssl || myconf="${myconf} --enable-internal-md5 --with-openssl=no"
+ use tcpd && myconf="${myconf} --with-libwrap" || myconf="${myconf} --with-libwrap=no"
+ use ipv6 && myconf="${myconf} --enable-ipv6" || myconf="${myconf} --disable-ipv6"
+ # Doesn't seem that emerge passes the escaped double quotes properly -- nitro
+ #use ipv6 || myconf="${myconf} --with-out-transports=\"TCPIPv6 UDPIPv6\""
+ use kerberos && myconf="${myconf} --with-security-modules=\"usm ksm\""
+
+ econf \
+ --with-cflags="${CFLAGS}" \
+ --host="${CHOST}" \
+ --with-zlib \
+ --enable-shared \
+ --with-sys-location="Unknown" \
+ --with-sys-contact="root@Unknown" \
+ --with-default-snmp-version="3" \
+ --with-logfile=/var/log/net-snmpd.log \
+ --with-persistent-directory=/var/lib/net-snmp \
+ --with-mib-modules=host \
+ ${myconf} || die "bad ./configure"
+
+ # Parallel make doesn't work.
+ make || die "compile problem"
+}
+
+src_install () {
+
+ einstall exec_prefix=${D}/usr \
+ persistentdir=${D}/var/lib/net-snmp || die
+
+ dodir /var/lib/net-snmp
+
+ dodoc AGENT.txt ChangeLog FAQ INSTALL NEWS PORTING README* TODO EXAMPLE.conf.def
+
+ # Close bug #5882:
+ rm -f ${D}/usr/bin/snmptrap
+ dosym /usr/bin/snmptrap /usr/bin/snmpinform
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/net-snmpd.rc6 net-snmpd
+}