summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2013-07-04 12:47:55 +0000
committerLars Wendler <polynomial-c@gentoo.org>2013-07-04 12:47:55 +0000
commite91a53ca626d92fe56ede7569da6ecb3104029e6 (patch)
tree33977be587ba8239c8c439a3985a404b42da3df9 /net-analyzer/ntop/ntop-5.0.1.ebuild
parentx11-libs/qwt: Version Bump (diff)
downloadhistorical-e91a53ca626d92fe56ede7569da6ecb3104029e6.tar.gz
historical-e91a53ca626d92fe56ede7569da6ecb3104029e6.tar.bz2
historical-e91a53ca626d92fe56ede7569da6ecb3104029e6.zip
Version bump (fixes bug #430428). Removed old
Package-Manager: portage-2.2.0_alpha186/cvs/Linux x86_64 Manifest-Sign-Key: 0x981CA6FC
Diffstat (limited to 'net-analyzer/ntop/ntop-5.0.1.ebuild')
-rw-r--r--net-analyzer/ntop/ntop-5.0.1.ebuild117
1 files changed, 117 insertions, 0 deletions
diff --git a/net-analyzer/ntop/ntop-5.0.1.ebuild b/net-analyzer/ntop/ntop-5.0.1.ebuild
new file mode 100644
index 000000000000..d0f91976d288
--- /dev/null
+++ b/net-analyzer/ntop/ntop-5.0.1.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-5.0.1.ebuild,v 1.1 2013/07/04 12:47:51 polynomial-c Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_{6,7} )
+
+inherit autotools eutils user python-single-r1
+
+DESCRIPTION="Network traffic analyzer with web interface"
+HOMEPAGE="http://www.ntop.org/products/ntop/"
+SRC_URI="mirror://sourceforge/ntop/ntop/Stable/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="snmp ssl"
+
+COMMON_DEPEND="
+ virtual/awk
+ dev-lang/perl
+ sys-libs/gdbm
+ dev-libs/libevent
+ net-libs/libpcap
+ media-libs/gd
+ media-libs/libpng
+ net-analyzer/rrdtool
+ ssl? ( dev-libs/openssl )
+ sys-libs/zlib
+ dev-libs/geoip
+ dev-lang/lua
+ snmp? ( net-analyzer/net-snmp[ipv6] )"
+DEPEND="${COMMON_DEPEND}
+ >=sys-devel/libtool-1.5.26
+ ${PYTHON_DEPS}"
+RDEPEND="${COMMON_DEPEND}
+ media-fonts/corefonts
+ media-gfx/graphviz
+ net-misc/wget
+ app-arch/gzip
+ dev-libs/glib:2
+ dev-python/mako"
+
+pkg_setup() {
+ enewgroup ntop
+ enewuser ntop -1 -1 /var/lib/ntop ntop
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ cp /usr/share/aclocal/libtool.m4 libtool.m4.in
+ cat acinclude.m4.in libtool.m4.in acinclude.m4.ntop > acinclude.m4
+ eautoreconf
+}
+
+src_configure() {
+ export \
+ ac_cv_header_glib_h=no \
+ ac_cv_header_glibconfig_h=no \
+ ac_cv_header_gdome_h=no \
+ ac_cv_lib_glib_g_date_julian=no \
+ ac_cv_lib_xml2_xmlCheckVersion=no \
+ ac_cv_lib_gdome_gdome_di_saveDocToFile=no
+
+ pushd nDPI >/dev/null || die
+ econf
+ popd &>/dev/null || die
+
+ econf \
+ $(use_enable snmp) \
+ $(use_with ssl) \
+ --with-rrd-home=/usr/lib
+
+}
+
+src_compile() {
+ pushd nDPI >/dev/null || die
+ emake
+ popd &>/dev/null || die
+
+ emake
+}
+
+src_install() {
+ LC_ALL=C # apparently doesn't work with some locales (#191576 and #205382)
+
+ emake DESTDIR="${D}" install
+
+ keepdir /var/lib/ntop &&
+ fowners ntop:ntop /var/lib/ntop &&
+ fperms 750 /var/lib/ntop
+ insinto /var/lib/ntop
+ gunzip 3rd_party/GeoIPASNum.dat.gz
+ gunzip 3rd_party/GeoLiteCity.dat.gz
+ local f
+ for f in GeoIPASNum.dat GeoLiteCity.dat; do
+ # Don't install included GeoIP files if newer versions are available
+ [ -f "${ROOT}/var/lib/ntop/${f}" ] ||
+ doins "3rd_party/${f}"
+ done
+
+ dodoc AUTHORS CONTENTS ChangeLog MANIFESTO NEWS
+ dodoc PORTING README SUPPORT_NTOP.txt THANKS $(find docs -type f)
+
+ newinitd "${FILESDIR}"/ntop-initd ntop
+ newconfd "${FILESDIR}"/ntop-confd ntop
+
+ exeinto /etc/cron.monthly
+ doexe "${FILESDIR}"/ntop-update-geoip-db
+}
+
+pkg_postinst() {
+ elog "If this is the first time you install ntop, you need to run"
+ elog "following command before starting ntop service:"
+ elog " ntop --set-admin-password"
+}