summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-08 16:06:07 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-08 16:06:07 +0000
commit801c3e9c067b7962abaaf6e31207e42536e12e2a (patch)
tree541d9de2628ff98f95a971c7d28e5493c1e071ec /net-analyzer/ntop
parent*** empty log message *** (diff)
downloadhistorical-801c3e9c067b7962abaaf6e31207e42536e12e2a.tar.gz
historical-801c3e9c067b7962abaaf6e31207e42536e12e2a.tar.bz2
historical-801c3e9c067b7962abaaf6e31207e42536e12e2a.zip
*** empty log message ***
Diffstat (limited to 'net-analyzer/ntop')
-rw-r--r--net-analyzer/ntop/files/digest2
-rw-r--r--net-analyzer/ntop/ntop-1.3.1-r1.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/net-analyzer/ntop/files/digest b/net-analyzer/ntop/files/digest
new file mode 100644
index 000000000000..f5c79862ae09
--- /dev/null
+++ b/net-analyzer/ntop/files/digest
@@ -0,0 +1,2 @@
+MD5 8afc33c65a176339916841e3a5177468 ntop-1.3.1.tar.gz
+MD5 8fcb6a8ba511ec8b54b95f267ef52cf0 openssl-0.9.5a.tar.gz
diff --git a/net-analyzer/ntop/ntop-1.3.1-r1.ebuild b/net-analyzer/ntop/ntop-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..5ac2fec59dea
--- /dev/null
+++ b/net-analyzer/ntop/ntop-1.3.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-1.3.1-r1.ebuild,v 1.1 2000/08/08 16:06:07 achim Exp $
+
+P=ntop-1.3.1
+A="${P}.tar.gz"
+S=${WORKDIR}/${P}
+CATEGORY="net-analyzer"
+DESCRIPTION="Unix Tool that shows networkusage like top"
+SRC_URI="ftp://ftp.it.ntop.org/pub/local/ntop/snapshots/${A}"
+HOMEPAGE="http://www.ntop.org/ntop.html"
+
+
+src_compile() {
+ cd ${S}
+ cp configure configure.orig
+ sed -e "s:/usr/local/ssl:/usr:" configure.orig > configure
+ CFLAGS="$CFLAGS -I/usr/include/openssl" ./configure --prefix=/usr --sysconfdir=/usr/share --host=${CHOST}
+ make
+
+}
+
+src_install () {
+
+ cd ${S}
+ make prefix=${D}/usr sysconfdir=/${D}/usr/share install
+ mv ${D}/usr/bin/plugins ${D}/usr/share/ntop
+ prepman
+ dodoc AUTHORS ChangeLog CONTENTS COPYING FAQ FILES HACKING
+ dodoc KNOWN_BUGS MANIFESTO NEWS ntop.txt PORTING README*
+ dodoc SUPPORT* THANKS THREADS-FAQ TODO
+ docinto html
+ dodoc ntop.html
+}
+
+
+