summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2006-06-04 18:11:16 +0000
committerPeter Volkov <pva@gentoo.org>2006-06-04 18:11:16 +0000
commitbd8e763fe80b7f544b0e917fd55280b310ab480d (patch)
treec0027104f4f4e3834f0b1b7aa04fb554ea8b0ac9 /net-analyzer/sussen/files
parentRemove hardcoding of .m4 files from configure.in. Fixes bug 135463 (diff)
downloadhistorical-bd8e763fe80b7f544b0e917fd55280b310ab480d.tar.gz
historical-bd8e763fe80b7f544b0e917fd55280b310ab480d.tar.bz2
historical-bd8e763fe80b7f544b0e917fd55280b310ab480d.zip
Partial fix for bug 135493. sussen-applet should not crash when cancel pressed during execution.
Package-Manager: portage-2.0.54-r2
Diffstat (limited to 'net-analyzer/sussen/files')
-rw-r--r--net-analyzer/sussen/files/digest-sussen-0.22-r11
-rw-r--r--net-analyzer/sussen/files/sussen-0.22-applet-cancel-scan-crash.patch32
2 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/sussen/files/digest-sussen-0.22-r1 b/net-analyzer/sussen/files/digest-sussen-0.22-r1
new file mode 100644
index 000000000000..1f0c4bb7b5ef
--- /dev/null
+++ b/net-analyzer/sussen/files/digest-sussen-0.22-r1
@@ -0,0 +1 @@
+MD5 e4176264bf3f14e6badb726e18a14c4d sussen-0.22.tar.gz 765383
diff --git a/net-analyzer/sussen/files/sussen-0.22-applet-cancel-scan-crash.patch b/net-analyzer/sussen/files/sussen-0.22-applet-cancel-scan-crash.patch
new file mode 100644
index 000000000000..10b0be87e335
--- /dev/null
+++ b/net-analyzer/sussen/files/sussen-0.22-applet-cancel-scan-crash.patch
@@ -0,0 +1,32 @@
+diff -Naur sussen-0.22.orig/applet/ActionDialog.cs sussen-0.22/applet/ActionDialog.cs
+--- sussen-0.22.orig/applet/ActionDialog.cs 2006-05-13 20:05:54.000000000 +0400
++++ sussen-0.22/applet/ActionDialog.cs 2006-06-04 22:01:24.000000000 +0400
+@@ -59,6 +59,8 @@
+ ActionDialogType actionDialogType;
+
+ bool scanDone;
++ bool userCancelled;
++
+ uint scanTimer;
+ string xmlDirectory;
+ string downloadDirectory;
+@@ -190,6 +192,11 @@
+ {
+ GLib.Source.Remove (scanTimer);
+ notify.Close ();
++
++ if (userCancelled) {
++ userCancelled = false;
++ return;
++ }
+
+ scanDone = true;
+ executeButton.Sensitive = true;
+@@ -354,6 +361,7 @@
+ notify.WakeupMain ();
+
+ scanDone = true;
++ userCancelled = true;
+ }
+ }
+