summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-10-18 18:40:26 +0000
committerJeroen Roovers <jer@gentoo.org>2010-10-18 18:40:26 +0000
commitea31680327d5c2352e552712b7600be1551013e8 (patch)
treef294bf34d9968215b12a8845f38ab6e323931243 /net-analyzer/traceroute/traceroute-2.0.16.ebuild
parentReally made the remaining version block php 5.3 (diff)
downloadhistorical-ea31680327d5c2352e552712b7600be1551013e8.tar.gz
historical-ea31680327d5c2352e552712b7600be1551013e8.tar.bz2
historical-ea31680327d5c2352e552712b7600be1551013e8.zip
Version bump by Samuli Suominen (bug #338812).
Package-Manager: portage-2.2_rc98/cvs/Linux i686
Diffstat (limited to 'net-analyzer/traceroute/traceroute-2.0.16.ebuild')
-rw-r--r--net-analyzer/traceroute/traceroute-2.0.16.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-analyzer/traceroute/traceroute-2.0.16.ebuild b/net-analyzer/traceroute/traceroute-2.0.16.ebuild
new file mode 100644
index 000000000000..6da84ff435f9
--- /dev/null
+++ b/net-analyzer/traceroute/traceroute-2.0.16.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/traceroute/traceroute-2.0.16.ebuild,v 1.1 2010/10/18 18:40:26 jer Exp $
+
+EAPI=2
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Utility to trace the route of IP packets"
+HOMEPAGE="http://traceroute.sourceforge.net/"
+SRC_URI="mirror://sourceforge/traceroute/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static"
+
+src_compile() {
+ use static && append-ldflags -static
+ tc-export CC AR RANLIB
+ emake env=yes || die
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ prefix="/usr" \
+ libdir="/usr/$(get_libdir)" \
+ install \
+ || die
+ dodoc ChangeLog CREDITS README TODO
+}