summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-05-26 19:21:19 +0000
committerTravis Tilley <lv@gentoo.org>2004-05-26 19:21:19 +0000
commita2a4e9971a46ff06b3f06234d8171983a6e7f465 (patch)
tree3a857110ef7a61bb8b820552bc8fb3190f581e52 /net-analyzer/ttcp/ttcp-1.12.ebuild
parentarm KEYWORDS (diff)
downloadhistorical-a2a4e9971a46ff06b3f06234d8171983a6e7f465.tar.gz
historical-a2a4e9971a46ff06b3f06234d8171983a6e7f465.tar.bz2
historical-a2a4e9971a46ff06b3f06234d8171983a6e7f465.zip
go team 64bit cleanliness patch
Diffstat (limited to 'net-analyzer/ttcp/ttcp-1.12.ebuild')
-rw-r--r--net-analyzer/ttcp/ttcp-1.12.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/net-analyzer/ttcp/ttcp-1.12.ebuild b/net-analyzer/ttcp/ttcp-1.12.ebuild
index af841fde40d4..6d722dbf5ff6 100644
--- a/net-analyzer/ttcp/ttcp-1.12.ebuild
+++ b/net-analyzer/ttcp/ttcp-1.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ttcp/ttcp-1.12.ebuild,v 1.3 2004/05/09 10:57:37 sejo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ttcp/ttcp-1.12.ebuild,v 1.4 2004/05/26 19:21:19 lv Exp $
inherit gcc
@@ -14,6 +14,11 @@ KEYWORDS="x86 ~amd64 ~ppc"
DEPEND="virtual/glibc"
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ use amd64 && epatch ${FILESDIR}/ttcp-1.12-amd64.patch
+}
+
src_compile() {
$(gcc-getCC) ${CFLAGS} -o ttcp sgi-ttcp.c || die "compile failed"
}