summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Brindle <method@gentoo.org>2003-04-16 16:52:16 +0000
committerJoshua Brindle <method@gentoo.org>2003-04-16 16:52:16 +0000
commit13c1079600a9d374e7ce6f53aee57c6535547fc2 (patch)
tree9b8a9660d10e45d383f3022083a7a1ac518d0698 /net-analyzer
parent2.0 version bump (diff)
downloadhistorical-13c1079600a9d374e7ce6f53aee57c6535547fc2.tar.gz
historical-13c1079600a9d374e7ce6f53aee57c6535547fc2.tar.bz2
historical-13c1079600a9d374e7ce6f53aee57c6535547fc2.zip
2.0 version bump
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/snort/Manifest4
-rw-r--r--net-analyzer/snort/files/digest-snort-2.0.01
-rw-r--r--net-analyzer/snort/snort-2.0.0.ebuild109
3 files changed, 112 insertions, 2 deletions
diff --git a/net-analyzer/snort/Manifest b/net-analyzer/snort/Manifest
index c379c482552c..f5f03779c03e 100644
--- a/net-analyzer/snort/Manifest
+++ b/net-analyzer/snort/Manifest
@@ -1,10 +1,10 @@
MD5 710488a1702ad6555b6266400feca61c snort-1.8.6.ebuild 2539
MD5 b3815c56fdef8172caa0830e23810739 snort-1.9.1-r1.ebuild 2833
MD5 b7a9320806fdb6c56b298980ec223d1d snort-1.9.1.ebuild 2727
-MD5 31d00cdc74a863475fe67fd4d4d95af4 snort-2.0.0.ebuild 2838
+MD5 1057064defaeea4056ece6e5d894109d snort-2.0.0.ebuild 2899
MD5 4b805689503782e047d03cd3cceaee93 snort-1.8.7.ebuild 2565
MD5 cf4a92f35bdb8786f2e58741e3c08603 snort-1.9.0.ebuild 2720
-MD5 8df310533d2b3158af0af07fd092fd8e ChangeLog 2738
+MD5 53487bd69b13fb82e1ebc19ae52cb134 ChangeLog 2869
MD5 9a53009d3e2fabbb1cc15710a91b684d files/snort.rc6 781
MD5 121c260ad08b288811994e7b3d78d098 files/snort-1.9.1-alpha.patch 1614
MD5 f709dea91ede4986f0bcd0ec4b8f35b5 files/digest-snort-1.8.6 64
diff --git a/net-analyzer/snort/files/digest-snort-2.0.0 b/net-analyzer/snort/files/digest-snort-2.0.0
new file mode 100644
index 000000000000..524b1b60aa16
--- /dev/null
+++ b/net-analyzer/snort/files/digest-snort-2.0.0
@@ -0,0 +1 @@
+MD5 b7d374655c4390c07b2e38a2d381c2bd snort-2.0.0.tar.gz 1556540
diff --git a/net-analyzer/snort/snort-2.0.0.ebuild b/net-analyzer/snort/snort-2.0.0.ebuild
new file mode 100644
index 000000000000..03da952996fd
--- /dev/null
+++ b/net-analyzer/snort/snort-2.0.0.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/snort/snort-2.0.0.ebuild,v 1.1 2003/04/16 16:52:11 method Exp $
+
+inherit eutils
+
+IUSE="ssl postgres mysql snmp"
+S=${WORKDIR}/${P}
+DESCRIPTION="Libpcap-based packet sniffer/logger/lightweight IDS"
+SRC_URI="http://www.snort.org/dl/${P}.tar.gz"
+HOMEPAGE="http://www.snort.org"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~alpha"
+
+DEPEND="virtual/glibc
+ >=net-libs/libpcap-0.6.2-r1
+ ~net-libs/libnet-1.0.2a
+ postgres? ( >=dev-db/postgresql-7.2 )
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ ssl? ( >=dev-libs/openssl-0.9.6b )
+ snmp? ( >=net-analyzer/net-snmp-5.0 )"
+
+RDEPEND="virtual/glibc
+ dev-lang/perl
+ >=net-libs/libpcap-0.6.2-r1
+ postgres? ( >=dev-db/postgresql-7.2 )
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ ssl? ( >=dev-libs/openssl-0.9.6b )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ #is this needed in 2.0? -Method
+ #epatch ${FILESDIR}/${P}-configure.patch
+
+ # Following patch contributed in bug #18258
+ #is this needed in 2.0? -Method
+ #use alpha && epatch ${FILESDIR}/${P}-alpha.patch
+}
+
+src_compile() {
+
+ local myconf
+
+ use postgres && myconf="${myconf} --with-postgresql" \
+ || myconf="${myconf} --without-postgresql"
+ use mysql && myconf="${myconf} --with-mysql" \
+ || myconf="${myconf} --without-mysql"
+ use ssl && myconf="${myconf} --with-openssl" \
+ || myconf="${myconf} --without-openssl"
+ use snmp && myconf="${myconf} --with-snmp" \
+ || myconf="${myconf} --without-snmp"
+
+
+ ./configure \
+ --prefix=/usr \
+ --without-odbc \
+ --without-oracle \
+ --enable-pthreads \
+ --enable-flexresp \
+ --enable-smbalerts \
+ --mandir=/usr/share/man \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ emake || die "compile problem"
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+
+ dodir /var/log/snort
+ touch ${D}/var/log/snort/.keep
+
+ insinto /usr/lib/snort/bin
+ doins contrib/{create_mysql,snortlog,*.pl}
+
+ dodoc COPYING LICENSE doc/*
+ docinto contrib ; dodoc contrib/*
+
+ insinto /etc/snort
+ doins etc/classification.config rules/*.rules
+ newins etc/snort.conf snort.conf.distrib
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/snort.rc6 snort
+ insinto /etc/conf.d ; newins ${FILESDIR}/snort.confd snort
+}
+
+pkg_postinst() {
+
+ if ! grep -q ^snort: /etc/group ; then
+ groupadd snort || die "problem adding group snort"
+ fi
+ if ! grep -q ^snort: /etc/passwd ; then
+ useradd -g snort -s /dev/null -d /var/log/snort -c "snort" snort
+ assert "problem adding user snort"
+ fi
+ usermod -c "snort" snort || die "usermod problem"
+ usermod -d "/var/log/snort" snort || die "usermod problem"
+ usermod -g "snort" snort || die "usermod problem"
+ usermod -s "/dev/null" snort || die "usermod problem"
+ echo "ignore any message about CREATE_HOME above..."
+
+ chown snort.snort /var/log/snort
+ chmod 0770 /var/log/snort
+}