summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-10-25 13:53:21 +0000
committerEldad Zack <eldad@gentoo.org>2004-10-25 13:53:21 +0000
commit33a39b9d4b1b3f3f325b97416ac858974ba608d9 (patch)
treee664361fee6f385924b772b47610bc1740dba4ae /net-analyzer
parentunstable on ppc gsla: 68558 (diff)
downloadhistorical-33a39b9d4b1b3f3f325b97416ac858974ba608d9.tar.gz
historical-33a39b9d4b1b3f3f325b97416ac858974ba608d9.tar.bz2
historical-33a39b9d4b1b3f3f325b97416ac858974ba608d9.zip
bumpf
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ethereal/ChangeLog7
-rw-r--r--net-analyzer/ethereal/Manifest10
-rw-r--r--net-analyzer/ethereal/ethereal-0.10.7.ebuild86
-rw-r--r--net-analyzer/ethereal/files/digest-ethereal-0.10.71
4 files changed, 99 insertions, 5 deletions
diff --git a/net-analyzer/ethereal/ChangeLog b/net-analyzer/ethereal/ChangeLog
index 5cd46432439d..bd8e6f33b743 100644
--- a/net-analyzer/ethereal/ChangeLog
+++ b/net-analyzer/ethereal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/ethereal
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ChangeLog,v 1.85 2004/10/24 16:40:17 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ChangeLog,v 1.86 2004/10/25 13:53:21 eldad Exp $
+
+*ethereal-0.10.7 (25 Oct 2004)
+
+ 25 Oct 2004; Eldad Zack <eldad@gentoo.org> +ethereal-0.10.7.ebuild:
+ Version bump
24 Oct 2004; Eldad Zack <eldad@gentoo.org> ethereal-0.10.5-r1.ebuild,
ethereal-0.10.6.ebuild:
diff --git a/net-analyzer/ethereal/Manifest b/net-analyzer/ethereal/Manifest
index 11959ba40fec..506fdbf0a5d9 100644
--- a/net-analyzer/ethereal/Manifest
+++ b/net-analyzer/ethereal/Manifest
@@ -2,18 +2,20 @@
Hash: SHA1
MD5 e70cd283dc61b8b8ffdaba5e82ceb873 ethereal-0.10.5.ebuild 2580
+MD5 d31f4dc432eb756efbcc8d44503c1bd1 ethereal-0.10.7.ebuild 2422
MD5 d55ec36bbd613a4453870a65bc640b59 ethereal-0.10.6.ebuild 2421
-MD5 84b8ed2412f9a6996d97ebd04c4ae3f4 ChangeLog 4137
+MD5 96031ed3d6f54a90a35a231f48bc7f9f ChangeLog 4255
MD5 ac5ab068efc12615cf18dfcb44aad2e8 ethereal-0.10.5-r1.ebuild 2594
MD5 17a9be2cf8cb9f24e7e5b398392483b4 metadata.xml 224
MD5 5a73274ec255373b4e618388cd057275 files/0.10.4-gcc34.patch 458
MD5 56d5feedd5047dd2b7bcd4c9295addef files/digest-ethereal-0.10.5-r1 69
MD5 56d5feedd5047dd2b7bcd4c9295addef files/digest-ethereal-0.10.5 69
MD5 5bc98004e6492e3349a16bf0591c743e files/digest-ethereal-0.10.6 69
+MD5 17b6c78c6fc3bfe54222ff9626331c72 files/digest-ethereal-0.10.7 69
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)
-iD8DBQFBe9q/T+MN7JbqCpMRArJcAJ42fHEjiH/yUCU4Z/7qoTNWSpcUEgCgj8hB
-gwM1RAqk+yp+rx/8d1ncKes=
-=j7Dq
+iD8DBQFBfQUWT+MN7JbqCpMRAqqGAJ9c2ghnARKy0pzMGL9YC84nlj2VzgCdF8E7
+HMg3rOEcfrEcJxsjsboN1tE=
+=iQZ9
-----END PGP SIGNATURE-----
diff --git a/net-analyzer/ethereal/ethereal-0.10.7.ebuild b/net-analyzer/ethereal/ethereal-0.10.7.ebuild
new file mode 100644
index 000000000000..c2eaca395971
--- /dev/null
+++ b/net-analyzer/ethereal/ethereal-0.10.7.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.10.7.ebuild,v 1.1 2004/10/25 13:53:21 eldad Exp $
+
+inherit libtool flag-o-matic gcc eutils
+
+DESCRIPTION="A commercial-quality network protocol analyzer"
+HOMEPAGE="http://www.ethereal.com/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~amd64 ~ia64"
+IUSE="adns gtk ipv6 snmp ssl gtk2"
+
+# if --disable-gtk2 is not passed to configure it will try to build with glib-2.0.
+# --disable-ethereal do not have an influence.
+
+# snmp support requires >=net-snmp-5.1.1. Taking virtual off: snmp? ( virtual/snmp )
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ snmp? ( >=net-analyzer/net-snmp-5.1.1 )
+ >=dev-util/pkgconfig-0.15.0
+ gtk? ( gtk2? ( >=dev-libs/glib-2.0.4 =x11-libs/gtk+-2* )
+ !gtk2? ( =x11-libs/gtk+-1.2* ) )
+ !gtk? ( =dev-libs/glib-1.2* )
+ ssl? ( >=dev-libs/openssl-0.9.6e )
+ >=net-libs/libpcap-0.7.1
+ >=dev-libs/libpcre-4.2
+ adns? ( net-libs/adns )"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ sys-devel/bison
+ sys-devel/flex"
+
+src_compile() {
+
+ replace-flags -O3 -O
+ replace-flags -O2 -O
+
+ # Fix gcc-3.4 segfault #49238
+ [ "`gcc-version`" == "3.4" ] && append-flags -fno-unroll-loops
+
+ local myconf="
+ $(use_with ssl)
+ $(use_enable ipv6)
+ $(use_with adns)"
+
+ if use gtk; then
+ myconf="${myconf} $(use_enable gtk2)"
+ else
+ myconf="${myconf} --disable-gtk2"
+
+ # --disable-ethereal do not have an influence
+ #myconf="${myconf} --disable-ethereal"
+ # the asn1 plugin needs gtk
+ sed -i -e '/plugins.asn1/d' Makefile.in || die "sed failed"
+ sed -i -e '/^SUBDIRS/s/asn1//' plugins/Makefile.in || die "sed failed"
+ fi
+
+ # if USE=snmp, then one of the snmp libraries will be available,
+ # thanks to virtual/snmp. In that case, let Ethereal use
+ # whichever it finds.
+ if ! use snmp; then
+ myconf="${myconf} --without-ucd-snmp --without-net-snmp"
+ fi
+
+ econf \
+ --enable-dftest \
+ --enable-randpkt \
+ --sysconfdir=/etc/ethereal \
+ ${myconf} || die "bad ./configure"
+
+ addwrite "/usr/share/snmp/mibs/.index"
+ emake || die "compile problem"
+}
+
+src_install() {
+ addwrite "/usr/share/snmp/mibs/.index"
+ dodir /usr/lib/ethereal/plugins/${PV}
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS ChangeLog INSTALL.* NEWS README* TODO
+ insinto "/usr/share/pixmaps/"
+ doins "image/hi48-app-ethereal.png"
+}
diff --git a/net-analyzer/ethereal/files/digest-ethereal-0.10.7 b/net-analyzer/ethereal/files/digest-ethereal-0.10.7
new file mode 100644
index 000000000000..f422d099fc9c
--- /dev/null
+++ b/net-analyzer/ethereal/files/digest-ethereal-0.10.7
@@ -0,0 +1 @@
+MD5 eebd6cc45a45d68332b2c053aac0c484 ethereal-0.10.7.tar.bz2 5170212