summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2008-06-25 18:40:41 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2008-06-25 18:40:41 +0000
commit8c57de8c49afc8d930a12e5ed7c805b467b031ec (patch)
treedbfb8c01a62c91600be12e4f4f8be87eaeeeea4f /net-analyzer
parentBump. Fixes bugs 212943, 213167, 218105 and 226099. Added tests, cleaned up e... (diff)
downloadhistorical-8c57de8c49afc8d930a12e5ed7c805b467b031ec.tar.gz
historical-8c57de8c49afc8d930a12e5ed7c805b467b031ec.tar.bz2
historical-8c57de8c49afc8d930a12e5ed7c805b467b031ec.zip
Version bump
Package-Manager: portage-2.2_rc1/cvs/Linux 2.6.25-gentoo-r5 x86_64
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nagios-core/ChangeLog8
-rw-r--r--net-analyzer/nagios-core/nagios-core-3.0.3.ebuild219
-rw-r--r--net-analyzer/nagios/ChangeLog8
-rw-r--r--net-analyzer/nagios/nagios-3.0.3.ebuild54
4 files changed, 287 insertions, 2 deletions
diff --git a/net-analyzer/nagios-core/ChangeLog b/net-analyzer/nagios-core/ChangeLog
index a56f4f75d715..c8115c8fa188 100644
--- a/net-analyzer/nagios-core/ChangeLog
+++ b/net-analyzer/nagios-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/nagios-core
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/ChangeLog,v 1.125 2008/05/23 19:24:14 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/ChangeLog,v 1.126 2008/06/25 18:39:54 dertobi123 Exp $
+
+*nagios-core-3.0.3 (25 Jun 2008)
+
+ 25 Jun 2008; Tobias Scherbaum <dertobi123@gentoo.org>
+ +nagios-core-3.0.3.ebuild:
+ Version bump
23 May 2008; Tobias Scherbaum <dertobi123@gentoo.org>
nagios-core-3.0.2.ebuild:
diff --git a/net-analyzer/nagios-core/nagios-core-3.0.3.ebuild b/net-analyzer/nagios-core/nagios-core-3.0.3.ebuild
new file mode 100644
index 000000000000..842ede5fed4b
--- /dev/null
+++ b/net-analyzer/nagios-core/nagios-core-3.0.3.ebuild
@@ -0,0 +1,219 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-3.0.3.ebuild,v 1.1 2008/06/25 18:39:54 dertobi123 Exp $
+
+EAPI="1"
+
+inherit eutils depend.apache toolchain-funcs
+
+MY_P=${PN/-core}-${PV}
+DESCRIPTION="Nagios Core - Check daemon, CGIs, docs"
+HOMEPAGE="http://www.nagios.org/"
+SRC_URI="mirror://sourceforge/nagios/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug lighttpd perl +web vim-syntax"
+DEPEND="virtual/mailx
+ web? (
+ >=media-libs/jpeg-6b-r3
+ >=media-libs/libpng-1.2.5-r4
+ >=media-libs/gd-1.8.3-r5
+ lighttpd? ( www-servers/lighttpd )
+ )
+ perl? ( >=dev-lang/perl-5.6.1-r7 )"
+RDEPEND="${DEPEND}
+ vim-syntax? ( app-vim/nagios-syntax )"
+
+want_apache2
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ # Check if gd has been compiled with jpeg and png support
+ if use web; then
+ if ! built_with_use media-libs/gd jpeg png; then
+ eerror "Your gd has been compiled without jpeg and/or png support."
+ eerror "Please re-emerge gd:"
+ eerror "# USE="jpeg png" emerge gd"
+ die "pkg_setup failed"
+ fi
+ fi
+
+ enewgroup nagios
+ enewuser nagios -1 /bin/bash /var/nagios/home nagios
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ local strip="$(echo '$(MAKE) strip-post-install')"
+ sed -i -e "s:${strip}::" {cgi,base}/Makefile.in || die "sed failed in Makefile.in"
+}
+
+src_compile() {
+ local myconf
+
+ if use perl ; then
+ myconf="${myconf} --enable-embedded-perl --with-perlcache"
+ fi
+
+ if use debug; then
+ myconf="${myconf} --enable-DEBUG0"
+ myconf="${myconf} --enable-DEBUG1"
+ myconf="${myconf} --enable-DEBUG2"
+ myconf="${myconf} --enable-DEBUG3"
+ myconf="${myconf} --enable-DEBUG4"
+ myconf="${myconf} --enable-DEBUG5"
+ fi
+
+ if use !apache2 && use !lighttpd ; then
+ myconf="${myconf} --with-command-grp=nagios"
+ else
+ if use apache2 ; then
+ myconf="${myconf} --with-command-grp=apache"
+ myconf="${myconf} --with-httpd-conf=/etc/apache2/conf.d"
+ elif use lighttpd ; then
+ myconf="${myconf} --with-command-grp=lighttpd"
+ fi
+ fi
+
+ econf ${myconf} \
+ --prefix=/usr \
+ --bindir=/usr/sbin \
+ --sbindir=/usr/$(get_libdir)/nagios/cgi-bin \
+ --datadir=/usr/share/nagios/htdocs \
+ --localstatedir=/var/nagios \
+ --sysconfdir=/etc/nagios \
+ --libexecdir=/usr/$(get_libdir)/nagios/plugins \
+ || die "./configure failed"
+
+ emake CC=$(tc-getCC) nagios || die "make failed"
+
+ if use web ; then
+ # Only compile the CGI's if "web" useflag is set.
+ emake CC=$(tc-getCC) DESTDIR="${D}" cgis || die
+ fi
+}
+
+src_install() {
+ dodoc Changelog INSTALLING LEGAL README UPGRADING
+
+ if ! use web ; then
+ sed -i -e 's/cd $(SRC_CGI) && $(MAKE) $@/# line removed due missing web use flag/' \
+ -e 's/cd $(SRC_HTM) && $(MAKE) $@/# line removed due missing web use flag/' \
+ Makefile
+ fi
+
+ sed -i -e 's/^contactgroups$//g' Makefile
+
+ emake DESTDIR="${D}" install
+ emake DESTDIR="${D}" install-config
+ emake DESTDIR="${D}" install-commandmode
+
+ newinitd "${FILESDIR}"/nagios3 nagios
+ newconfd "${FILESDIR}"/conf.d nagios
+
+ # Apache Module
+ if use web ; then
+ if use apache2 ; then
+ insinto "${APACHE_MODULES_CONFDIR}"
+ doins "${FILESDIR}"/99_nagios3.conf
+ elif use lighttpd ; then
+ insinto /etc/lighttpd
+ newins "${FILESDIR}/lighttpd_nagios3.conf" nagios.conf
+ else
+ ewarn "${CATEGORY}/${PF} only supports Apache-2.x or Lighttpd webserver"
+ ewarn "out-of-the-box. Since you are not using one of them, you"
+ ewarn "have to configure your webserver accordingly yourself."
+ fi
+
+ fi
+
+ for dir in etc/nagios var/nagios ; do
+ chown -R nagios:nagios "${D}/${dir}" || die "Failed chown of ${D}/${dir}"
+ done
+
+ chown -R root:root "${D}"/usr/lib/nagios
+ find "${D}"/usr/lib/nagios -type d -print0 | xargs -0 chmod 755
+ find "${D}"/usr/lib/nagios/cgi-bin -type f -print0 | xargs -0 chmod 755
+
+ keepdir /etc/nagios
+ keepdir /var/nagios
+ keepdir /var/nagios/archives
+ keepdir /var/nagios/rw
+ keepdir /var/nagios/spool/checkresults
+
+ if use !apache2 && use !lighttpd; then
+ chown -R nagios:nagios "${D}"/var/nagios/rw || die "Failed chown of ${D}/var/nagios/rw"
+ else
+ if use apache2 ; then
+ chown -R nagios:apache "${D}"/var/nagios/rw || die "Failed chown of ${D}/var/nagios/rw"
+ elif use lighttpd ; then
+ chown -R nagios:lighttpd "${D}"/var/nagios/rw || die "Failed chown of ${D}/var/nagios/rw"
+ fi
+ fi
+
+ chmod ug+s "${D}"/var/nagios/rw || die "Failed Chmod of ${D}/var/nagios/rw"
+ chmod 0750 "${D}"/etc/nagios || die "Failed chmod of ${D}/etc/nagios"
+}
+
+pkg_postinst() {
+ elog "If you want nagios to start at boot time"
+ elog "remember to execute:"
+ elog " rc-update add nagios default"
+ elog
+
+ if use web ; then
+ elog "This does not include cgis that are perl-dependent"
+ elog "Currently traceroute.cgi is perl-dependent"
+ elog "To have ministatus.cgi requires copying of ministatus.c"
+ elog "to cgi directory for compiling."
+
+ elog "Note that the user your webserver is running at needs"
+ elog "read-access to /etc/nagios."
+ elog
+
+ if use apache2 || use lighttpd ; then
+ elog "There are several possible solutions to accomplish this,"
+ elog "choose the one you are most comfortable with:"
+ elog
+ if use apache2 ; then
+ elog " usermod -G nagios apache"
+ elog "or"
+ elog " chown nagios:apache /etc/nagios"
+ elog
+ elog "Also edit /etc/conf.d/apache2 and add \"-D NAGIOS\""
+ elif use lighttpd ; then
+ elog " usermod -G nagios lighttpd "
+ elog "or"
+ elog " chown nagios:lighttpd /etc/nagios"
+ fi
+ elog
+ elog "That will make nagios's web front end visable via"
+ elog "http://localhost/nagios/"
+ elog
+ else
+ elog "IMPORTANT: Do not forget to add the user your webserver"
+ elog "is running as to the nagios group!"
+ fi
+
+ else
+ elog "Please note that you have installed Nagios without web interface."
+ elog "Please don't file any bugs about having no web interface when you do this."
+ elog "Thank you!"
+ fi
+
+ elog
+ elog "If your kernel has /proc protection, nagios"
+ elog "will not be happy as it relies on accessing the proc"
+ elog "filesystem. You can fix this by adding nagios into"
+ elog "the group wheel, but this is not recomended."
+ elog
+}
+
+pkg_prerm() {
+ [[ "${ROOT}" == "/" ]] && /etc/init.d/nagios stop
+}
diff --git a/net-analyzer/nagios/ChangeLog b/net-analyzer/nagios/ChangeLog
index b18a9cf19908..a00f8df2e22a 100644
--- a/net-analyzer/nagios/ChangeLog
+++ b/net-analyzer/nagios/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/nagios
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios/ChangeLog,v 1.70 2008/06/08 16:31:25 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios/ChangeLog,v 1.71 2008/06/25 18:40:41 dertobi123 Exp $
+
+*nagios-3.0.3 (25 Jun 2008)
+
+ 25 Jun 2008; Tobias Scherbaum <dertobi123@gentoo.org>
+ +nagios-3.0.3.ebuild:
+ Version bump
08 Jun 2008; Tobias Scherbaum <dertobi123@gentoo.org> nagios-3.0.2.ebuild:
Add check if we are upgrading from <nagios-3.
diff --git a/net-analyzer/nagios/nagios-3.0.3.ebuild b/net-analyzer/nagios/nagios-3.0.3.ebuild
new file mode 100644
index 000000000000..593820611a73
--- /dev/null
+++ b/net-analyzer/nagios/nagios-3.0.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios/nagios-3.0.3.ebuild,v 1.1 2008/06/25 18:40:41 dertobi123 Exp $
+
+DESCRIPTION="The Nagios metapackage - merge this to pull install all of the
+nagios packages"
+HOMEPAGE="http://www.nagios.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="~net-analyzer/nagios-core-${PV}
+ >=net-analyzer/nagios-plugins-1.4.12-r100
+ >=net-analyzer/nagios-imagepack-1.0-r100"
+
+pkg_setup() {
+ # Avoid upgrading from Nagios <3 as the directory structure has changed
+ if [[ -f /var/lib/init.d/started/nagios ]] ; then
+ if has_version '<net-analyzer/nagios-3.0' ; then
+ if [[ "${FORCE_UPGRADE}" ]] ; then
+ echo
+ ewarn "you are upgrading from an incompatible version and have"
+ ewarn "FORCE_UPGRADE set, will build this package while Nagios is running."
+ echo
+ else
+ echo
+ eerror "You are upgrading from an incompatible version."
+ eerror "Please be advised that installation paths have changed to a more FHS"
+ eerror "compliant structure and you won't be able to easily upgrade to"
+ eerror "Nagios 3 therefore. You will have to change your configuration"
+ eerror "to reflect this change, for example Nagios plugins are now installed"
+ eerror "into /usr/$(get_libdir)/nagios/plugins/ instead of /usr/nagios/libexec."
+ echo
+ eerror "If you want to upgrade now, emerge nagios with:"
+ eerror " FORCE_UPGRADE=1 emerge nagios"
+ die "Upgrading from an incompatible version!"
+ echo
+ fi
+ fi
+ fi
+}
+
+pkg_postrm() {
+ elog "Note: this is a META ebuild for ${P}."
+ elog "to remove it completely or before re-emerging"
+ elog "either use 'depclean', or remove/re-emerge these packages:"
+ elog
+ for dep in ${RDEPEND}; do
+ elog " ${dep}"
+ done
+ echo
+}