summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-10 04:52:46 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-10 04:52:46 +0000
commitb8cbc13fb7742ae8665247c55221becfa41e7f5f (patch)
tree5e6a8c70cbc922afab7c667580c3799635ba7a15 /net-analyzer
parentMarked stable on mips. (diff)
downloadhistorical-b8cbc13fb7742ae8665247c55221becfa41e7f5f.tar.gz
historical-b8cbc13fb7742ae8665247c55221becfa41e7f5f.tar.bz2
historical-b8cbc13fb7742ae8665247c55221becfa41e7f5f.zip
add telnet support #47301
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/netcat/ChangeLog12
-rw-r--r--net-analyzer/netcat/files/digest-netcat-110-r53
-rw-r--r--net-analyzer/netcat/netcat-110-r5.ebuild52
3 files changed, 64 insertions, 3 deletions
diff --git a/net-analyzer/netcat/ChangeLog b/net-analyzer/netcat/ChangeLog
index afb1c617644a..cdc731777b14 100644
--- a/net-analyzer/netcat/ChangeLog
+++ b/net-analyzer/netcat/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-analyzer/netcat
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netcat/ChangeLog,v 1.21 2004/02/21 05:47:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netcat/ChangeLog,v 1.22 2004/04/10 04:52:45 vapier Exp $
+
+*netcat-110-r5 (10 Apr 2004)
+
+ 10 Apr 2004; Mike Frysinger <vapier@gentoo.org> :
+ Add -DTELNET to compile flags to have netcat compile w/telnet (-t)
+ support #47301 by Michael Leuchtenburg.
+
+*netcat-110-r4 (21 Aug 2003)
21 Feb 2004; Mike Frysinger <vapier@gentoo.org> :
Add local use flag to control GAPING_SECURITY_HOLE #41843 by Mitchell.
@@ -13,8 +21,6 @@
SRC_URI update, thanks to: Scott Alfter <gentoo@salfter.dyndns.org> in bug
#29154
-*netcat-110-r4 (21 Aug 2003)
-
21 Aug 2003; Mike Frysinger <vapier@gentoo.org> :
Grab debian patches to add support for broadcasting and -q #24236.
Had to redo a few deb patches since we also use ipv6 patch ... thats
diff --git a/net-analyzer/netcat/files/digest-netcat-110-r5 b/net-analyzer/netcat/files/digest-netcat-110-r5
new file mode 100644
index 000000000000..909dbf020d41
--- /dev/null
+++ b/net-analyzer/netcat/files/digest-netcat-110-r5
@@ -0,0 +1,3 @@
+MD5 402632f2fe01c169ff19a0ad6e9d608c nc110.tgz 75267
+MD5 84d850745dd860aedce64b518e0e3330 nc-v6-20000918.patch.gz 8740
+MD5 67eb99f4d005b7f2210f1731636de4a2 netcat-110-deb-patches.tbz2 8457
diff --git a/net-analyzer/netcat/netcat-110-r5.ebuild b/net-analyzer/netcat/netcat-110-r5.ebuild
new file mode 100644
index 000000000000..3ba3758fd7b9
--- /dev/null
+++ b/net-analyzer/netcat/netcat-110-r5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/netcat/netcat-110-r5.ebuild,v 1.1 2004/04/10 04:52:45 vapier Exp $
+
+inherit eutils gcc
+
+MY_P=nc${PV}
+DESCRIPTION="A network piping program"
+HOMEPAGE="http://www.atstake.com/research/tools/network_utilities/"
+SRC_URI="http://www.atstake.com/research/tools/network_utilities/${MY_P}.tgz
+ ipv6?( ftp://sith.mimuw.edu.pl/pub/users/baggins/IPv6/nc-v6-20000918.patch.gz )
+ mirror://gentoo/${P}-deb-patches.tbz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86 ppc sparc alpha hppa amd64"
+IUSE="ipv6 static GAPING_SECURITY_HOLE"
+
+DEPEND="virtual/glibc"
+
+S=${WORKDIR}/nc-${PV}
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unpack ${MY_P}.tgz
+ unpack ${P}-deb-patches.tbz2
+ use ipv6 \
+ && epatch ${DISTDIR}/nc-v6-20000918.patch.gz && rm deb-patches/*_noipv6.patch \
+ || rm deb-patches/*_ipv6.patch
+ EPATCH_SUFFIX="patch"
+ epatch ${S}/deb-patches/
+ echo "#define arm arm_timer" >> generic.h
+ sed -i 's:#define HAVE_BIND:#undef HAVE_BIND:' netcat.c
+ sed -i 's:#define FD_SETSIZE 16:#define FD_SETSIZE 1024:' netcat.c #34250
+}
+
+src_compile() {
+ export XFLAGS="-DLINUX -DTELNET"
+ use ipv6 && XFLAGS="${XFLAGS} -DINET6"
+ use static && export STATIC="-static"
+ use GAPING_SECURITY_HOLE && XFLAGS="${XFLAGS} -DGAPING_SECURITY_HOLE"
+ CC="$(gcc-getCC) ${CFLAGS}" make -e nc || die
+}
+
+src_install() {
+ dobin nc || die "dobin failed"
+ dodoc README README.Debian netcat.blurb
+ doman nc.1
+ docinto scripts
+ dodoc scripts/*
+}