summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-07-28 16:03:07 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-07-28 16:03:07 +0000
commitc5a22517919f759c07469e0cd83697c916a02845 (patch)
tree0ccb820ecfadd942a37657f4c7e1a7ac3809c5fe /net-analyzer
parentInitial import. (diff)
downloadhistorical-c5a22517919f759c07469e0cd83697c916a02845.tar.gz
historical-c5a22517919f759c07469e0cd83697c916a02845.tar.bz2
historical-c5a22517919f759c07469e0cd83697c916a02845.zip
Version bump
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nmap/ChangeLog8
-rw-r--r--net-analyzer/nmap/files/digest-nmap-2.99_rc11
-rw-r--r--net-analyzer/nmap/nmap-2.99_rc1.ebuild49
3 files changed, 57 insertions, 1 deletions
diff --git a/net-analyzer/nmap/ChangeLog b/net-analyzer/nmap/ChangeLog
index 319609108388..ab4e5e0ef78b 100644
--- a/net-analyzer/nmap/ChangeLog
+++ b/net-analyzer/nmap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/nmap
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.5 2002/07/19 20:49:03 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.6 2002/07/28 16:03:07 aliz Exp $
+
+*nmap-2.99_rc1 (28 Jul 2002)
+
+ 28 Jul 2002; Daniel Ahlberg <aliz@gentoo.org> nmap-2.99_rc1.ebuild :
+
+ Version bump. Ebuild contributed by SpanKY <vapier@netzero.com>.
*nmap-2.54_beta37 (19 Jul 2002)
diff --git a/net-analyzer/nmap/files/digest-nmap-2.99_rc1 b/net-analyzer/nmap/files/digest-nmap-2.99_rc1
new file mode 100644
index 000000000000..9a78a28aac5c
--- /dev/null
+++ b/net-analyzer/nmap/files/digest-nmap-2.99_rc1
@@ -0,0 +1 @@
+MD5 ea5dd423ccbd3a8ae54eb60c80d52fa0 nmap-2.99RC1.tgz 922315
diff --git a/net-analyzer/nmap/nmap-2.99_rc1.ebuild b/net-analyzer/nmap/nmap-2.99_rc1.ebuild
new file mode 100644
index 000000000000..ca4eb10e80e9
--- /dev/null
+++ b/net-analyzer/nmap/nmap-2.99_rc1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-2.99_rc1.ebuild,v 1.1 2002/07/28 16:03:07 aliz Exp $
+
+MY_P="${P/_rc/RC}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Portscanner"
+SRC_URI="http://www.insecure.org/nmap/dist/${MY_P}.tgz"
+HOMEPAGE="http://www.insecure.org/nmap/"
+DEPEND="virtual/glibc
+ gtk? ( =x11-libs/gtk+-1.2* )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc"
+
+src_compile() {
+ if [ `use ipv6` ]; then
+ econf --enable-ipv6 || die
+ else
+ econf || die
+ fi
+
+ use gtk && ( \
+ make || die
+ ) || (
+ make nmap || die
+ )
+}
+
+src_install() {
+ local myinst
+
+ # If gnome does not exist on the system, there is no need for the gnome
+ # menu item.
+ use gnome || myinst="${myinst} deskdir=${S}"
+
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ nmapdatadir=${D}/usr/share/nmap \
+ install || die
+
+ dodoc CHANGELOG COPYING HACKING README*
+ cd docs
+ dodoc *.txt
+ dohtml *.html
+}
+