summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2008-01-06 02:09:09 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2008-01-06 02:09:09 +0000
commit1bb8d0dc3d0a8726cef462d4edda1ac368f74bb9 (patch)
treeb07b1c9f1be93505a011170c61ca7eabee4ad287 /net-dialup/fcusb/fcusb-0.1.ebuild
parentremoved old ebuild, all drivers have their own package now (diff)
downloadhistorical-1bb8d0dc3d0a8726cef462d4edda1ac368f74bb9.tar.gz
historical-1bb8d0dc3d0a8726cef462d4edda1ac368f74bb9.tar.bz2
historical-1bb8d0dc3d0a8726cef462d4edda1ac368f74bb9.zip
using special openSUSE repository for AVM drivers from now on.
Package-Manager: portage-2.1.4_rc14
Diffstat (limited to 'net-dialup/fcusb/fcusb-0.1.ebuild')
-rw-r--r--net-dialup/fcusb/fcusb-0.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-dialup/fcusb/fcusb-0.1.ebuild b/net-dialup/fcusb/fcusb-0.1.ebuild
new file mode 100644
index 000000000000..ef32f798a73b
--- /dev/null
+++ b/net-dialup/fcusb/fcusb-0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcusb/fcusb-0.1.ebuild,v 1.1 2008/01/06 02:02:49 sbriesen Exp $
+
+inherit eutils rpm linux-mod
+
+DESCRIPTION="AVM kernel 2.6 modules for Fritz!Card USB"
+HOMEPAGE="http://opensuse.foehr-it.de/"
+SRC_URI="http://opensuse.foehr-it.de/rpms/10_3/src/${P}-0.src.rpm"
+
+LICENSE="AVM-FC"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="!net-dialup/fritzcapi"
+RDEPEND="${DEPEND} net-dialup/capi4k-utils"
+
+S="${WORKDIR}/fritz"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if ! kernel_is 2 6; then
+ die "This package works only with 2.6 kernel!"
+ fi
+
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="KDIR=${KV_DIR} LIBDIR=${S}/src"
+ MODULE_NAMES="${PN}(net:${S}/src)"
+}
+
+src_unpack() {
+ rpm_unpack "${DISTDIR}/${A}" || die "failed to unpack ${A} file"
+ DISTDIR="${WORKDIR}" unpack ${PN}-suse[0-9][0-9]-[0-9].[0-9]*-[0-9]*.tar.gz
+
+ cd "${S}"
+ epatch $(sed -n "s|^Patch[01234]:\s*\(.*\)|../\1|p" ../${PN}.spec)
+ convert_to_m "src/Makefile"
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc CAPI*.txt
+ dohtml *.html
+}