summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2006-02-10 21:41:28 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2006-02-10 21:41:28 +0000
commit8960b55c268ecd5a5bc1e13cb56048b34f1f480a (patch)
tree083d3716481ab85489548a3d04d34a33611abc65 /net-dialup/itund/itund-0.3.1.ebuild
parentimmediate stable bump because both the stable and unstable version are horrib... (diff)
downloadhistorical-8960b55c268ecd5a5bc1e13cb56048b34f1f480a.tar.gz
historical-8960b55c268ecd5a5bc1e13cb56048b34f1f480a.tar.bz2
historical-8960b55c268ecd5a5bc1e13cb56048b34f1f480a.zip
version bump.
Package-Manager: portage-2.1_pre4-r1
Diffstat (limited to 'net-dialup/itund/itund-0.3.1.ebuild')
-rw-r--r--net-dialup/itund/itund-0.3.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-dialup/itund/itund-0.3.1.ebuild b/net-dialup/itund/itund-0.3.1.ebuild
new file mode 100644
index 000000000000..6df54dc645ae
--- /dev/null
+++ b/net-dialup/itund/itund-0.3.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/itund/itund-0.3.1.ebuild,v 1.1 2006/02/10 21:41:28 sbriesen Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="ItunD (ISDN tunnel Daemon) provides a network tunnel over ISDN lines using CAPI"
+HOMEPAGE="http://sourceforge.net/projects/itund/"
+SRC_URI="mirror://sourceforge/itund/${P}.tgz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+DEPEND="sys-libs/zlib
+ net-dialup/capi4k-utils"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # patch Makefile to use our CFLAGS
+ sed -i -e "s:^\(CFLAGS=.*\) -O2 :\1 ${CFLAGS} :g" Makefile
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ dosbin itund
+ dodoc CHANGES README
+}