summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2005-04-24 13:37:58 +0000
committerStefan Schweizer <genstef@gentoo.org>2005-04-24 13:37:58 +0000
commitb008c4779abba797b5b2ae14b6ee423b6fa84c21 (patch)
tree7507d90fcb910aa6ab102ea37c7180d5b135a92e /net-dialup
parentbump (diff)
downloadhistorical-b008c4779abba797b5b2ae14b6ee423b6fa84c21.tar.gz
historical-b008c4779abba797b5b2ae14b6ee423b6fa84c21.tar.bz2
historical-b008c4779abba797b5b2ae14b6ee423b6fa84c21.zip
New ebuild for the experimental mISDN driver, thanks to sbriesen and strafbomber for testing
Package-Manager: portage-1.586-cvs
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/misdn/ChangeLog12
-rw-r--r--net-dialup/misdn/Manifest6
-rw-r--r--net-dialup/misdn/files/change-pci_find_subsys-to-pci_get_subsys.patch12
-rw-r--r--net-dialup/misdn/files/digest-misdn-200504091
-rw-r--r--net-dialup/misdn/files/misdn.modulesd85
-rw-r--r--net-dialup/misdn/metadata.xml5
-rw-r--r--net-dialup/misdn/misdn-20050409.ebuild95
7 files changed, 216 insertions, 0 deletions
diff --git a/net-dialup/misdn/ChangeLog b/net-dialup/misdn/ChangeLog
new file mode 100644
index 000000000000..a9af69b39b99
--- /dev/null
+++ b/net-dialup/misdn/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for net-dialup/misdn
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/misdn/ChangeLog,v 1.1 2005/04/24 13:37:58 genstef Exp $
+
+*misdn-20050409 (24 Apr 2005)
+
+ 24 Apr 2005; Stefan Schweizer <genstef@gentoo.org>
+ +files/change-pci_find_subsys-to-pci_get_subsys.patch,
+ +files/misdn.modulesd, +metadata.xml, +misdn-20050409.ebuild:
+ New ebuild for the experimental mISDN driver, thanks to sbriesen and
+ strafbomber for testing
+
diff --git a/net-dialup/misdn/Manifest b/net-dialup/misdn/Manifest
new file mode 100644
index 000000000000..4651e8be6b09
--- /dev/null
+++ b/net-dialup/misdn/Manifest
@@ -0,0 +1,6 @@
+MD5 1788ac55437d5f1f6753542295913557 misdn-20050409.ebuild 3316
+MD5 5ff7285519eb3a1b5484dbe47b60c07e ChangeLog 509
+MD5 ec2f84816306825d125d0c01bd86758d metadata.xml 163
+MD5 faca61b6fa6c40a64ed122df59ab7a7d files/misdn.modulesd 2404
+MD5 591b7a0690f210221ae79ac9f1ae5633 files/change-pci_find_subsys-to-pci_get_subsys.patch 919
+MD5 9b0b0d0760eb4e9f26bd420c16a1dc5d files/digest-misdn-20050409 73
diff --git a/net-dialup/misdn/files/change-pci_find_subsys-to-pci_get_subsys.patch b/net-dialup/misdn/files/change-pci_find_subsys-to-pci_get_subsys.patch
new file mode 100644
index 000000000000..60631b5fded8
--- /dev/null
+++ b/net-dialup/misdn/files/change-pci_find_subsys-to-pci_get_subsys.patch
@@ -0,0 +1,12 @@
+diff -upr mISDN-CVS-2005-04-09.orig/drivers/isdn/hardware/mISDN/hfc_multi.c mISDN-CVS-2005-04-09/drivers/isdn/hardware/mISDN/hfc_multi.c
+--- mISDN-CVS-2005-04-09.orig/drivers/isdn/hardware/mISDN/hfc_multi.c 2005-04-24 12:54:38.000000000 +0200
++++ mISDN-CVS-2005-04-09/drivers/isdn/hardware/mISDN/hfc_multi.c 2005-04-24 12:54:55.000000000 +0200
+@@ -2799,7 +2799,7 @@ setup_pci(hfc_multi_t *hc)
+ if (debug & DEBUG_HFCMULTI_INIT)
+ printk(KERN_DEBUG "setup_pci(): investigating card entry %d (looking for type %d)\n", i, hc->type);
+ inuse:
+- tmp_dev = pci_find_subsys(id_list[i].vendor_id, id_list[i].device_id, id_list[i].vendor_sub, id_list[i].device_sub, tmp_dev);
++ tmp_dev = pci_get_subsys(id_list[i].vendor_id, id_list[i].device_id, id_list[i].vendor_sub, id_list[i].device_sub, tmp_dev);
+ if (tmp_dev) {
+ /* skip if already in use */
+ list_for_each_entry_safe(hc_tmp, next, &HFCM_obj.ilist, list) {
diff --git a/net-dialup/misdn/files/digest-misdn-20050409 b/net-dialup/misdn/files/digest-misdn-20050409
new file mode 100644
index 000000000000..a7f37b0a3c11
--- /dev/null
+++ b/net-dialup/misdn/files/digest-misdn-20050409
@@ -0,0 +1 @@
+MD5 c12e84e162054a090250648eef318723 mISDN-CVS-2005-04-09.tar.bz2 256956
diff --git a/net-dialup/misdn/files/misdn.modulesd b/net-dialup/misdn/files/misdn.modulesd
new file mode 100644
index 000000000000..5a358d04a730
--- /dev/null
+++ b/net-dialup/misdn/files/misdn.modulesd
@@ -0,0 +1,85 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/misdn/files/misdn.modulesd,v 1.1 2005/04/24 13:37:58 genstef Exp $
+
+# Options for the mISDN card drivers
+#
+# There's currently no documentation available. You should check
+# the comments in the source code for available parameters and
+# the possible values.
+#
+options avmfritz protocol=2
+options hfcpci protocol=2
+options hfcsusb protocol=2
+options hfcmulti protocol=2
+options sedlfax protocol=2
+options w6692pci protocol=2
+
+# mISDN framework
+install mISDN \
+/sbin/modprobe mISDN_core && \
+/sbin/modprobe mISDN_l1 && \
+/sbin/modprobe mISDN_l2 && \
+/sbin/modprobe l3udss1 && \
+/sbin/modprobe mISDN_capi && \
+/sbin/modprobe mISDN_x25dte
+remove mISDN \
+/sbin/modprobe -r mISDN_x25dte && \
+/sbin/modprobe -r mISDN_capi && \
+/sbin/modprobe -r l3udss1 && \
+/sbin/modprobe -r mISDN_l2 && \
+/sbin/modprobe -r mISDN_l1 && \
+/sbin/modprobe -r mISDN_core
+
+# Colognechip HFC PCI
+install hfcpci \
+/sbin/modprobe mISDN && \
+/sbin/modprobe --ignore-install hfcpci
+remove hfcpci \
+/sbin/modprobe -r --ignore-remove hfcpci && \
+/sbin/modprobe -r mISDN
+
+# Colognechip HFC-S USB
+install hfcsusb \
+/sbin/modprobe mISDN && \
+/sbin/modprobe --ignore-install hfcsusb
+remove hfcsusb \
+/sbin/modprobe -r --ignore-remove hfcsusb && \
+/sbin/modprobe -r mISDN
+
+# Colognechip HFC-4S / HFC-8S / HFC-E1
+install hfcmulti \
+/sbin/modprobe mISDN && \
+/sbin/modprobe --ignore-install hfcmulti
+remove hfcmulti \
+/sbin/modprobe -r --ignore-remove hfcmulti && \
+/sbin/modprobe -r mISDN
+
+# AVM Fritz!PCI and ISA PnP
+install avmfritz \
+/sbin/modprobe mISDN && \
+/sbin/modprobe --ignore-install avmfritz
+remove avmfritz \
+/sbin/modprobe -r --ignore-remove avmfritz && \
+/sbin/modprobe -r mISDN
+
+# Sedlbauer Speedfax+
+# Important: For the sedlbauer speed fax+ to work properly
+# you have to download the firmware 'ISAR.BIN' onto the card.
+install sedlfax \
+/sbin/modprobe mISDN && \
+/sbin/modprobe faxl3 && \
+/sbin/modprobe --ignore-install sedlfax
+remove sedlfax \
+/sbin/modprobe -r --ignore-remove sedlfax && \
+/sbin/modprobe -r faxl3 && \
+/sbin/modprobe -r mISDN
+
+# Winbond W6692 PCI
+install w6692pci \
+/sbin/modprobe mISDN && \
+/sbin/modprobe --ignore-install w6692pci
+remove w6692pci \
+/sbin/modprobe -r --ignore-remove w6692pci && \
+/sbin/modprobe -r mISDN
+
diff --git a/net-dialup/misdn/metadata.xml b/net-dialup/misdn/metadata.xml
new file mode 100644
index 000000000000..1e11e7bbd01b
--- /dev/null
+++ b/net-dialup/misdn/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-dialup</herd>
+</pkgmetadata>
diff --git a/net-dialup/misdn/misdn-20050409.ebuild b/net-dialup/misdn/misdn-20050409.ebuild
new file mode 100644
index 000000000000..2004abb27577
--- /dev/null
+++ b/net-dialup/misdn/misdn-20050409.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/misdn/misdn-20050409.ebuild,v 1.1 2005/04/24 13:37:58 genstef Exp $
+
+inherit eutils linux-mod
+
+MY_P=mISDN-CVS-${PV:0:4}-${PV:4:2}-${PV:6:2}
+DESCRIPTION="mISDN (modular ISDN) is the new ISDN stack of the linux kernel version 2.6."
+HOMEPAGE="http://www.isdn4linux.de/mISDN"
+SRC_URI="ftp://ftp.isdn4linux.de/pub/isdn4linux/CVS-Snapshots/${MY_P}.tar.bz2
+ ftp://linux.mathematik.tu-darmstadt.de/pub/linux/mirrors/misc/isdn4linux/CVS-Snapshots/${MY_P}.tar.bz2
+ ftp://ftp.cs.tu-berlin.de/pub/net/isdn/isdn4linux/CVS-Snapshots/${MY_P}.tar.bz2
+ ftp://ftp.gwdg.de/pub/linux/isdn/isdn4linux/CVS-Snapshots/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RDEPEND=">=net-dialup/capi4k-utils-20050322-r1"
+S=${WORKDIR}/${MY_P}/drivers/isdn/hardware/mISDN/
+
+MISDN_MODULES=("avmfritz" "hfcpci" "hfcmulti" "hfcsusb" "sedlfax" "w6692pci")
+MISDN_KCONFIG=("AVM_FRITZ" "HFCPCI" "HFCMULTI" "HFCUSB" "SPEEDFAX" "W6692" )
+
+pkg_setup() {
+ CONFIG_CHECK="ISDN_CAPI ISDN_CAPI_CAPI20 ISDN_CAPI_CAPIFS_BOOL"
+ linux-mod_pkg_setup
+ MODULE_NAMES="mISDN_capi(net:) mISDN_dtmf(net:) mISDN_l1(net:)
+ mISDN_x25dte(net:) l3udss1(net:) mISDN_core(net:) mISDN_isac(net:)
+ mISDN_l2(net:) faxl3(net:) mISDN_dsp(net:)"
+ BUILD_PARAMS="-C ${KV_DIR} SUBDIRS=${S} EXTRA_CFLAGS=-I${WORKDIR}/${MY_P}/include CONFIG_MISDN_DRV=m CONFIG_MISDN_DSP=y"
+ BUILD_TARGETS="modules"
+ #I4LmISDN(net:) does not compile :( CONFIG_I4L_CAPI_LAYER=m
+ # the i4l->capi simulation seems to be only for kernel 2.4
+
+ if [ -n "${MISDN_CARDS}" ]; then
+ #Check existence of user selected cards
+ for USERCARD in ${MISDN_CARDS} ; do
+ for ((CARD=0; CARD < ${#MISDN_MODULES[*]}; CARD++)); do
+ if [ "${USERCARD}" = "${MISDN_MODULES[CARD]}" ]; then
+ MODULE_NAMES="${MODULE_NAMES} ${MISDN_MODULES[CARD]}(net:)"
+ BUILD_PARAMS="${BUILD_PARAMS} CONFIG_MISDN_${MISDN_KCONFIG[CARD]}=y"
+ continue 2
+ fi
+ done
+ die "Module ${USERCARD} not present in ${P}"
+ done
+ else
+ einfo
+ einfo "You can control the modules which are built with the variable"
+ einfo "MISDN_CARDS which should contain a blank separated list"
+ einfo "of a selection from the following cards:"
+ einfo " ${MISDN_MODULES[*]}"
+ einfo
+ ewarn "I give you the chance of hitting Ctrl-C and make the necessary"
+ ewarn "adjustments in /etc/make.conf."
+
+ # enable everything
+ for ((CARD=0; CARD < ${#MISDN_MODULES[*]}; CARD++)); do
+ MODULE_NAMES="${MODULE_NAMES} ${MISDN_MODULES[CARD]}(net:)"
+ BUILD_PARAMS="${BUILD_PARAMS} CONFIG_MISDN_${MISDN_KCONFIG[CARD]}=y"
+ done
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${MY_P}
+ kernel_is ge 2 6 10 && epatch ${FILESDIR}/change-pci_find_subsys-to-pci_get_subsys.patch
+}
+
+src_compile() {
+ mv Makefile.v2.6 Makefile
+ linux-mod_src_compile
+}
+
+src_install() {
+ linux-mod_src_install
+
+ insinto /etc/modules.d
+ newins ${FILESDIR}/misdn.modulesd misdn
+
+ dodoc Kconfig.v2.6
+}
+
+pkg_postinst() {
+ update_depmod
+ update_modules
+
+ ewarn
+ ewarn "This driver is still under heavy development"
+ ewarn "Please report ebuild related bugs / wishes to http://bugs.gentoo.org"
+ ewarn "Please report driver bugs to the mISDN mailing-list:"
+ ewarn " https://www.isdn4linux.de/mailman/listinfo/isdn4linux"
+}