summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2004-11-24 06:04:45 +0000
committerAlin Năstac <mrness@gentoo.org>2004-11-24 06:04:45 +0000
commitc3355279dab3cdbbc49255a1fb2b02b52b78bc10 (patch)
tree1e2628d55502b5a97602aa9111afafb160a88985 /net-dialup
parentAdded ~sparc keyword. (diff)
downloadhistorical-c3355279dab3cdbbc49255a1fb2b02b52b78bc10.tar.gz
historical-c3355279dab3cdbbc49255a1fb2b02b52b78bc10.tar.bz2
historical-c3355279dab3cdbbc49255a1fb2b02b52b78bc10.zip
initial import from #71845
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/capifwd/ChangeLog11
-rw-r--r--net-dialup/capifwd/Manifest17
-rw-r--r--net-dialup/capifwd/capifwd-0.6.3.ebuild39
-rw-r--r--net-dialup/capifwd/files/capifwd-0.6.3.patch31
-rw-r--r--net-dialup/capifwd/files/capifwd.conf6
-rw-r--r--net-dialup/capifwd/files/capifwd.init22
-rw-r--r--net-dialup/capifwd/files/digest-capifwd-0.6.31
-rw-r--r--net-dialup/capifwd/metadata.xml6
8 files changed, 133 insertions, 0 deletions
diff --git a/net-dialup/capifwd/ChangeLog b/net-dialup/capifwd/ChangeLog
new file mode 100644
index 000000000000..7999313fe58b
--- /dev/null
+++ b/net-dialup/capifwd/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-dialup/capifwd
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/capifwd/ChangeLog,v 1.1 2004/11/24 06:04:45 mrness Exp $
+
+*capifwd-0.6.3 (24 Nov 2004)
+
+ 24 Nov 2004; Alin Nastac <mrness@gentoo.org> +metadata.xml,
+ +files/capifwd-0.6.3.patch, +files/capifwd.conf, +files/capifwd.init,
+ +capifwd-0.6.3.ebuild:
+ Initial import from #71845, thanks to Stefan Briesenick <sbriesen@gmx.de>.
+
diff --git a/net-dialup/capifwd/Manifest b/net-dialup/capifwd/Manifest
new file mode 100644
index 000000000000..a58a3cf31e12
--- /dev/null
+++ b/net-dialup/capifwd/Manifest
@@ -0,0 +1,17 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 712eaef702847f2ff7e01bf2ffc19be2 capifwd-0.6.3.ebuild 1045
+MD5 d2acf377c86761937a704f2455f1e353 metadata.xml 255
+MD5 833786ffba14f3f0949593ecb6fcd194 ChangeLog 476
+MD5 c285576667acfe2e958402cd0d600ad7 files/digest-capifwd-0.6.3 65
+MD5 3e3512b77612880bfe174bee8870e609 files/capifwd-0.6.3.patch 1057
+MD5 d9ba73a7ed9b8ec964aa75ce3890da52 files/capifwd.init 552
+MD5 449537e26587ce2daaf23629bcad366a files/capifwd.conf 255
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.6 (GNU/Linux)
+
+iD8DBQFBpCSIjtv59x0+BrURAjLZAJ9FagUFz0RikDdjHzbZQqA4wSR8qgCgxPSd
+f3uGY6fmv7r+L1AzvMxDupA=
+=CJlY
+-----END PGP SIGNATURE-----
diff --git a/net-dialup/capifwd/capifwd-0.6.3.ebuild b/net-dialup/capifwd/capifwd-0.6.3.ebuild
new file mode 100644
index 000000000000..58a96c44bc99
--- /dev/null
+++ b/net-dialup/capifwd/capifwd-0.6.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/capifwd/capifwd-0.6.3.ebuild,v 1.1 2004/11/24 06:04:45 mrness Exp $
+
+inherit eutils
+
+DESCRIPTION="A daemon forwarding CAPI messages to capi20proxy clients"
+HOMEPAGE="http://capi20proxy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/capi20proxy/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="net-dialup/capi4k-utils"
+
+S="${WORKDIR}/linux-server"
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S}
+ epatch "${FILESDIR}/${P}.patch"
+
+ #Replace obsolete sys_errlist with strerror
+ sed -i -e 's:sys_errlist *\[ *errno *\]:strerror(errno):' \
+ src/capifwd.c src/capi/waitforsignal.c src/auth/auth.c || \
+ die "failed to replace sys_errlist"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+ dodoc AUTHORS ChangeLog README
+
+ # install init-script
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/capifwd.init capifwd
+ insinto /etc/conf.d
+ newins ${FILESDIR}/capifwd.conf capifwd
+}
diff --git a/net-dialup/capifwd/files/capifwd-0.6.3.patch b/net-dialup/capifwd/files/capifwd-0.6.3.patch
new file mode 100644
index 000000000000..e2235fab66d9
--- /dev/null
+++ b/net-dialup/capifwd/files/capifwd-0.6.3.patch
@@ -0,0 +1,31 @@
+--- src/config/cmdline.c.orig 2002-12-29 16:41:02.000000000 +0100
++++ src/config/cmdline.c 2004-11-20 02:01:38.821706921 +0100
+@@ -57,17 +57,17 @@
+ else if ( !strcmp("-v",argv[i]) || !strcmp("-h",argv[1]) ||
+ !strcmp("--version", argv[1]) || !strcmp("--help", argv[i]) )
+ {
+- printf("
+-%s version %s
+-Copyright (C) 2002: F. Lindenberg, A. Szalkowski
+-Usage:
+-\t%s [options]\n\n Where options is one of:
+--h --help or
+--v --version\tprint this info and quit.
+--f --file\tdefine the configuration file (makes no
+-\t\tsense without config file support).
+--p --port\tdefine the port number.
+-", _progname_long, _version, argv[0]);
++ printf(
++"%s version %s\n"
++"Copyright (C) 2002: F. Lindenberg, A. Szalkowski\n"
++"Usage:\n"
++"\t%s [options]\n\n Where options is one of:\n"
++"-h --help or\n"
++"-v --version\tprint this info and quit.\n"
++"-f --file\tdefine the configuration file (makes no\n"
++"\t\tsense without config file support).\n"
++"-p --port\tdefine the port number.\n\n",
++_progname_long, _version, argv[0]);
+ exit ( 0 );
+ }
+
diff --git a/net-dialup/capifwd/files/capifwd.conf b/net-dialup/capifwd/files/capifwd.conf
new file mode 100644
index 000000000000..6bc3e810d17c
--- /dev/null
+++ b/net-dialup/capifwd/files/capifwd.conf
@@ -0,0 +1,6 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/capifwd/files/capifwd.conf,v 1.1 2004/11/24 06:04:45 mrness Exp $
+
+# define the port number
+PORT=6674
diff --git a/net-dialup/capifwd/files/capifwd.init b/net-dialup/capifwd/files/capifwd.init
new file mode 100644
index 000000000000..29c8d54ec0a4
--- /dev/null
+++ b/net-dialup/capifwd/files/capifwd.init
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/capifwd/files/capifwd.init,v 1.1 2004/11/24 06:04:45 mrness Exp $
+
+opts="start stop"
+
+depend() {
+ need capi
+}
+
+start() {
+ ebegin "Starting capi forwarding daemon"
+ start-stop-daemon --start --quiet --exec /usr/sbin/capifwd -- -p ${PORT}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping capi forwarding daemon"
+ start-stop-daemon --stop --quiet --retry 5 --exec /usr/sbin/capifwd
+ eend $?
+}
diff --git a/net-dialup/capifwd/files/digest-capifwd-0.6.3 b/net-dialup/capifwd/files/digest-capifwd-0.6.3
new file mode 100644
index 000000000000..39f7cf630e60
--- /dev/null
+++ b/net-dialup/capifwd/files/digest-capifwd-0.6.3
@@ -0,0 +1 @@
+MD5 af2e1bd61769a5237b349d85df34ef80 capifwd-0.6.3.tar.bz2 82604
diff --git a/net-dialup/capifwd/metadata.xml b/net-dialup/capifwd/metadata.xml
new file mode 100644
index 000000000000..097c7811abe8
--- /dev/null
+++ b/net-dialup/capifwd/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-dialup</herd>
+<longdescription>A daemon forwarding CAPI messages to capi20proxy clients</longdescription>
+</pkgmetadata>