summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2002-06-29 00:55:03 +0000
committerThilo Bangert <bangert@gentoo.org>2002-06-29 00:55:03 +0000
commitd19f63797573f43ce392be56bf42e6ac3217c32e (patch)
tree1248b0606c23a939a46398eadcce97d8f1223c92 /net-dns/dns2go
parentnew category: net-dns (diff)
downloadhistorical-d19f63797573f43ce392be56bf42e6ac3217c32e.tar.gz
historical-d19f63797573f43ce392be56bf42e6ac3217c32e.tar.bz2
historical-d19f63797573f43ce392be56bf42e6ac3217c32e.zip
new category: net-dns. initial import
Diffstat (limited to 'net-dns/dns2go')
-rw-r--r--net-dns/dns2go/ChangeLog13
-rw-r--r--net-dns/dns2go/dns2go-1.1-r2.ebuild22
-rw-r--r--net-dns/dns2go/files/digest-dns2go-1.1-r21
-rw-r--r--net-dns/dns2go/files/dns2go.rc620
4 files changed, 56 insertions, 0 deletions
diff --git a/net-dns/dns2go/ChangeLog b/net-dns/dns2go/ChangeLog
new file mode 100644
index 000000000000..4bceecb31cc1
--- /dev/null
+++ b/net-dns/dns2go/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for net-dns/dns2go
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dns2go/ChangeLog,v 1.1 2002/06/29 00:55:03 bangert Exp $
+
+*dns2go-1.1-r2 (1 Feb 2002)
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/net-dns/dns2go/dns2go-1.1-r2.ebuild b/net-dns/dns2go/dns2go-1.1-r2.ebuild
new file mode 100644
index 000000000000..d99b64b1a562
--- /dev/null
+++ b/net-dns/dns2go/dns2go-1.1-r2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bart Verwilst <verwilst@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dns2go/dns2go-1.1-r2.ebuild,v 1.1 2002/06/29 00:55:03 bangert Exp $
+
+S=${WORKDIR}/dns2go-1.1-1
+DESCRIPTION="Dns2Go Linux Client v1.1"
+SRC_URI="http://home.planetinternet.be/~felixdv/d2gsetup.tar.gz"
+HOMEPAGE="http://www.dns2go.com"
+SLOT="0"
+
+DEPENDS="virtual/glibc"
+
+src_install() {
+ dobin dns2go
+ doman dns2go.1 dns2go.conf.5
+ dodoc INSTALL README LICENSE
+ mkdir -p ${D}/var/dns2go
+ mkdir -p ${D}/etc/init.d
+ cp ${FILESDIR}/dns2go.rc6 ${D}/etc/init.d/dns2go
+ chmod 755 ${D}/etc/init.d/dns2go
+}
diff --git a/net-dns/dns2go/files/digest-dns2go-1.1-r2 b/net-dns/dns2go/files/digest-dns2go-1.1-r2
new file mode 100644
index 000000000000..a1d183f72ea0
--- /dev/null
+++ b/net-dns/dns2go/files/digest-dns2go-1.1-r2
@@ -0,0 +1 @@
+MD5 16c6ab3279c2c73f519f008bdfd0a8d8 d2gsetup.tar.gz 31718
diff --git a/net-dns/dns2go/files/dns2go.rc6 b/net-dns/dns2go/files/dns2go.rc6
new file mode 100644
index 000000000000..f71251539716
--- /dev/null
+++ b/net-dns/dns2go/files/dns2go.rc6
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# /home/cvsroot/gentoo-x86/net-misc/dns2go/files/dns2go.rc6 $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting DNS2GO"
+ /usr/bin/dns2go
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping DNS2GO"
+ /usr/bin/dns2go -k
+ eend $?
+}