summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Portnoy <avenj@gentoo.org>2004-11-22 16:34:37 +0000
committerJon Portnoy <avenj@gentoo.org>2004-11-22 16:34:37 +0000
commit0d9be766896665e8d4fbddec8e65ebe29bdb971e (patch)
treee972e76c061279495c079eb5a837434927518c2c /net-dns/dnsmasq/dnsmasq-2.18.ebuild
parentFix to use bind-now for suid binaries. Using dobin instead of make install. (diff)
downloadhistorical-0d9be766896665e8d4fbddec8e65ebe29bdb971e.tar.gz
historical-0d9be766896665e8d4fbddec8e65ebe29bdb971e.tar.bz2
historical-0d9be766896665e8d4fbddec8e65ebe29bdb971e.zip
Bump to 2.18, cleanup old ebuilds
Diffstat (limited to 'net-dns/dnsmasq/dnsmasq-2.18.ebuild')
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.18.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-dns/dnsmasq/dnsmasq-2.18.ebuild b/net-dns/dnsmasq/dnsmasq-2.18.ebuild
new file mode 100644
index 000000000000..a74abdb591c5
--- /dev/null
+++ b/net-dns/dnsmasq/dnsmasq-2.18.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.18.ebuild,v 1.1 2004/11/22 16:34:37 avenj Exp $
+
+#inherit eutils
+
+MY_P="${P/_/}"
+MY_PV="${PV/_rc*/}"
+DESCRIPTION="Small forwarding DNS server"
+HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/"
+SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~arm ~amd64 ~ia64 ~s390"
+IUSE=""
+
+RDEPEND="virtual/libc"
+DEPEND=">=sys-apps/sed-4 ${RDEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ make \
+ PREFIX=/usr \
+ MANDIR=/usr/share/man \
+ DESTDIR=${D} \
+ install || die
+ dodoc CHANGELOG FAQ
+ dohtml *.html
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/dnsmasq-init dnsmasq
+ insinto /etc/conf.d
+ newins ${FILESDIR}/dnsmasq.confd dnsmasq
+ insinto /etc
+ newins dnsmasq.conf.example dnsmasq.conf
+}