summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2011-02-24 16:44:26 +0000
committerPatrick McLean <chutzpah@gentoo.org>2011-02-24 16:44:26 +0000
commit6f722fdae1e58d86b81cd74cc2f7c63d0e1b1553 (patch)
tree5d7def6115325fbd187f927086931b5ebaaea9fc /net-dns/dnsmasq/dnsmasq-2.57.ebuild
parentVersion bump with bugfix. (diff)
downloadhistorical-6f722fdae1e58d86b81cd74cc2f7c63d0e1b1553.tar.gz
historical-6f722fdae1e58d86b81cd74cc2f7c63d0e1b1553.tar.bz2
historical-6f722fdae1e58d86b81cd74cc2f7c63d0e1b1553.zip
Version bump, some cleanups suggested by Jan Psota <jasiu@kkfsa.pl>. Remove sed workaround for bug #214865 as the Makefile no longer calls any form of awk.
Package-Manager: portage-2.1.9.41/cvs/Linux x86_64
Diffstat (limited to 'net-dns/dnsmasq/dnsmasq-2.57.ebuild')
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.57.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/net-dns/dnsmasq/dnsmasq-2.57.ebuild b/net-dns/dnsmasq/dnsmasq-2.57.ebuild
new file mode 100644
index 000000000000..c6d019a03518
--- /dev/null
+++ b/net-dns/dnsmasq/dnsmasq-2.57.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.57.ebuild,v 1.1 2011/02/24 16:44:26 chutzpah Exp $
+
+EAPI=2
+
+inherit eutils toolchain-funcs flag-o-matic
+
+MY_P="${P/_/}"
+MY_PV="${PV/_/}"
+DESCRIPTION="Small forwarding DNS server"
+HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/"
+SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${MY_P}.tar.lzma"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="dbus +dhcp idn ipv6 nls tftp"
+
+RDEPEND="dbus? ( sys-apps/dbus )
+ idn? ( net-dns/libidn )
+ nls? (
+ sys-devel/gettext
+ net-dns/libidn
+ )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ || ( app-arch/xz-utils app-arch/lzma-utils )"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ # dnsmasq on FreeBSD wants the config file in a silly location, this fixes
+ epatch "${FILESDIR}/${PN}-2.47-fbsd-config.patch"
+}
+
+src_configure() {
+ COPTS=""
+ use tftp || COPTS+=" -DNO_TFTP"
+ use dhcp || COPTS+=" -DNO_DHCP"
+ use ipv6 || COPTS+=" -DNO_IPV6"
+ use dbus && COPTS+=" -DHAVE_DBUS"
+ use idn && COPTS+=" -DHAVE_IDN"
+}
+
+src_compile() {
+ emake \
+ PREFIX=/usr \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ COPTS="${COPTS}" \
+ all$(use nls && echo "-i18n") || die
+}
+
+src_install() {
+ emake \
+ PREFIX=/usr \
+ MANDIR=/usr/share/man \
+ DESTDIR="${D}" \
+ install$(use nls && echo "-i18n") || die
+
+ dodoc CHANGELOG FAQ
+ dohtml *.html
+
+ newinitd "${FILESDIR}"/dnsmasq-init dnsmasq
+ newconfd "${FILESDIR}"/dnsmasq.confd dnsmasq
+ insinto /etc
+ newins dnsmasq.conf.example dnsmasq.conf
+
+ if use dbus ; then
+ insinto /etc/dbus-1/system.d
+ doins dbus/dnsmasq.conf
+ fi
+}