summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2002-06-29 00:55:03 +0000
committerThilo Bangert <bangert@gentoo.org>2002-06-29 00:55:03 +0000
commitd19f63797573f43ce392be56bf42e6ac3217c32e (patch)
tree1248b0606c23a939a46398eadcce97d8f1223c92 /net-dns/hesiod/hesiod-3.0.2.ebuild
parentnew category: net-dns (diff)
downloadhistorical-d19f63797573f43ce392be56bf42e6ac3217c32e.tar.gz
historical-d19f63797573f43ce392be56bf42e6ac3217c32e.tar.bz2
historical-d19f63797573f43ce392be56bf42e6ac3217c32e.zip
new category: net-dns. initial import
Diffstat (limited to 'net-dns/hesiod/hesiod-3.0.2.ebuild')
-rw-r--r--net-dns/hesiod/hesiod-3.0.2.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/net-dns/hesiod/hesiod-3.0.2.ebuild b/net-dns/hesiod/hesiod-3.0.2.ebuild
new file mode 100644
index 000000000000..4399caa66eaf
--- /dev/null
+++ b/net-dns/hesiod/hesiod-3.0.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/hesiod/hesiod-3.0.2.ebuild,v 1.1 2002/06/29 00:55:03 bangert Exp $
+
+DESCRIPTION="Hesiod is a system which uses existing DNS functionality to provide access to databases of information that changes infrequently."
+
+HOMEPAGE="ftp://athena-dist.mit.edu/pub/ATHENA/hesiod"
+LICENSE="ISC"
+DEPEND="virtual/glibc"
+#RDEPEND=""
+SRC_URI="ftp://athena-dist.mit.edu/pub/ATHENA/${PN}/${P}.tar.gz"
+SLOT="0"
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ #Patches stolen from RH
+ cat ${FILESDIR}/hesiod-3.0.2-shlib.patch | patch -d ${S} -p1
+ cat ${FILESDIR}/hesiod-3.0.2-env.patch | patch -d ${S} -p1
+ cat ${FILESDIR}/hesiod-3.0.2-str.patch | patch -d ${S} -p1
+ cd ${S}
+ for manpage in *.3
+ do
+ if grep -q '^\.so man3/hesiod.3' ${manpage}
+ then
+ echo .so hesiod.3 > ${manpage}
+ elif grep -q '^\.so man3/hesiod_getmailhost.3' ${manpage}
+ then
+ echo .so hesiod_getmailhost.3 > ${manpage}
+ elif grep -q '^\.so man3/hesiod_getpwnam.3' ${manpage}
+ then
+ echo .so hesiod_getpwnam.3 > ${manpage}
+ elif grep -q '^\.so man3/hesiod_getservbyname.3' ${manpage}
+ then
+ echo .so hesiod_getservbyname.3 > ${manpage}
+ fi
+ done
+}
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+ #make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ #make \
+ # prefix=${D}/usr \
+ # mandir=${D}/usr/share/man \
+ # infodir=${D}/usr/share/info \
+ # install || die
+ # Again, verify the Makefiles! We don't want anything falling
+ # outside of ${D}.
+}