summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Stadler <centic@gentoo.org>2006-12-28 20:59:13 +0000
committerDominik Stadler <centic@gentoo.org>2006-12-28 20:59:13 +0000
commita7a587dfe43442ecf25f52273149b0b9316db95f (patch)
treeeeb7f990ada5ae438d9070dffcf1dd4e12d22ecc /net-firewall/firehol/firehol-1.250.ebuild
parentAdd a live SVN version of Amarok. Although not supported and a bad idea in ge... (diff)
downloadhistorical-a7a587dfe43442ecf25f52273149b0b9316db95f.tar.gz
historical-a7a587dfe43442ecf25f52273149b0b9316db95f.tar.bz2
historical-a7a587dfe43442ecf25f52273149b0b9316db95f.zip
Upgrade to Version 250 from CVS, fixes some Bugs, also adjust for newer bash by using %b instead of %q in printf-statements.
Package-Manager: portage-2.1.2_rc2-r2
Diffstat (limited to 'net-firewall/firehol/firehol-1.250.ebuild')
-rw-r--r--net-firewall/firehol/firehol-1.250.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/net-firewall/firehol/firehol-1.250.ebuild b/net-firewall/firehol/firehol-1.250.ebuild
new file mode 100644
index 000000000000..40a31bb072b9
--- /dev/null
+++ b/net-firewall/firehol/firehol-1.250.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/firehol/firehol-1.250.ebuild,v 1.1 2006/12/28 20:59:13 centic Exp $
+
+inherit eutils
+
+DESCRIPTION="iptables firewall generator"
+HOMEPAGE="http://firehol.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-1.226.tar.bz2"
+
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="sys-apps/iproute2"
+RDEPEND="net-firewall/iptables
+ sys-apps/iproute2
+ virtual/modutils
+ || (
+ net-misc/wget
+ net-misc/curl
+ )"
+
+S="${WORKDIR}/${PN}-1.226"
+
+pkg_setup() {
+ # Bug 81600 fail if iproute2 is built with minimal
+ if built_with_use sys-apps/iproute2 minimal; then
+ eerror "Firehol requires iproute2 to be emerged without"
+ eerror "the USE-Flag \"minimal\"."
+ eerror "Re-emerge iproute2 with"
+ eerror "USE=\"-minimal\" emerge sys-apps/iproute2"
+ die "sys-apps/iproute2 without USE=\"minimal\" needed"
+ fi
+}
+
+# patch for embedded Gentoo - GNAP
+# backport from firehol-CVS.
+src_unpack() {
+ unpack ${A}
+ cd ${S} || die
+ epatch ${FILESDIR}/firehol-1.226-to-228.patch || die
+ epatch ${FILESDIR}/firehol-1.226-to-250.patch || die
+ epatch ${FILESDIR}/${P}-printf.patch || die
+}
+
+src_install() {
+ newsbin firehol.sh firehol
+
+ dodir /etc/firehol /etc/firehol/examples /etc/firehol/services
+ insinto /etc/firehol/examples
+ doins examples/* || die
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/firehol.conf.d firehol || die
+
+ dodoc ChangeLog README TODO WhatIsNew || die
+ dohtml doc/*.html doc/*.css || die
+
+ docinto scripts
+ dodoc get-iana.sh adblock.sh || die
+
+ doman man/*.1 man/*.5 || die
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/firehol.initrd firehol || die
+}
+
+pkg_postinst() {
+ einfo "The default path to firehol's configuration file is /etc/firehol/firehol.conf"
+ einfo "See /etc/firehol/examples for configuration examples."
+ #
+ # Install a default configuration if none is available yet
+ if [[ ! -e "${ROOT}/etc/firehol/firehol.conf" ]]; then
+ einfo "Installing a sample configuration as ${ROOT}/etc/firehol/firehol.conf"
+ cp "${ROOT}/etc/firehol/examples/client-all.conf" "${ROOT}/etc/firehol/firehol.conf"
+ fi
+}
+