summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConstanze Hausner <constanze@gentoo.org>2011-07-24 15:26:50 +0000
committerConstanze Hausner <constanze@gentoo.org>2011-07-24 15:26:50 +0000
commita87fe6c8647f77da19ecca8634f51b740a5475de (patch)
tree95aea97a355bc9abfc8a507e231e16fd58be754e /net-firewall/shorewall6
parentVersion bump. (diff)
downloadhistorical-a87fe6c8647f77da19ecca8634f51b740a5475de.tar.gz
historical-a87fe6c8647f77da19ecca8634f51b740a5475de.tar.bz2
historical-a87fe6c8647f77da19ecca8634f51b740a5475de.zip
Make sure that /var/lock/subsys exists, see Bug 375495
Package-Manager: portage-2.1.10.3/cvs/Linux x86_64
Diffstat (limited to 'net-firewall/shorewall6')
-rw-r--r--net-firewall/shorewall6/ChangeLog8
-rw-r--r--net-firewall/shorewall6/shorewall6-4.4.21-r1.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/net-firewall/shorewall6/ChangeLog b/net-firewall/shorewall6/ChangeLog
index dd99121ec948..3f589a3a65f9 100644
--- a/net-firewall/shorewall6/ChangeLog
+++ b/net-firewall/shorewall6/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/shorewall6
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/ChangeLog,v 1.38 2011/07/16 14:31:52 constanze Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/ChangeLog,v 1.39 2011/07/24 15:26:50 constanze Exp $
+
+*shorewall6-4.4.21-r1 (24 Jul 2011)
+
+ 24 Jul 2011; Constanze Hausner <constanze@gentoo.org>
+ +shorewall6-4.4.21-r1.ebuild:
+ Make sure that /var/lock/subsys exists, see Bug #375495
*shorewall6-4.4.21 (16 Jul 2011)
diff --git a/net-firewall/shorewall6/shorewall6-4.4.21-r1.ebuild b/net-firewall/shorewall6/shorewall6-4.4.21-r1.ebuild
new file mode 100644
index 000000000000..b56ddf9e7f64
--- /dev/null
+++ b/net-firewall/shorewall6/shorewall6-4.4.21-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall6/shorewall6-4.4.21-r1.ebuild,v 1.1 2011/07/24 15:26:50 constanze Exp $
+
+EAPI="4"
+
+inherit versionator linux-info
+
+# Select version (stable, RC, Beta, upstream patched):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_PV_BASE=$(get_version_component_range 1-3) # which shorewall-common to use
+
+MY_PN="${PN/6/}"
+MY_P="${MY_PN}-${MY_PV_BASE}"
+MY_P_DOCS="${MY_PN}-docs-html-${PV}"
+
+DESCRIPTION="Shoreline Firewall with IPv6 support."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/${P}.tar.bz2
+ doc? ( http://www1.shorewall.net/pub/${PN}/${MY_PV_TREE}/${MY_P}/${MY_P_DOCS}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="doc"
+
+DEPEND=">=net-firewall/iptables-1.4.0
+ sys-apps/iproute2
+ >=net-firewall/shorewall-${MY_PV_BASE}
+ dev-perl/Socket6"
+RDEPEND="${DEPEND}"
+
+pkg_pretend() {
+ if kernel_is lt 2 6 25 ; then
+ die "${PN} requires at least kernel 2.6.25."
+ fi
+}
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ keepdir /var/lib/${PN}
+
+ cd "${WORKDIR}/${P}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+
+ dodoc changelog.txt releasenotes.txt
+ if use doc; then
+ dodoc -r Samples6
+ cd "${WORKDIR}/${MY_P_DOCS}"
+ dohtml -r *
+ fi
+ dodir /var/lock/subsys
+}