summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConstanze Hausner <constanze@gentoo.org>2012-06-08 17:13:08 +0000
committerConstanze Hausner <constanze@gentoo.org>2012-06-08 17:13:08 +0000
commitcec018692c364df17834fb7d670a6137cc8eef3e (patch)
treeadb97bf205527ca71e6200c69b2a96e2c3301af4 /net-firewall/shorewall
parentVersion bump. (diff)
downloadhistorical-cec018692c364df17834fb7d670a6137cc8eef3e.tar.gz
historical-cec018692c364df17834fb7d670a6137cc8eef3e.tar.bz2
historical-cec018692c364df17834fb7d670a6137cc8eef3e.zip
Version bump with new config file
Package-Manager: portage-2.1.10.49/cvs/Linux x86_64
Diffstat (limited to 'net-firewall/shorewall')
-rw-r--r--net-firewall/shorewall/ChangeLog8
-rw-r--r--net-firewall/shorewall/files/shorewallrc21
-rw-r--r--net-firewall/shorewall/shorewall-4.5.4.2.ebuild63
3 files changed, 91 insertions, 1 deletions
diff --git a/net-firewall/shorewall/ChangeLog b/net-firewall/shorewall/ChangeLog
index a9fa54e048f1..976388ddb7bb 100644
--- a/net-firewall/shorewall/ChangeLog
+++ b/net-firewall/shorewall/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/shorewall
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/ChangeLog,v 1.205 2012/05/20 08:42:07 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/ChangeLog,v 1.206 2012/06/08 17:11:17 constanze Exp $
+
+*shorewall-4.5.4.2 (08 Jun 2012)
+
+ 08 Jun 2012; Constanze Hausner <constanze@gentoo.org>
+ +shorewall-4.5.4.2.ebuild, +files/shorewallrc:
+ Version bump with new config file
20 May 2012; Mark Loeser <halcy0n@gentoo.org> shorewall-4.4.23.2.ebuild:
Stable for ppc/ppc64; bug #388195
diff --git a/net-firewall/shorewall/files/shorewallrc b/net-firewall/shorewall/files/shorewallrc
new file mode 100644
index 000000000000..4f13769114a4
--- /dev/null
+++ b/net-firewall/shorewall/files/shorewallrc
@@ -0,0 +1,21 @@
+#
+# Gentoo Shorewall 4.5 rc file
+#
+HOST=linux #Generic Linux
+BUILD= #Default is to detect the build system
+PREFIX=/usr #Top-level directory for shared files, libraries, etc.
+SHAREDIR=${PREFIX}/share #Directory for arch-neutral files.
+LIBEXECDIR=${PREFIX}/share #Directory for executable scripts.
+PERLLIBDIR=${PREFIX}/share/shorewall #Directory to install Shorewall Perl module directory
+CONFDIR=/etc #Directory where subsystem configurations are installed
+SBINDIR=/sbin #Directory where system administration programs are installed
+MANDIR=${PREFIX}/share/man #Directory where manpages are installed.
+INITDIR=etc/init.d #Directory where SysV init scripts are installed.
+INITFILE=$PRODUCT #Name of the product's installed SysV init script
+INITSOURCE=init.sh #Name of the distributed file to be installed as the SysV init script
+ANNOTATED= #If non-zero, annotated configuration files are installed
+SYSTEMD= #Directory where .service files are installed (systems running systemd only)
+SYSCONFFILE= #Name of the distributed file to be installed in $SYSCONFDIR
+SYSCONFDIR= #Directory where SysV init parameter files are installed
+SPARSE= #If non-empty, only install $PRODUCT/$PRODUCT.conf in $CONFDIR
+VARDIR=/var/lib #Directory where product variable data is stored.
diff --git a/net-firewall/shorewall/shorewall-4.5.4.2.ebuild b/net-firewall/shorewall/shorewall-4.5.4.2.ebuild
new file mode 100644
index 000000000000..a498be345979
--- /dev/null
+++ b/net-firewall/shorewall/shorewall-4.5.4.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall/shorewall-4.5.4.2.ebuild,v 1.1 2012/06/08 17:11:17 constanze Exp $
+
+EAPI="4"
+
+inherit eutils versionator
+
+# Select version (stable, RC, Beta):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_PV_BASE=$(get_version_component_range 1-3)
+
+MY_P="${PN}-${MY_PV_BASE}"
+MY_P_DOCS="${P/${PN}/${PN}-docs-html}"
+
+DESCRIPTION="Shoreline Firewall is an iptables-based firewall for Linux."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${PN}/${MY_PV_TREE}/${MY_P}/${P}.tar.bz2
+ doc? ( http://www1.shorewall.net/pub/${PN}/${MY_PV_TREE}/${MY_P}/${MY_P_DOCS}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND=">=net-firewall/iptables-1.2.4
+ sys-apps/iproute2[-minimal]
+ dev-lang/perl
+ =net-firewall/shorewall-core-${PV}"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ :;
+}
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ keepdir /var/lib/shorewall
+
+ cd "${WORKDIR}/${P}"
+ DESTDIR="${D}" ./install.sh "${FILESDIR}"/shorewallrc || die "install.sh failed"
+ newinitd "${FILESDIR}"/shorewall.initd shorewall
+
+ dodoc changelog.txt releasenotes.txt
+ if use doc; then
+ dodoc -r Samples
+ cd "${WORKDIR}/${MY_P_DOCS}"
+ dohtml -r *
+ fi
+ dodir /var/lock/subsys
+}
+
+pkg_postinst() {
+ elog "It is advised to copy the /usr/share/shorewall/configfiles dir to your"
+ elog "own 'export directories'. However, whenever you upgrade Shorewall you"
+ elog "should check for changes in configfiles and manually update your exports."
+ elog "Alternatively, if you only have one Shorewall-Lite system in your network"
+ elog "then you can use the configfiles dir but set CONFIG_PROTECT appropriately"
+ elog "in /etc/make.conf (man make.conf)."
+}