summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2003-08-03 03:12:24 +0000
committerNed Ludd <solar@gentoo.org>2003-08-03 03:12:24 +0000
commit32676d23769a2e8f5b56793c2fc66ba0d791c6bb (patch)
tree3395abd906d5cec9150926ae080bdb1d6a0b837e /net-firewall
parentAdded support for console only building. Server installs are a place that I t... (diff)
downloadhistorical-32676d23769a2e8f5b56793c2fc66ba0d791c6bb.tar.gz
historical-32676d23769a2e8f5b56793c2fc66ba0d791c6bb.tar.bz2
historical-32676d23769a2e8f5b56793c2fc66ba0d791c6bb.zip
Added support for console only building. Server installs are a place that I think most admins/users would want the functionality of something like bastille without having to install X
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/bastille/Manifest4
-rw-r--r--net-firewall/bastille/bastille-2.1.1.ebuild16
-rw-r--r--net-firewall/bastille/metadata.xml10
3 files changed, 21 insertions, 9 deletions
diff --git a/net-firewall/bastille/Manifest b/net-firewall/bastille/Manifest
index a1cde278823c..6c268ca87a68 100644
--- a/net-firewall/bastille/Manifest
+++ b/net-firewall/bastille/Manifest
@@ -1,4 +1,4 @@
-MD5 d56c03462c666007f0cc11c3931d95d0 ChangeLog 743
-MD5 a6f56b0caf08a3ee80f8bc13dc462192 bastille-2.1.1.ebuild 3064
+MD5 eb6b0233f21b12c87ea1d805e5509ed8 ChangeLog 741
+MD5 d60f1a734e3d507246af3991821e41f3 bastille-2.1.1.ebuild 3062
MD5 624441f5e21afa19251eedc583e0c4e7 metadata.xml 433
MD5 4272f90fa558fdd79b79173aed7070a7 files/digest-bastille-2.1.1 142
diff --git a/net-firewall/bastille/bastille-2.1.1.ebuild b/net-firewall/bastille/bastille-2.1.1.ebuild
index ddb6b7a235fb..062432ab00f4 100644
--- a/net-firewall/bastille/bastille-2.1.1.ebuild
+++ b/net-firewall/bastille/bastille-2.1.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/bastille/bastille-2.1.1.ebuild,v 1.2 2003/08/02 10:24:08 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/bastille/bastille-2.1.1.ebuild,v 1.3 2003/08/03 03:12:17 solar Exp $
inherit perl-module
-IUSE=""
+IUSE="tcltk"
MY_PN=${PN/b/B}
MY_P=${MY_PN}-${PV}
@@ -20,7 +20,7 @@ KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa"
RDEPEND="dev-perl/Curses
- dev-perl/perl-tk"
+ tcltk? ( dev-perl/perl-tk )"
src_unpack() {
unpack ${A}
@@ -31,14 +31,14 @@ src_compile() {
cd ${S}/psad/Psad.pm
SRC_PREP="no" perl-module_src_compile
- make test
+ emake test
cd ${S}/psad/Unix-Syslog-0.98
SRC_PREP="no" perl-module_src_compile
- make test
+ emake test
cd ${S}/psad/whois-4.5.29
- make || die
+ emake || die
cd ${S}
}
@@ -75,7 +75,8 @@ src_install() {
perlinfo
insinto ${SITE_LIB}
- doins Bastille_Curses.pm Bastille_Tk.pm
+ doins Bastille_Curses.pm
+ use tcltk && doins Bastille_Tk.pm
insinto ${SITE_LIB}/Curses
doins Curses/Widgets.pm
@@ -119,4 +120,5 @@ pkg_postinst() {
mknod -m 600 ${ROOT}/var/log/psadfifo p
eend $?
fi
+ use tcltk || einfo "When not using the Tk interface you will need to start use the -c flag when calling ${PN} from command line. example ${PN} -c --os GE1.4"
}
diff --git a/net-firewall/bastille/metadata.xml b/net-firewall/bastille/metadata.xml
new file mode 100644
index 000000000000..cefbc16f77a9
--- /dev/null
+++ b/net-firewall/bastille/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>hardened</herd>
+ <maintainer>
+ <email>hardened@gentoo.org</email>
+ <description>Bastille Currently Has No Primary Gentoo Maintainer</description>
+ </maintainer>
+ <longdescription>The Bastille Hardening System attempts to "harden" or "tighten" Unix operating systems.</longdescription>
+</pkgmetadata>