summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-07-05 20:37:14 +0000
committerPeter Volkov <pva@gentoo.org>2008-07-05 20:37:14 +0000
commit4a681414d40302f0fe02e0103c2c50ec79ea2060 (patch)
treee5b19480c7fe3ed3844dfa7f2b1cecacf9d4b828 /net-firewall
parentfix #227277 (diff)
downloadhistorical-4a681414d40302f0fe02e0103c2c50ec79ea2060.tar.gz
historical-4a681414d40302f0fe02e0103c2c50ec79ea2060.tar.bz2
historical-4a681414d40302f0fe02e0103c2c50ec79ea2060.zip
Version bump, bug #230467, thank Vieri for all the work
Package-Manager: portage-2.2_rc1/cvs/Linux 2.6.22-ovz005 i686
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/shorewall-common/ChangeLog8
-rw-r--r--net-firewall/shorewall-common/shorewall-common-4.0.12.ebuild97
-rw-r--r--net-firewall/shorewall-lite/ChangeLog7
-rw-r--r--net-firewall/shorewall-lite/shorewall-lite-4.0.12.ebuild64
-rw-r--r--net-firewall/shorewall-perl/ChangeLog8
-rw-r--r--net-firewall/shorewall-perl/shorewall-perl-4.0.12.1.ebuild56
-rw-r--r--net-firewall/shorewall-shell/ChangeLog7
-rw-r--r--net-firewall/shorewall-shell/shorewall-shell-4.0.12.ebuild54
8 files changed, 297 insertions, 4 deletions
diff --git a/net-firewall/shorewall-common/ChangeLog b/net-firewall/shorewall-common/ChangeLog
index 99d0bb76fb37..a605c68ad4ce 100644
--- a/net-firewall/shorewall-common/ChangeLog
+++ b/net-firewall/shorewall-common/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/shorewall-common
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-common/ChangeLog,v 1.15 2008/05/21 18:01:40 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-common/ChangeLog,v 1.16 2008/07/05 20:28:09 pva Exp $
+
+*shorewall-common-4.0.12 (05 Jul 2008)
+
+ 05 Jul 2008; Peter Volkov <pva@gentoo.org>
+ +shorewall-common-4.0.12.ebuild:
+ Version bump, bug #230467, thank Vieri for all the work
*shorewall-common-4.0.11 (21 May 2008)
diff --git a/net-firewall/shorewall-common/shorewall-common-4.0.12.ebuild b/net-firewall/shorewall-common/shorewall-common-4.0.12.ebuild
new file mode 100644
index 000000000000..e7bbcc252908
--- /dev/null
+++ b/net-firewall/shorewall-common/shorewall-common-4.0.12.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-common/shorewall-common-4.0.12.ebuild,v 1.1 2008/07/05 20:28:09 pva Exp $
+
+inherit eutils versionator
+
+# Select version (stable, RC, Beta):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_P_BETA="" # stable or experimental (eg. "-RC1" or "-Beta4")
+MY_PV_BASE=$(get_version_component_range 1-3)
+
+MY_PN="${PN/-common/}"
+MY_P="${MY_PN}-${MY_PV_BASE}${MY_P_BETA}"
+MY_P_DOCS="${MY_P/${MY_PN}/${MY_PN}-docs-html}"
+
+DESCRIPTION="Shoreline Firewall is an iptables-based firewall for Linux."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/${P}${MY_P_BETA}.tar.bz2
+ doc? ( http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/${MY_P_DOCS}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND=">=net-firewall/iptables-1.2.4
+ sys-apps/iproute2
+ !<net-firewall/shorewall-4.0"
+
+pkg_setup() {
+ if built_with_use sys-apps/iproute2 minimal; then
+ die "Shorewall requires sys-apps/iproute2 to be built without the \"minimal\" USE flag."
+ fi
+}
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ keepdir /var/lib/shorewall
+
+ cd "${WORKDIR}/${P}${MY_P_BETA}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+ newinitd "${FILESDIR}"/shorewall.initd shorewall || die "doinitd failed"
+
+ dodoc changelog.txt releasenotes.txt
+ if use doc; then
+ cd "${WORKDIR}/${MY_P_DOCS}"
+ # install documentation
+ dohtml -r *
+ ## dosym Documentation_Index.html "/usr/share/doc/${PF}/html/index.htm"
+ # install samples
+ cp -pR "${S}${MY_P_BETA}/Samples" "${D}/usr/share/doc/${PF}"
+ fi
+}
+
+pkg_postinst() {
+ elog
+ if use doc ; then
+ elog "Documentation is available at /usr/share/doc/${PF}/html."
+ elog "Please read the Release Notes in /usr/share/doc/${PF}."
+ elog "Samples are available at /usr/share/doc/${PF}/Samples."
+ else
+ elog "Documentation is available at http://www.shorewall.net"
+ fi
+ elog "There are man pages for shorewall(8) and for each configuration file."
+ elog
+ elog "Bridging configuration has changed with kernel 2.6.20+."
+ elog "Check the documentation."
+ elog
+ elog "Do not blindly start shorewall, edit the files in /etc/shorewall first"
+ elog "At the very least, you must change 'STARTUP_ENABLED' in shorewall.conf"
+ elog
+ elog "Be aware that version ${MY_PV_TREE} differs substantially from previous releases."
+ elog "Information on upgrading is available at:"
+ elog "http://www.shorewall.net/upgrade_issues.htm"
+ elog
+ elog "There is a 'shorewall compile' command to generate scripts to run"
+ elog "on systems with Shorewall Lite installed."
+ elog "Please refer to http://www.shorewall.net/CompiledPrograms.html"
+ elog "It is advised to copy the /usr/share/shorewall/configfiles dir to your"
+ elog "own 'export directories'. However, whenever you upgrade Shorewall you"
+ elog "should check for changes in configfiles and manually update your exports."
+ elog "Alternatively, if you only have one Shorewall-Lite system in your network"
+ elog "then you can use the configfiles dir but set CONFIG_PROTECT appropriately"
+ elog "in /etc/make.conf (man make.conf)."
+ elog
+ elog "Known problems:"
+ elog "http://shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/known_problems.txt"
+ elog
+ elog "Whether upgrading or installing you should run shorewall check,"
+ elog "correct any errors found and run shorewall restart|start."
+ elog
+ elog "${PN} requires a compiler."
+ elog "You can choose to emerge shorewall-shell and/or shorewall-perl."
+}
diff --git a/net-firewall/shorewall-lite/ChangeLog b/net-firewall/shorewall-lite/ChangeLog
index 2f04ddc67818..41a91f6b7a7d 100644
--- a/net-firewall/shorewall-lite/ChangeLog
+++ b/net-firewall/shorewall-lite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/shorewall-lite
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-lite/ChangeLog,v 1.40 2008/05/21 18:08:12 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-lite/ChangeLog,v 1.41 2008/07/05 20:31:15 pva Exp $
+
+*shorewall-lite-4.0.12 (05 Jul 2008)
+
+ 05 Jul 2008; Peter Volkov <pva@gentoo.org> +shorewall-lite-4.0.12.ebuild:
+ Version bump, bug #230467, thank Vieri for all the work
*shorewall-lite-4.0.11 (21 May 2008)
diff --git a/net-firewall/shorewall-lite/shorewall-lite-4.0.12.ebuild b/net-firewall/shorewall-lite/shorewall-lite-4.0.12.ebuild
new file mode 100644
index 000000000000..7e975b9181eb
--- /dev/null
+++ b/net-firewall/shorewall-lite/shorewall-lite-4.0.12.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-lite/shorewall-lite-4.0.12.ebuild,v 1.1 2008/07/05 20:31:15 pva Exp $
+
+inherit versionator
+
+# Select version (stable, RC, Beta):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_P_BETA="" # stable or experimental (eg. "-RC1" or "-Beta4")
+MY_PV_BASE=$(get_version_component_range 1-3)
+
+MY_PN="${PN/-lite/}"
+MY_P="${MY_PN}-${MY_PV_BASE}${MY_P_BETA}"
+MY_P_DOCS="${MY_PN}-docs-html-${MY_PV_BASE}${MY_P_BETA}"
+
+DESCRIPTION="An iptables-based firewall whose config is handled by a normal Shorewall."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/${P}${MY_P_BETA}.tar.bz2
+ doc? ( http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/${MY_P_DOCS}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="net-firewall/iptables
+ sys-apps/iproute2"
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ keepdir /var/lib/shorewall-lite
+
+ cd "${WORKDIR}/${P}${MY_P_BETA}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+ newinitd "${FILESDIR}/shorewall-lite" shorewall-lite
+
+ dodoc changelog.txt releasenotes.txt
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Documentation is available at http://www.shorewall.net"
+ einfo "There are man pages for shorewall-lite(8) and for each"
+ einfo "configuration file."
+ einfo
+ einfo "You should have already generated a firewall script with"
+ einfo "'shorewall compile' on the administrative Shorewall."
+ einfo "Please refer to"
+ einfo "http://www.shorewall.net/CompiledPrograms.html"
+ einfo
+ einfo "If you intend to use the 2.6 IPSEC Support, you must retrieve the"
+ einfo "kernel patches from http://shorewall.net/pub/shorewall/contrib/IPSEC/"
+ einfo "or install kernel 2.6.16+ as well as a recent Netfilter iptables"
+ einfo "and compile it with support for policy match."
+ einfo
+ einfo "Note that /etc/shorewall-lite/shorewall.conf has been renamed"
+ einfo "to /etc/shorewall-lite/shorewall-lite.conf"
+ einfo
+ einfo "Known problems:"
+ einfo "http://shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/known_problems.txt"
+}
diff --git a/net-firewall/shorewall-perl/ChangeLog b/net-firewall/shorewall-perl/ChangeLog
index 379a435d60ea..0e63dfda2a41 100644
--- a/net-firewall/shorewall-perl/ChangeLog
+++ b/net-firewall/shorewall-perl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/shorewall-perl
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-perl/ChangeLog,v 1.16 2008/05/21 18:04:54 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-perl/ChangeLog,v 1.17 2008/07/05 20:34:19 pva Exp $
+
+*shorewall-perl-4.0.12.1 (05 Jul 2008)
+
+ 05 Jul 2008; Peter Volkov <pva@gentoo.org>
+ +shorewall-perl-4.0.12.1.ebuild:
+ Version bump, bug #230467, thank Vieri for all the work
*shorewall-perl-4.0.11 (21 May 2008)
diff --git a/net-firewall/shorewall-perl/shorewall-perl-4.0.12.1.ebuild b/net-firewall/shorewall-perl/shorewall-perl-4.0.12.1.ebuild
new file mode 100644
index 000000000000..d5e56b719c71
--- /dev/null
+++ b/net-firewall/shorewall-perl/shorewall-perl-4.0.12.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-perl/shorewall-perl-4.0.12.1.ebuild,v 1.1 2008/07/05 20:34:19 pva Exp $
+
+inherit versionator
+
+# Select version (stable, RC, Beta, upstream patched):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_P_BETA="" # stable or experimental (eg. "-RC1" or "-Beta4")
+MY_PV_BASE=$(get_version_component_range 1-3) # which shorewall-common to use
+
+MY_PN="${PN/-perl/}"
+MY_P="${MY_PN}-${MY_PV_BASE}${MY_P_BETA}"
+
+DESCRIPTION="Shoreline Firewall Perl-based compiler that allows faster compilation and execution."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/${P}${MY_P_BETA}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE=""
+
+DEPEND="net-firewall/iptables
+ sys-apps/iproute2
+ dev-lang/perl
+ !<net-firewall/shorewall-4.0"
+
+PDEPEND="=net-firewall/shorewall-common-${MY_PV_BASE}*"
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ cd "${WORKDIR}/${P}${MY_P_BETA}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+
+ dodoc releasenotes.txt
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Documentation is available at http://www.shorewall.net"
+ einfo
+ elog "In order to use the Perl compiler you need to add"
+ elog "SHOREWALL_COMPILER=perl"
+ elog "to shorewall.conf unless you did not install the Shell compiler."
+ einfo
+ einfo "Please read the included release notes for more information."
+ einfo
+ einfo "Known problems:"
+ einfo "http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/known_problems.txt"
+ einfo
+}
diff --git a/net-firewall/shorewall-shell/ChangeLog b/net-firewall/shorewall-shell/ChangeLog
index 13b2217db509..ed2d5468ce94 100644
--- a/net-firewall/shorewall-shell/ChangeLog
+++ b/net-firewall/shorewall-shell/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/shorewall-shell
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-shell/ChangeLog,v 1.14 2008/05/21 18:05:25 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-shell/ChangeLog,v 1.15 2008/07/05 20:37:14 pva Exp $
+
+*shorewall-shell-4.0.12 (05 Jul 2008)
+
+ 05 Jul 2008; Peter Volkov <pva@gentoo.org> +shorewall-shell-4.0.12.ebuild:
+ Version bump, bug #230467, thank Vieri for all the work
*shorewall-shell-4.0.11 (21 May 2008)
diff --git a/net-firewall/shorewall-shell/shorewall-shell-4.0.12.ebuild b/net-firewall/shorewall-shell/shorewall-shell-4.0.12.ebuild
new file mode 100644
index 000000000000..6177078019c0
--- /dev/null
+++ b/net-firewall/shorewall-shell/shorewall-shell-4.0.12.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/shorewall-shell/shorewall-shell-4.0.12.ebuild,v 1.1 2008/07/05 20:37:14 pva Exp $
+
+inherit versionator
+
+# Select version (stable, RC, Beta):
+MY_PV_TREE=$(get_version_component_range 1-2) # for devel versions use "development/$(get_version_component_range 1-2)"
+MY_P_BETA="" # stable or experimental (eg. "-RC1" or "-Beta4")
+MY_PV_BASE=$(get_version_component_range 1-3) # shorewall-common version to use (ignoring upstream "compatibility matrix" for now as it is not always updated at the same time as the software is released)
+
+MY_PN="${PN/-shell/}"
+MY_P="${MY_PN}-${MY_PV_BASE}${MY_P_BETA}"
+
+DESCRIPTION="Shoreline Firewall shell-based compiler."
+HOMEPAGE="http://www.shorewall.net/"
+SRC_URI="http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/${P}${MY_P_BETA}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="net-firewall/iptables
+ sys-apps/iproute2
+ !<net-firewall/shorewall-4.0"
+
+PDEPEND="=net-firewall/shorewall-common-${MY_PV_BASE}*"
+
+src_compile() {
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ cd "${WORKDIR}/${P}${MY_P_BETA}"
+ PREFIX="${D}" ./install.sh || die "install.sh failed"
+
+ dodoc releasenotes.txt
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Documentation is available at http://www.shorewall.net"
+ einfo
+ elog "In order to use the shell compiler you need to add"
+ elog "SHOREWALL_COMPILER=shell"
+ elog "to shorewall.conf unless you do not have the Perl compiler."
+ einfo
+ einfo "Please read the included release notes for more information."
+ einfo
+ einfo "Known problems:"
+ einfo "http://www1.shorewall.net/pub/${MY_PN}/${MY_PV_TREE}/${MY_P}/known_problems.txt"
+ einfo
+}