summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-08-04 12:41:01 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-08-04 12:41:01 +0000
commit83b80078f13504fd5f44a94ee85429fcd9b55d97 (patch)
tree41f9cd528f0eef12777d00c30dd426ce5b91f733 /net-fs
parentquick fix (diff)
downloadhistorical-83b80078f13504fd5f44a94ee85429fcd9b55d97.tar.gz
historical-83b80078f13504fd5f44a94ee85429fcd9b55d97.tar.bz2
historical-83b80078f13504fd5f44a94ee85429fcd9b55d97.zip
added check for ssl, currently always disabled until someone from the server team can test this
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/samba-2.2.1a.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/net-fs/samba/samba-2.2.1a.ebuild b/net-fs/samba/samba-2.2.1a.ebuild
index bc26b802f535..ed9cd39e8113 100644
--- a/net-fs/samba/samba-2.2.1a.ebuild
+++ b/net-fs/samba/samba-2.2.1a.ebuild
@@ -11,7 +11,8 @@ HOMEPAGE="http://www.samba.org"
DEPEND="virtual/glibc sys-devel/autoconf
cups? ( net-print/cups )
pam? ( >=sys-libs/pam-0.72 )
- tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
RDEPEND="virtual/glibc
cups? ( net-print/cups )"
@@ -40,6 +41,17 @@ src_compile() {
# else
myconf="--without-pam"
# fi
+
+# Samba doesn't seem to work well with ssl support but I'll add the check
+# anyway (otherwise it seems to be built with ssl if it finds it). This should # tested. I'll mail gentoo-dev and add a todo in wiki. /Hallski
+
+# if [ "`use ssl`" ]
+# then
+# myconf="${myconf} --with-ssl"
+# else
+ myconf="${myconf} --without-ssl"
+# fi
+
cd ${S}/source
if [ ! "`use cups`" ] ; then
cp configure.in configure.in.orig