summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStewart Honsberger <blkdeath@gentoo.org>2004-01-14 20:13:11 +0000
committerStewart Honsberger <blkdeath@gentoo.org>2004-01-14 20:13:11 +0000
commit72ff735e086d50d0aea890a57a7efdf1611a7470 (patch)
tree0939af9c6ccb39afa017fbc419f3db3dae8b30af /net-ftp/gproftpd/gproftpd-8.1.4.ebuild
parentadded ~sparc (diff)
downloadhistorical-72ff735e086d50d0aea890a57a7efdf1611a7470.tar.gz
historical-72ff735e086d50d0aea890a57a7efdf1611a7470.tar.bz2
historical-72ff735e086d50d0aea890a57a7efdf1611a7470.zip
Version bump
Diffstat (limited to 'net-ftp/gproftpd/gproftpd-8.1.4.ebuild')
-rw-r--r--net-ftp/gproftpd/gproftpd-8.1.4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-ftp/gproftpd/gproftpd-8.1.4.ebuild b/net-ftp/gproftpd/gproftpd-8.1.4.ebuild
new file mode 100644
index 000000000000..b17f15666902
--- /dev/null
+++ b/net-ftp/gproftpd/gproftpd-8.1.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/gproftpd/gproftpd-8.1.4.ebuild,v 1.1 2004/01/14 20:13:03 blkdeath Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="GTK frontend to proftpd"
+HOMEPAGE="http://mange.dynup.net/linux.html"
+SRC_URI="http://mange.dynup.net/linux/gproftpd/${P}.tar.gz"
+LICENSE="GPL-2"
+
+KEYWORDS="~x86"
+
+SLOT="0"
+
+IUSE="X gtk"
+
+# Requiring ProFTPD 1.2.9 due to security fixes
+DEPEND=">=net-ftp/proftpd-1.2.9
+ >=x11-libs/gtk+-2.0
+ >=dev-libs/glib-2.0
+ >=x11-libs/pango-1.0
+ >=dev-libs/atk-1.0
+ >=media-libs/freetype-2.0"
+
+# >=x11-libs/xft-2.0 //this is blocked by xfree4.3.99
+
+src_compile() {
+ econf --sysconfdir=/etc || die "./configure failed"
+ # --sysconfdir=/path/to/proftpd/conf/file
+ # or you can remove the --sysconfdir line and specify when starting the app proftpd -c /etc/proftpd.conf
+ emake || die "Build failure"
+}
+
+src_install () {
+ einstall || die "Installation failure"
+
+# Add the Gnome menu entry
+ if [ `use gnome` ] ; then
+ insinto /usr/share/gnome/apps/Internet/
+ doins ${FILESDIR}/gproftpd.desktop
+ fi
+
+ dodoc AUTHORS ChangeLog COPYING INSTALL NEWS README
+}