summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2003-10-13 16:19:58 +0000
committerNed Ludd <solar@gentoo.org>2003-10-13 16:19:58 +0000
commit8475f13481750d9218f10ad94c672b61b53b27a7 (patch)
tree08928d9b5c8b01b3a5b201d9544cc2147d148f63 /net-ftp/proftpd
parentAdding TJ Saunders directive lookup code patch from Comment #10 http://bugs.p... (diff)
downloadhistorical-8475f13481750d9218f10ad94c672b61b53b27a7.tar.gz
historical-8475f13481750d9218f10ad94c672b61b53b27a7.tar.bz2
historical-8475f13481750d9218f10ad94c672b61b53b27a7.zip
Adding TJ Saunders directive lookup code patch from Comment #10 http://bugs.proftpd.org/show_bug.cgi?id=2183 for src/dirtree.c This should close Gentoo Bug #29639
Diffstat (limited to 'net-ftp/proftpd')
-rw-r--r--net-ftp/proftpd/Manifest4
-rw-r--r--net-ftp/proftpd/files/digest-proftpd-1.2.9_rc2-r11
-rw-r--r--net-ftp/proftpd/files/proftpd-1.2.9_rc2-dirtree-r118.patch16
-rw-r--r--net-ftp/proftpd/proftpd-1.2.9_rc2-r1.ebuild124
4 files changed, 143 insertions, 2 deletions
diff --git a/net-ftp/proftpd/Manifest b/net-ftp/proftpd/Manifest
index c3e98f5f73c6..ced57d78356d 100644
--- a/net-ftp/proftpd/Manifest
+++ b/net-ftp/proftpd/Manifest
@@ -1,10 +1,10 @@
-MD5 d5e56bcc7d33c02846950a666c3dca42 ChangeLog 6082
+MD5 c1a9128c8b5cbf88915cfabc1218b6af ChangeLog 6398
MD5 6af0a703972bb7f858aabcc18896454b proftpd-1.2.5-r1.ebuild 2487
MD5 bef00204f7097fbe4c9cc00c6f638e93 proftpd-1.2.7.ebuild 3670
MD5 3ae04eafb730c36ccc8984f86799af79 proftpd-1.2.8.ebuild 2739
MD5 ed644dbda898814d27dbf3b8b8775fef proftpd-1.2.9_rc1.ebuild 2911
MD5 52a4951fa28542163e71336339fdbe57 proftpd-1.2.9_rc2.ebuild 3036
-MD5 12e2cf75f54fe4b37392ea2574efbf73 proftpd-1.2.9_rc2-r1.ebuild 3157
+MD5 7312398ea208fcb46ef6709cbdc295d8 proftpd-1.2.9_rc2-r1.ebuild 3160
MD5 6236a589ef01778d118911281b20be51 files/digest-proftpd-1.2.5-r1 66
MD5 c1dc1d9278d5b77f53ea44ee848dafc6 files/digest-proftpd-1.2.7 211
MD5 cb6cd6133728449d0da092b1d6147b9d files/digest-proftpd-1.2.8 66
diff --git a/net-ftp/proftpd/files/digest-proftpd-1.2.9_rc2-r1 b/net-ftp/proftpd/files/digest-proftpd-1.2.9_rc2-r1
new file mode 100644
index 000000000000..ea05d4753d99
--- /dev/null
+++ b/net-ftp/proftpd/files/digest-proftpd-1.2.9_rc2-r1
@@ -0,0 +1 @@
+MD5 27e3f62a5615999adbbebcefa92b4510 proftpd-1.2.9rc2p.tar.bz2 811669
diff --git a/net-ftp/proftpd/files/proftpd-1.2.9_rc2-dirtree-r118.patch b/net-ftp/proftpd/files/proftpd-1.2.9_rc2-dirtree-r118.patch
new file mode 100644
index 000000000000..2eeb23880ae2
--- /dev/null
+++ b/net-ftp/proftpd/files/proftpd-1.2.9_rc2-dirtree-r118.patch
@@ -0,0 +1,16 @@
+Index: src/dirtree.c
+===================================================================
+RCS file: /cvsroot/proftp/proftpd/src/dirtree.c,v
+retrieving revision 1.118
+diff -u -r1.118 dirtree.c
+--- src/dirtree.c 9 Sep 2003 01:04:26 -0000 1.118
++++ src/dirtree.c 28 Sep 2003 01:05:55 -0000
+@@ -2136,7 +2136,7 @@
+ else
+ path = NULL;
+
+- if (path && *path) {
++ if (path) {
+ if (*(path + strlen(path) - 1) == '*')
+ *(path +strlen(path) - 1) = '\0';
+
diff --git a/net-ftp/proftpd/proftpd-1.2.9_rc2-r1.ebuild b/net-ftp/proftpd/proftpd-1.2.9_rc2-r1.ebuild
new file mode 100644
index 000000000000..3b0bc34001bb
--- /dev/null
+++ b/net-ftp/proftpd/proftpd-1.2.9_rc2-r1.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/proftpd-1.2.9_rc2-r1.ebuild,v 1.1 2003/10/13 16:19:54 solar Exp $
+
+
+inherit flag-o-matic
+
+IUSE="ldap pam postgres mysql ssl tcpd ipv6"
+
+MY_P=${P/_/}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="An advanced and very configurable FTP server"
+SRC_URI="ftp://ftp.proftpd.org/distrib/source/${MY_P}p.tar.bz2"
+HOMEPAGE="http://www.proftpd.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~hppa ~alpha ~ppc"
+
+DEPEND="net-libs/libpcap
+ pam? ( >=sys-libs/pam-0.75 )
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ ldap? ( >=net-nds/openldap-1.2.11 )
+ postgres? ( >=dev-db/postgresql-7.3 )
+ ssl? ( >=dev-libs/openssl-0.9.6f )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r3 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ [ "$PV" == "1.2.9_rc2" ] && epatch ${FILESDIR}/${PN}-${PV}-dirtree-r118.patch
+}
+src_compile() {
+ local modules myconf
+
+ modules="mod_ratio:mod_readme"
+ use pam && modules="${modules}:mod_auth_pam"
+ use tcpd && modules="${modules}:mod_wrap"
+
+ if use ldap; then
+ einfo ldap
+ modules="${modules}:mod_ldap"
+ export LDFLAGS="-lresolv"
+ fi
+
+ if use ssl; then
+ einfo ssl
+ # enable mod_tls
+ modules="${modules}:mod_tls"
+ fi
+
+ if use mysql; then
+ modules="${modules}:mod_sql:mod_sql_mysql"
+ myconf="--with-includes=/usr/include/mysql"
+ elif use postgres; then
+ modules="${modules}:mod_sql:mod_sql_postgres"
+ myconf="--with-includes=/usr/include/postgresql"
+ fi
+
+ # New modules for 1.2.9
+ # Not sure how these should be enabled yet as no use variables
+ # apply currently. Uncomment if you want to use them though.
+ # -raker 06/16/2003
+ #
+ # modules="${modules}:mod_ifsession"
+ # modules="${modules}:mod_radius"
+ # modules="${modules}:mod_rewrite"
+
+ # bug #30359
+ has_version sys-devel/hardened-gcc && echo > lib/libcap/cap_sys.c
+ is-flag -fPIC && echo > lib/libcap/cap_sys.c
+
+ econf \
+ --sbindir=/usr/sbin \
+ --localstatedir=/var/run \
+ --sysconfdir=/etc/proftpd \
+ --enable-shadow \
+ --disable-sendfile \
+ --enable-autoshadow \
+ --with-modules=${modules} \
+ ${myconf} $( use_enable ipv6 ) || die "bad ./configure"
+
+ make || die "compile problem"
+}
+
+src_install() {
+ # Note rundir needs to be specified to avoid sandbox violation
+ # on initial install. See Make.rules
+ make DESTDIR=${D} install || die
+
+ keepdir /home/ftp
+ keepdir /var/run/proftpd
+
+ dodoc contrib/README.mod_sql ${FILESDIR}/proftpd.conf \
+ COPYING CREDITS ChangeLog NEWS README* \
+ doc/{license.txt,GetConf}
+ dohtml doc/*.html
+ docinto rfc
+ dodoc doc/rfc/*.txt
+
+ mv ${D}/etc/proftpd/proftpd.conf ${D}/etc/proftpd/proftpd.conf.distrib
+
+ insinto /etc/proftpd
+ newins ${FILESDIR}/proftpd.conf proftpd.conf.sample
+
+ if use pam; then
+ insinto /etc/pam.d
+ newins ${S}/contrib/dist/rpm/ftp.pamd ftp
+ fi
+
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/proftpd.xinetd proftpd
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/proftpd.rc6 proftpd
+}
+
+pkg_postinst() {
+ groupadd proftpd &>/dev/null
+ id proftpd &>/dev/null || \
+ useradd -g proftpd -d /home/ftp -s /bin/false proftpd
+ einfo
+ einfo 'You can find the config files in /etc/proftpd'
+ einfo
+}