summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKyle Manna <nitro@gentoo.org>2002-07-19 16:08:39 +0000
committerKyle Manna <nitro@gentoo.org>2002-07-19 16:08:39 +0000
commitc1e29b6ae5c1992541c49221bcf7f918f3802b47 (patch)
tree645251a746bba8950f0dbed1319c204ccc5ed3b4 /net-ftp/proftpd
parentScrapped the manual file install. Finally figured out the required (diff)
downloadhistorical-c1e29b6ae5c1992541c49221bcf7f918f3802b47.tar.gz
historical-c1e29b6ae5c1992541c49221bcf7f918f3802b47.tar.bz2
historical-c1e29b6ae5c1992541c49221bcf7f918f3802b47.zip
Added new masked release candidate.
Diffstat (limited to 'net-ftp/proftpd')
-rw-r--r--net-ftp/proftpd/ChangeLog6
-rw-r--r--net-ftp/proftpd/files/digest-proftpd-1.2.6_rc11
-rw-r--r--net-ftp/proftpd/proftpd-1.2.6_rc1.ebuild99
3 files changed, 105 insertions, 1 deletions
diff --git a/net-ftp/proftpd/ChangeLog b/net-ftp/proftpd/ChangeLog
index ad83614bf490..b729716aff67 100644
--- a/net-ftp/proftpd/ChangeLog
+++ b/net-ftp/proftpd/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for net-ftp/proftpd
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/ChangeLog,v 1.7 2002/06/27 22:37:44 bass Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/ChangeLog,v 1.8 2002/07/19 16:08:39 nitro Exp $
+*proftpd-1.2.6_rc1 (19 Jul 2002)
+ 19 Jul 2002; Kyle Manna <nitro@gentoo.org> proftpd-1.2.6_rc1.ebuild
+
+ Added masked release candidate. Please test.
*proftpd-1.2.5-r1 (20 Jun 2002)
diff --git a/net-ftp/proftpd/files/digest-proftpd-1.2.6_rc1 b/net-ftp/proftpd/files/digest-proftpd-1.2.6_rc1
new file mode 100644
index 000000000000..07de557fe643
--- /dev/null
+++ b/net-ftp/proftpd/files/digest-proftpd-1.2.6_rc1
@@ -0,0 +1 @@
+MD5 8bbe9e82cbcde203edfbf6dfc0562b71 proftpd-1.2.6rc1.tar.bz2 565290
diff --git a/net-ftp/proftpd/proftpd-1.2.6_rc1.ebuild b/net-ftp/proftpd/proftpd-1.2.6_rc1.ebuild
new file mode 100644
index 000000000000..13fad0af9468
--- /dev/null
+++ b/net-ftp/proftpd/proftpd-1.2.6_rc1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/proftpd/proftpd-1.2.6_rc1.ebuild,v 1.1 2002/07/19 16:08:39 nitro Exp $
+
+PV=1.2.6rc1
+P=${PN}-${PV}
+S=${WORKDIR}/${P}
+
+DESCRIPTION="An advanced and very configurable FTP server"
+SRC_URI="ftp://ftp.proftpd.org/distrib/source/${P}.tar.bz2"
+HOMEPAGE="http://www.proftpd.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc"
+
+DEPEND="virtual/glibc
+ pam? ( >=sys-libs/pam-0.75 )
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ ldap? ( >=net-nds/openldap-1.2.11 )
+ postgres? ( >=dev-db/postgresql-7.1 )"
+
+src_unpack() {
+
+#Fix bug #3791
+
+ unpack ${P}.tar.bz2
+ cd ${WORKDIR}/${P}
+ patch contrib/mod_sql_postgres.c < ${FILESDIR}/mod_sql_postgres.c.patch || die "config patch failed"
+}
+
+src_compile() {
+ local modules myconf
+
+ modules="mod_ratio:mod_readme:mod_linuxprivs"
+ use pam && modules="${modules}:mod_pam"
+ use ldap && modules="${modules}:mod_ldap"
+
+ if [ "`use mysql`" ] ; then
+ modules="${modules}:mod_sql:mod_sql_mysql"
+ elif [ "`use postgres`" ] ; then
+ modules="${modules}:mod_sql:mod_sql_postgres"
+ myconf="--with-includes=/usr/include/postgresql"
+ fi
+
+ use ldap && export LDFLAGS="-lresolv"
+
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/sbin \
+ --mandir=/usr/share/man \
+ --localstatedir=/var/run \
+ --sysconfdir=/etc/proftpd \
+ --enable-shadow \
+ --disable-sendfile \
+ --enable-autoshadow \
+ --with-modules=${modules} \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+
+ #Note rundir needs to be specified to avoid sanbox violation
+ #on initial install. See Make.rules
+ make \
+ prefix=${D}/usr \
+ sbindir=${D}/usr/sbin \
+ mandir=${D}/usr/share/man \
+ localstatedir=${D}/var/run \
+ rundir=${D}/var/run/proftpd \
+ sysconfdir=${D}/etc/proftpd \
+ install || die
+
+ #dobin contrib/genuser.pl
+ dodir /home/ftp
+
+ dodoc contrib/README.mod_sql ${FILESDIR}/proftpd.conf \
+ COPYING CREDITS ChangeLog NEWS README* \
+ doc/{API,license.txt,GetConf,ShowUndocumented} \
+ doc/development.notes
+ dohtml doc/*.html
+ docinto rfc
+ dodoc doc/rfc/*.txt
+
+ cd ${D}/etc/proftpd
+ mv proftpd.conf proftpd.conf.distrib
+
+ insinto /etc/proftpd
+ newins ${FILESDIR}/proftpd.conf proftpd.conf.sample
+
+ if [ "`use pam`" ] ; then
+ insinto /etc/pam.d
+ newins ${S}/contrib/dist/rpm/ftp.pamd ftp
+ fi
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/proftpd.rc6 proftpd
+}