summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-04-13 23:31:25 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-04-13 23:31:25 +0000
commite66076eefb87254cd093fbc6b38a538bf777d8c3 (patch)
tree7340f065f1a91b99b887bb1ba7baa257c446fb22 /net-ftp/pure-ftpd
parentinitial ebuild (diff)
downloadhistorical-e66076eefb87254cd093fbc6b38a538bf777d8c3.tar.gz
historical-e66076eefb87254cd093fbc6b38a538bf777d8c3.tar.bz2
historical-e66076eefb87254cd093fbc6b38a538bf777d8c3.zip
new version, removed old one
Diffstat (limited to 'net-ftp/pure-ftpd')
-rw-r--r--net-ftp/pure-ftpd/ChangeLog7
-rw-r--r--net-ftp/pure-ftpd/files/digest-pure-ftpd-1.0.111
-rw-r--r--net-ftp/pure-ftpd/pure-ftpd-1.0.11.ebuild54
3 files changed, 61 insertions, 1 deletions
diff --git a/net-ftp/pure-ftpd/ChangeLog b/net-ftp/pure-ftpd/ChangeLog
index 1e0f1122ec82..2119c706646d 100644
--- a/net-ftp/pure-ftpd/ChangeLog
+++ b/net-ftp/pure-ftpd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-ftp/pure-ftpd
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/pure-ftpd/ChangeLog,v 1.1 2002/02/01 21:53:32 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pure-ftpd/ChangeLog,v 1.2 2002/04/13 23:31:24 verwilst Exp $
+
+ 14 April 2002; Bart Verwilst <verwilst@gentoo.org> ChangeLog :
+
+ Upgraded version, removed old one.. New ebuild (1.0.11) includes pam
+ fixes as well..
*pure-ftpd-1.0.8 (1 Feb 2002)
diff --git a/net-ftp/pure-ftpd/files/digest-pure-ftpd-1.0.11 b/net-ftp/pure-ftpd/files/digest-pure-ftpd-1.0.11
new file mode 100644
index 000000000000..7dcc2f880a73
--- /dev/null
+++ b/net-ftp/pure-ftpd/files/digest-pure-ftpd-1.0.11
@@ -0,0 +1 @@
+MD5 dbe22575c6bc6fa234d65372482900b5 pure-ftpd-1.0.11.tar.bz2 373109
diff --git a/net-ftp/pure-ftpd/pure-ftpd-1.0.11.ebuild b/net-ftp/pure-ftpd/pure-ftpd-1.0.11.ebuild
new file mode 100644
index 000000000000..52ed99fcbcb8
--- /dev/null
+++ b/net-ftp/pure-ftpd/pure-ftpd-1.0.11.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Maintainer: Bart Verwilst <verwilst@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/pure-ftpd/pure-ftpd-1.0.11.ebuild,v 1.1 2002/04/13 23:31:25 verwilst Exp $
+
+S="${WORKDIR}/${P}"
+SRC_URI="http://prdownloads.sourceforge.net/pureftpd/${P}.tar.bz2"
+DESCRIPTION="Pure-FTPd is a fast, production-quality, standard-conformant FTP server"
+HOMEPAGE="http://www.pureftpd.org/"
+SLOT="0"
+DEPEND="virtual/glibc
+ pam? ( >=sys-libs/pam-0.75 )
+ mysql? ( >=dev-db/mysql-3.23.49 )
+ postgres? ( >=dev-db/postgresql-7.2 )
+ ldap? ( >=net-nds/openldap-2.0.21 )"
+
+src_compile() {
+
+ local myconf
+ use pam && myconf="${myconf} --with-pam"
+ use ldap && myconf="${myconf} --with-ldap"
+ use mysql && myconf="${myconf} --with-mysql"
+ use postgres && myconf="${myconf} --with-pgsql"
+
+ ./configure --prefix=/usr --mandir=/usr/share/man \
+ --with-altlog --with-extauth \
+ --with-puredb --with-cookie \
+ --with-throttling --with-ratios \
+ --with-quotas --with-ftpwho \
+ --with-uploadscript --with-virtualhosts \
+ --with-virtualchroot --with-diraliases \
+ --build=${CHOST} ${myconf} || die "configure failed"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ install || die
+ dodoc AUTHORS CONTACT COPYING ChangeLog
+ dodoc FAQ HISTORY INSTALL README* NEWS
+ insinto /etc/ ; doins ${FILESDIR}/ftpusers
+ newdoc ${FILESDIR}/pure-ftpd.conf_d pure-ftpd.conf.sample
+ if [ "`use pam`" ] ; then
+ insinto /etc/pam.d ; doins pam/{ftplockout,pure-ftpd}
+ fi
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pure-ftpd.rc6 pure-ftpd
+
+}
+