summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-06-22 02:40:35 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-06-22 02:40:35 +0000
commit83aca266f2ef4bb3910a2ea80130f1b07def256a (patch)
tree01c5003e891bcf9d238019d18b160693a3b0c670 /net-ftp
parentnew version, bump ebuild and change gtk+ dep (diff)
downloadhistorical-83aca266f2ef4bb3910a2ea80130f1b07def256a.tar.gz
historical-83aca266f2ef4bb3910a2ea80130f1b07def256a.tar.bz2
historical-83aca266f2ef4bb3910a2ea80130f1b07def256a.zip
changed dependencies on pygtk so it doesn't break on gnome2 / gtk2 bindings
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/ftpcube/ChangeLog4
-rw-r--r--net-ftp/ftpcube/files/digest-ftpcube-0.3.2-r21
-rw-r--r--net-ftp/ftpcube/ftpcube-0.3.2-r2.ebuild27
3 files changed, 32 insertions, 0 deletions
diff --git a/net-ftp/ftpcube/ChangeLog b/net-ftp/ftpcube/ChangeLog
index 642612fdcccc..1f34c8ac446a 100644
--- a/net-ftp/ftpcube/ChangeLog
+++ b/net-ftp/ftpcube/ChangeLog
@@ -2,7 +2,11 @@
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
# Author: José Alberto Suárez López <bass@gentoo.org>
+
*ftpcube-0.3.2 (13 Jun 2002)
+ 21 Jun 2002; Spider <spider@gentoo.org> ftpcube-0.3.2-r2.ebuild :
+ Tweaked the depenendencies so it doesn't break with pygtk-1.99.x series. incompatible with the new gnome bindings.
+
17 Jun 2002; J.Alberto S.L. <bass@gentoo.org> ftpcube-0.3.2-r1.ebuild:
fixed a problem with icons.
diff --git a/net-ftp/ftpcube/files/digest-ftpcube-0.3.2-r2 b/net-ftp/ftpcube/files/digest-ftpcube-0.3.2-r2
new file mode 100644
index 000000000000..dfbbf655c9ba
--- /dev/null
+++ b/net-ftp/ftpcube/files/digest-ftpcube-0.3.2-r2
@@ -0,0 +1 @@
+MD5 0786b2466030dc4f63e9619d5b7c0566 ftpcube-0.3.2.tar.gz 82407
diff --git a/net-ftp/ftpcube/ftpcube-0.3.2-r2.ebuild b/net-ftp/ftpcube/ftpcube-0.3.2-r2.ebuild
new file mode 100644
index 000000000000..4efc9b9a0314
--- /dev/null
+++ b/net-ftp/ftpcube/ftpcube-0.3.2-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ftpcube/ftpcube-0.3.2-r2.ebuild,v 1.1 2002/06/22 02:40:35 spider Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Graphic ftp client written in python and gtk"
+SRC_URI="mirror://sourceforge/ftpcube/${P}.tar.gz"
+HOMEPAGE="ftpcube.sf.net"
+LICENSE="Artistic"
+DEPEND="( <dev-python/pygtk-1.99.0 )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ python setup.py clean || die "clean fails"
+}
+
+src_install() {
+ dobin ftpcube
+ dodir /usr/lib/python2.2/site-packages/libftpcube
+ insinto /usr/lib/python2.2/site-packages/libftpcube
+ doins libftpcube/*
+ dodir /usr/share/ftpcube/icons
+ insinto /usr/share/ftpcube/icons
+ doins icons/*
+ dosym /usr/share/ftpcube/icons/ftpcube.xpm /usr/share/icons
+ dodoc CHANGELOG README
+}