summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2004-06-28 21:23:02 +0000
committerMichael Januszewski <spock@gentoo.org>2004-06-28 21:23:02 +0000
commitff75e1d74960a1497100ec3c4b224443efc8d8ce (patch)
tree40ee49ffca17e356bc347dc6697199a83919c104 /net-im/ekg
parentPatched rezound 0.9beta to make it compatible with gcc3.3 and the new libfox1... (diff)
downloadhistorical-ff75e1d74960a1497100ec3c4b224443efc8d8ce.tar.gz
historical-ff75e1d74960a1497100ec3c4b224443efc8d8ce.tar.bz2
historical-ff75e1d74960a1497100ec3c4b224443efc8d8ce.zip
Version bump.
Diffstat (limited to 'net-im/ekg')
-rw-r--r--net-im/ekg/ChangeLog7
-rw-r--r--net-im/ekg/Manifest4
-rw-r--r--net-im/ekg/ekg-1.5.ebuild41
-rw-r--r--net-im/ekg/files/digest-ekg-1.51
4 files changed, 51 insertions, 2 deletions
diff --git a/net-im/ekg/ChangeLog b/net-im/ekg/ChangeLog
index b5b313534d7f..87d233722bfd 100644
--- a/net-im/ekg/ChangeLog
+++ b/net-im/ekg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/ekg
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/ekg/ChangeLog,v 1.10 2004/06/24 22:50:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/ekg/ChangeLog,v 1.11 2004/06/28 21:23:02 spock Exp $
+
+*ekg-1.5 (28 Jun 2004)
+
+ 28 Jun 2004; Michal Januszewski <spock@gentoo.org> +ekg-1.5.ebuild:
+ Version bump.
*ekg-1.5_rc2 (13 May 2004)
diff --git a/net-im/ekg/Manifest b/net-im/ekg/Manifest
index c90d50d98019..41cf9629df65 100644
--- a/net-im/ekg/Manifest
+++ b/net-im/ekg/Manifest
@@ -2,11 +2,13 @@ MD5 08211275c9d8c870ec1966320be6f6b7 ekg-1.4.ebuild 1109
MD5 3b274a0980356156a3dc9b9a492511d0 ekg-1.4-r1.ebuild 1109
MD5 5ad95326144dbaf024661234071adbf9 ekg-1.5_rc2.ebuild 1230
MD5 d2e44bfd92cfba992ef02716103fb8ea ekg-1.3.ebuild 974
+MD5 a01481ed56f66d228a74f94840ed510b ekg-1.5.ebuild 1223
MD5 dcf6c424b2d92e92ab1a6d530b723a63 ekg-1.5_rc1.ebuild 1230
-MD5 049e96c2a9bd0bb10beb1479ce6a5323 ChangeLog 2068
+MD5 297b965595eeae99b81c6b3b3e940524 ChangeLog 2176
MD5 d94d306da3804e41296e1bf04c7c9cae metadata.xml 255
MD5 2bc5f13c9e2cc840a2f8f61fc3a51391 files/digest-ekg-1.4-r1 59
MD5 61a8d228207769381b68425490e01c3c files/digest-ekg-1.5_rc1 62
MD5 75aeb8acff541767e9811b0b68de6f65 files/digest-ekg-1.5_rc2 62
MD5 fa4379b937783ca0ff3bc06452e35ea1 files/digest-ekg-1.3 59
MD5 2bc5f13c9e2cc840a2f8f61fc3a51391 files/digest-ekg-1.4 59
+MD5 fabb312576862c943792eed047bac7a8 files/digest-ekg-1.5 59
diff --git a/net-im/ekg/ekg-1.5.ebuild b/net-im/ekg/ekg-1.5.ebuild
new file mode 100644
index 000000000000..696cc7963670
--- /dev/null
+++ b/net-im/ekg/ekg-1.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/ekg/ekg-1.5.ebuild,v 1.1 2004/06/28 21:23:02 spock Exp $
+
+IUSE="ssl ncurses zlib python spell"
+
+DESCRIPTION="EKG (Eksperymentalny Klient Gadu-Gadu) - a text client for Polish instant messaging system Gadu-Gadu"
+HOMEPAGE="http://dev.null.pl/ekg/"
+SRC_URI="http://dev.null.pl/ekg/${P/_/}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~ia64 ~amd64"
+
+S="${WORKDIR}/${P/_/}"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6 )
+ ncurses? ( sys-libs/ncurses )
+ !ncurses? ( sys-libs/readline )
+ zlib? ( sys-libs/zlib )
+ python? ( dev-lang/python )
+ spell? ( >=app-text/aspell-0.50.3 )"
+
+src_compile() {
+
+ local myconf="--enable-ioctld --enable-shared --with-pthread --enable-dynamic"
+ use ssl || myconf="$myconf --disable-openssl"
+ use ncurses || myconf="$myconf --disable-ui-ncurses --enable-ui-readline"
+ use zlib || myconf="$myconf --disable-zlib"
+ use python && myconf="$myconf --with-python"
+ use spell && myconf="$myconf --enable-aspell"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+
+ einstall || die
+ dodoc docs/* docs/api/*
+}
diff --git a/net-im/ekg/files/digest-ekg-1.5 b/net-im/ekg/files/digest-ekg-1.5
new file mode 100644
index 000000000000..c7c7de0f535c
--- /dev/null
+++ b/net-im/ekg/files/digest-ekg-1.5
@@ -0,0 +1 @@
+MD5 721ebfe7b13e9531b30d558465e6695f ekg-1.5.tar.gz 483606