summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-04-06 21:19:12 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-04-06 21:19:12 +0000
commitdc77568b2f2f91f09b5e4ddd0599c09963a838fc (patch)
treef3930c9f3af0aab8b756124021c0e07ec57507b3 /net-im/gaim
parentInitial Version (diff)
downloadhistorical-dc77568b2f2f91f09b5e4ddd0599c09963a838fc.tar.gz
historical-dc77568b2f2f91f09b5e4ddd0599c09963a838fc.tar.bz2
historical-dc77568b2f2f91f09b5e4ddd0599c09963a838fc.zip
Add encryption - 1
Diffstat (limited to 'net-im/gaim')
-rw-r--r--net-im/gaim/gaim-0.60-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/net-im/gaim/gaim-0.60-r1.ebuild b/net-im/gaim/gaim-0.60-r1.ebuild
new file mode 100644
index 000000000000..5da25939ceb8
--- /dev/null
+++ b/net-im/gaim/gaim-0.60-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-0.60-r1.ebuild,v 1.1 2003/04/06 21:19:12 lostlogic Exp $
+
+IUSE="nls perl spell ssl nas"
+
+DESCRIPTION="GTK Instant Messenger client"
+HOMEPAGE="http://gaim.sourceforge.net/"
+EV=1.17
+SRC_URI="mirror://sourceforge/gaim/${P}.tar.bz2
+ ssl? ( mirror://sourceforge/gaim-encryption/encrypt-${EV}.tar.gz )"
+
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc"
+
+DEPEND="=sys-libs/db-1*
+ >=x11-libs/gtk+-2.0
+ >=dev-libs/glib-2.0
+ nas? ( >=media-libs/nas-1.4.1-r1 )
+ nls? ( sys-devel/gettext )
+ media-libs/libao
+ >=media-libs/audiofile-0.2.0
+ perl? ( >=dev-lang/perl-5.6.1 )
+ ssl? ( dev-libs/openssl )
+ spell? ( >=app-text/gtkspell-2.0.2 )"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ use ssl && {
+ cd ${S}/plugins
+ unpack encrypt-${EV}.tar.gz
+ cd encrypt
+ patch -p0 < patchfile.0.60 || die "patch for encryption failed"
+ }
+}
+
+src_compile() {
+ local myconf
+ use perl || myconf="${myconf} --disable-perl"
+ use spell || myconf="${myconf} --disable-gtkspell"
+ use nls || myconf="${myconf} --disable-nls"
+ use nas && myconf="${myconf} --enable-nas" || myconf="${myconf} --disable-nas"
+
+ econf ${myconf} || die "Configuration failed"
+ emake || die "Make failed"
+}
+
+src_install() {
+ einstall || die "Install failed"
+ dodoc ABOUT-NLS AUTHORS HACKING INSTALL NEWS README TODO ChangeLog
+}