summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-07-18 19:41:46 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-07-18 19:41:46 +0000
commitf92ea9e77b6f81760c32021fab3acc6ce9605ca3 (patch)
treec9b1f738b9821d1405e4460ed0d0ee6907dfb80e /net-im/gaim
parentBumpage from upstream (diff)
downloadhistorical-f92ea9e77b6f81760c32021fab3acc6ce9605ca3.tar.gz
historical-f92ea9e77b6f81760c32021fab3acc6ce9605ca3.tar.bz2
historical-f92ea9e77b6f81760c32021fab3acc6ce9605ca3.zip
Bumpage from upstream
Diffstat (limited to 'net-im/gaim')
-rw-r--r--net-im/gaim/Manifest4
-rw-r--r--net-im/gaim/files/digest-gaim-0.662
-rw-r--r--net-im/gaim/gaim-0.66.ebuild78
3 files changed, 82 insertions, 2 deletions
diff --git a/net-im/gaim/Manifest b/net-im/gaim/Manifest
index 215ba79622f4..c693dc0ca004 100644
--- a/net-im/gaim/Manifest
+++ b/net-im/gaim/Manifest
@@ -1,8 +1,8 @@
MD5 63f5d5add45a34870e61e2e39d70b919 gaim-0.63-r1.ebuild 1835
-MD5 c0e476b7820974a1312abcdbe702b29b gaim-0.66.ebuild 2166
+MD5 563bfa3942598d75f097aaf618e9bfe3 gaim-0.66.ebuild 2163
MD5 c312c7f2f86088e2cbae1c306fb009ee gaim-0.59.9-r1.ebuild 2173
MD5 75b5b8d5565abeeca9fdad904cc765d6 gaim-0.65-r1.ebuild 2167
-MD5 7724a34077a43f92863a62eed9714ec9 ChangeLog 10461
+MD5 1d54dc5487b4a08728d8708b15535074 ChangeLog 10609
MD5 07beb4e67f5dd8cafed146e45b919144 files/digest-gaim-0.59.9-r1 128
MD5 ee8fb28717ed5fd8bdfce0b4c0611d75 files/digest-gaim-0.66 126
MD5 908f7feabba8c8b1d74510f1f2b7706d files/digest-gaim-0.63-r1 126
diff --git a/net-im/gaim/files/digest-gaim-0.66 b/net-im/gaim/files/digest-gaim-0.66
new file mode 100644
index 000000000000..15a8f62cec60
--- /dev/null
+++ b/net-im/gaim/files/digest-gaim-0.66
@@ -0,0 +1,2 @@
+MD5 80c52fc8c969a65ea7bbd6444142fe5f gaim-0.66.tar.bz2 2744562
+MD5 09f3ae70c4998a4aeb5473bb4e212bfa encrypt-2.00.tar.gz 73991
diff --git a/net-im/gaim/gaim-0.66.ebuild b/net-im/gaim/gaim-0.66.ebuild
new file mode 100644
index 000000000000..2a9c3542fd6f
--- /dev/null
+++ b/net-im/gaim/gaim-0.66.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-0.66.ebuild,v 1.1 2003/07/18 19:41:42 lostlogic Exp $
+
+IUSE="nls perl spell nas ssl cjk"
+
+DESCRIPTION="GTK Instant Messenger client"
+HOMEPAGE="http://gaim.sourceforge.net/"
+EV=2.00
+SRC_URI="mirror://sourceforge/gaim/${P}.tar.bz2
+ ssl? ( mirror://sourceforge/gaim-encryption/encrypt-${EV}.tar.gz )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc"
+
+DEPEND="=sys-libs/db-1*
+ >=x11-libs/gtk+-2.0
+ >=dev-libs/glib-2.0
+ nas? ( >=media-libs/nas-1.4.1-r1 )
+ sys-devel/gettext
+ media-libs/libao
+ >=media-libs/audiofile-0.2.0
+ perl? ( >=dev-lang/perl-5.6.1 )
+ ssl? ( dev-libs/nss )
+ spell? ( >=app-text/gtkspell-2.0.2 )"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ cd ${P}
+ use ssl && {
+ cd ${S}/plugins
+ unpack encrypt-${EV}.tar.gz
+ cd encrypt
+ epatch patchfile.0.65
+ touch aclocal.m4 \
+ config.h.in \
+ Makefile.in \
+ */Makefile.in \
+ */*/Makefile.in \
+ */*/*/Makefile.in \
+ configure
+ ln ../../mkinstalldirs ../../../mkinstalldirs
+ }
+ use cjk && {
+ cd ${S}/src
+ epatch ${FILESDIR}/gaim_gtkimcontext_patch.diff
+ }
+}
+
+src_compile() {
+
+ local myconf
+ use perl || myconf="${myconf} --disable-perl"
+ use spell || myconf="${myconf} --disable-gtkspell"
+ use nls || myconf="${myconf} --disable-nls"
+ use nas && myconf="${myconf} --enable-nas" || myconf="${myconf} --disable-nas"
+
+ econf ${myconf} || die "Configuration failed"
+ emake || MAKEOPTS="${MAKEOPTS} -j1" emake || die "Make failed"
+}
+
+src_install() {
+ einstall || die "Install failed"
+ dodoc ABOUT-NLS AUTHORS HACKING INSTALL NEWS README TODO ChangeLog
+}
+
+pkg_postinst() {
+ if [ `use ssl` ]; then
+ ewarn
+ ewarn "You have chosen (by selecting 'USE=ssl') to install"
+ ewarn "the gaim-encryption plugin ( http://gaim-encryption.sf.net/ )"
+ ewarn "this plugin is NOT supported by the Gaim project, and if you"
+ ewarn "expierence problems related to it, contact the Gentoo project"
+ ewarn "via http://bugs.gentoo.org/ or the gaim-encryption project."
+ ewarn
+ fi
+}