summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2003-10-13 21:50:20 +0000
committerStefan Knoblich <stkn@gentoo.org>2003-10-13 21:50:20 +0000
commit4840d1b8ba9c806e12be32e474514f42ff93d4b3 (patch)
tree0f4e815bf2cd002d74a05f427be62b9691bada48 /net-im/linphone
parentmake openh323u.mak pathes point to right locations, (required for other apps) (diff)
downloadhistorical-4840d1b8ba9c806e12be32e474514f42ff93d4b3.tar.gz
historical-4840d1b8ba9c806e12be32e474514f42ff93d4b3.tar.bz2
historical-4840d1b8ba9c806e12be32e474514f42ff93d4b3.zip
new maintainer. version bumped
Diffstat (limited to 'net-im/linphone')
-rw-r--r--net-im/linphone/ChangeLog7
-rw-r--r--net-im/linphone/Manifest5
-rw-r--r--net-im/linphone/files/digest-linphone-0.12.01
-rw-r--r--net-im/linphone/linphone-0.12.0.ebuild55
-rw-r--r--net-im/linphone/metadata.xml10
5 files changed, 76 insertions, 2 deletions
diff --git a/net-im/linphone/ChangeLog b/net-im/linphone/ChangeLog
index 2ce9586043aa..ac7344d802b7 100644
--- a/net-im/linphone/ChangeLog
+++ b/net-im/linphone/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-im/linphone
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/linphone/ChangeLog,v 1.6 2003/09/25 18:27:02 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/linphone/ChangeLog,v 1.7 2003/10/13 21:50:14 stkn Exp $
+
+*linphone-0.12.0 (04 Oct 2003)
+
+ 04 Oct 2003; Stefan Knoblich <stkn@gentoo.org> linphone-0.12.0.ebuild:
+ Version bumped. Changed dependency from alsa-driver to alsa-lib.
26 Sep 2003; Martin Holzer <mholzer@gentoo.org> linphone-0.10.2.ebuild:
Added IUSE flags. Closes #29265.
diff --git a/net-im/linphone/Manifest b/net-im/linphone/Manifest
index 637bdae19d12..37e249317368 100644
--- a/net-im/linphone/Manifest
+++ b/net-im/linphone/Manifest
@@ -1,5 +1,8 @@
-MD5 05f30a14abc0d94a0c03705763872616 ChangeLog 982
+MD5 ce57a167c90208412d27cbdf04f70a2a ChangeLog 1152
MD5 e761e4337fc06d01607d56119a3d2bdd linphone-0.10.2.ebuild 1337
MD5 8c55808e1d3d72bb970ecb50d69aa0e5 linphone-0.9.0-r1.ebuild 1025
+MD5 c6875681379825448264d56b9a2aeca3 linphone-0.12.0.ebuild 1330
+MD5 bf329e2b298c08082a3ff4dfe6c236b3 metadata.xml 315
MD5 29e56d450d4aa47d230872e2b18eae40 files/digest-linphone-0.10.2 68
MD5 a0232ab5ebf0e61290df410da9561c26 files/digest-linphone-0.9.0-r1 67
+MD5 f271139e66524e42ff3a35b3b442dc87 files/digest-linphone-0.12.0 68
diff --git a/net-im/linphone/files/digest-linphone-0.12.0 b/net-im/linphone/files/digest-linphone-0.12.0
new file mode 100644
index 000000000000..3260b762867c
--- /dev/null
+++ b/net-im/linphone/files/digest-linphone-0.12.0
@@ -0,0 +1 @@
+MD5 79abbdcbec4c59cdd28a2722fe333b6e linphone-0.12.0.tar.gz 2751318
diff --git a/net-im/linphone/linphone-0.12.0.ebuild b/net-im/linphone/linphone-0.12.0.ebuild
new file mode 100644
index 000000000000..c22908544e54
--- /dev/null
+++ b/net-im/linphone/linphone-0.12.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/linphone/linphone-0.12.0.ebuild,v 1.1 2003/10/13 21:50:14 stkn Exp $
+
+IUSE="doc gnome gtk2 gtk nls xv alsa"
+
+DESCRIPTION="Linphone is a Web phone with a GNOME interface."
+HOMEPAGE="http://www.linphone.org/?lang=us"
+SRC_URI="http://simon.morlat.free.fr/download/${PV}/source/${P}.tar.gz"
+
+SLOT="1"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
+
+DEPEND="dev-libs/glib
+ >=net-libs/libosip-0.9.6
+ dev-util/pkgconfig
+ xv? ( dev-lang/nasm )
+ gtk? ( =x11-libs/gtk+-1.2* )
+ gtk2? ( >=x11-libs/gtk+-2 )
+ gnome? ( gnome-base/gnome-panel
+ gnome-base/libgnome
+ gnome-base/libgnomeui )
+ alsa? ( >media-libs/alsa-lib-0.5 )
+ doc? ( dev-util/gtk-doc )"
+
+src_compile() {
+
+ local myconf
+
+ if use gnome
+ then
+ use gtk2 && myconf="${myconf} --enable-platform-gnome-2"
+ else
+ use gnome || myconf="${myconf}--enable-gnome_ui=no"
+ fi
+
+ if use gtk && use doc
+ then
+ myconf="${myconf} --enable-gtk-doc"
+ else
+ myconf="${myconf} --disable-gtk-doc"
+ fi
+
+ econf \
+ `use_enable alsa` \
+ `use_enable nls` \
+ ${myconf} || die
+ emake || die
+}
+
+src_install () {
+ dodoc ABOUT-NLS COPYING README AUTHORS BUGS INSTALL NEWS ChangeLog TODO
+ einstall PIXDESTDIR=${D} || die
+}
diff --git a/net-im/linphone/metadata.xml b/net-im/linphone/metadata.xml
new file mode 100644
index 000000000000..c1d12ddea706
--- /dev/null
+++ b/net-im/linphone/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>voip</herd>
+<maintainer>
+ <email>stkn@gentoo.org</email>
+ <name>Stefan Knoblich</name>
+ <description>voip herd will be taking care of this</description>
+</maintainer>
+</pkgmetadata>