summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-09-24 20:23:32 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-09-24 20:23:32 +0000
commit165929011bd31b855e4bf9cfd8b63b31d8a332bf (patch)
tree5fbcd45cb33af30a6799fff6886d3eba85266d06 /net-im/linpopup
parentVersion bumped. (diff)
downloadhistorical-165929011bd31b855e4bf9cfd8b63b31d8a332bf.tar.gz
historical-165929011bd31b855e4bf9cfd8b63b31d8a332bf.tar.bz2
historical-165929011bd31b855e4bf9cfd8b63b31d8a332bf.zip
Version bumped.
Diffstat (limited to 'net-im/linpopup')
-rw-r--r--net-im/linpopup/Manifest4
-rw-r--r--net-im/linpopup/files/digest-linpopup-2.0.21
-rw-r--r--net-im/linpopup/files/linpopup.desktop9
-rw-r--r--net-im/linpopup/linpopup-2.0.2.ebuild56
4 files changed, 68 insertions, 2 deletions
diff --git a/net-im/linpopup/Manifest b/net-im/linpopup/Manifest
index cb7240c1564b..a7fd254496a7 100644
--- a/net-im/linpopup/Manifest
+++ b/net-im/linpopup/Manifest
@@ -1,6 +1,6 @@
-MD5 a9aaf7fe7f3c990f6d6b6abbab826ca9 ChangeLog 420
+MD5 c83364d6b6456c310a25385dd0d9020d ChangeLog 657
MD5 f43d01c82f73619d1e883759dcb40bab linpopup-1.2.0.ebuild 1809
-MD5 5b5f2b1ed55e892a12618ac668462009 linpopup-2.0.2.ebuild 1443
+MD5 60fe09bef8971bb071ee37beb3c14ea3 linpopup-2.0.2.ebuild 1544
MD5 535a60b1905be6c3c0349c488220e30c files/digest-linpopup-1.2.0 70
MD5 cc6067f86d972179bff61a52dbec66fa files/digest-linpopup-2.0.2 67
MD5 64959795c47be33ab1bf172f96c02371 files/linpopup.desktop 188
diff --git a/net-im/linpopup/files/digest-linpopup-2.0.2 b/net-im/linpopup/files/digest-linpopup-2.0.2
new file mode 100644
index 000000000000..e1e64a30cd87
--- /dev/null
+++ b/net-im/linpopup/files/digest-linpopup-2.0.2
@@ -0,0 +1 @@
+MD5 922608ba0cc1f54c1922a8801cfc3818 linpopup-2.0.2.tar.bz2 126173
diff --git a/net-im/linpopup/files/linpopup.desktop b/net-im/linpopup/files/linpopup.desktop
new file mode 100644
index 000000000000..ee2b99401ffe
--- /dev/null
+++ b/net-im/linpopup/files/linpopup.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=LinPopUp
+Comment=Send and recieve network messages
+Exec=LinPopUp
+StartupNotify=false
+Terminal=false
+Type=Application
+Icon=linpopup.xpm
+Categories=Application;Network;
diff --git a/net-im/linpopup/linpopup-2.0.2.ebuild b/net-im/linpopup/linpopup-2.0.2.ebuild
new file mode 100644
index 000000000000..649282e56de0
--- /dev/null
+++ b/net-im/linpopup/linpopup-2.0.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/linpopup/linpopup-2.0.2.ebuild,v 1.1 2003/09/24 20:23:27 mholzer Exp $
+
+inherit gnome2
+
+SRC_URI="mirror://sourceforge/linpopup2/${P}.tar.bz2"
+
+DESCRIPTION="GTK2 port of the LinPopUp messaging client for Samba"
+HOMEPAGE="http://linpopup2.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+RDEPEND=">=x11-libs/gtk+-2
+ >=dev-libs/glib-2
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=net-fs/samba-2.2.8a"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS BUGS COPYING ChangeLog INSTALL MANUAL NEWS README THANKS TODO"
+
+S=${WORKDIR}/${P}
+
+src_install() {
+ # Install icon and .desktop for menu entry
+ if [ `use gnome` ] ; then
+ insinto /usr/share/pixmaps
+ newins ${S}/pixmaps/icon_256.xpm linpopup.xpm
+ insinto /usr/share/applications
+ doins ${FILESDIR}/linpopup.desktop
+ fi
+
+ gnome2_src_install
+}
+
+pkg_postinst() {
+ echo
+ einfo "To be able to receive messages that are sent to you, you will need to"
+ einfo "edit your /etc/samba/smb.conf file."
+ einfo
+ einfo "Add this line to the [global settings] section:"
+ einfo
+ einfo " message command = /usr/bin/linpopup \"%f\" \"%m\" %s; rm %s"
+ einfo
+ einfo "PLEASE NOTE that \"%f\" is not the same thing as %f , '%f' or %f"
+ einfo "and take care to enter \"%f\" \"%m\" %s exactly as shown above."
+ einfo
+ einfo "For more information, please refer to the documentation, found in"
+ einfo "/usr/share/doc/${P}/"
+ echo
+}