summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2007-11-20 00:41:03 +0000
committerWolfram Schlich <wschlich@gentoo.org>2007-11-20 00:41:03 +0000
commitbebeda41ea1ef4b368bd56170e1a294411238083 (patch)
tree0c0427f6f0229362d23babb14335d3c3a8bf6c89 /net-im/mcabber/mcabber-0.9.4.ebuild
parentmask USE=otr for net-im/mcabber (diff)
downloadhistorical-bebeda41ea1ef4b368bd56170e1a294411238083.tar.gz
historical-bebeda41ea1ef4b368bd56170e1a294411238083.tar.bz2
historical-bebeda41ea1ef4b368bd56170e1a294411238083.zip
version bump, add missing otr USE flag
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'net-im/mcabber/mcabber-0.9.4.ebuild')
-rw-r--r--net-im/mcabber/mcabber-0.9.4.ebuild20
1 files changed, 12 insertions, 8 deletions
diff --git a/net-im/mcabber/mcabber-0.9.4.ebuild b/net-im/mcabber/mcabber-0.9.4.ebuild
index b8c0a3c42004..85e50a473a78 100644
--- a/net-im/mcabber/mcabber-0.9.4.ebuild
+++ b/net-im/mcabber/mcabber-0.9.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/mcabber-0.9.4.ebuild,v 1.1 2007/11/19 23:07:59 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/mcabber-0.9.4.ebuild,v 1.2 2007/11/20 00:41:02 wschlich Exp $
DESCRIPTION="A small Jabber console client with various features, like MUC, SSL, PGP"
HOMEPAGE="http://www.lilotux.net/~mikael/mcabber/"
@@ -10,7 +10,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE="crypt spell ssl"
+IUSE="crypt otr spell ssl"
LANGS="de en fr nl pl uk ru"
# localized help versions are installed only, when LINGUAS var is set
@@ -20,6 +20,7 @@ done;
DEPEND="ssl? ( >=dev-libs/openssl-0.9.7-r1 )
crypt? ( >=app-crypt/gpgme-1.0.0 )
+ otr? ( net-libs/libotr )
spell? ( app-text/aspell )
>=dev-libs/glib-2.0.0
sys-libs/ncurses"
@@ -27,6 +28,7 @@ DEPEND="ssl? ( >=dev-libs/openssl-0.9.7-r1 )
src_compile() {
econf \
$(use_enable crypt gpgme) \
+ $(use_enable otr) \
$(use_enable spell aspell) \
$(use_with ssl) \
|| die "econf failed"
@@ -35,10 +37,10 @@ src_compile() {
}
src_install() {
- make install DESTDIR=${D} || die "make install failed"
+ make install DESTDIR="${D}" || die "make install failed"
# clean unneeded language documentation
for i in ${LANGS}; do
- ! use linguas_${i} && rm -rf ${D}/usr/share/${PN}/help/${i}
+ ! use linguas_${i} && rm -rf "${D}"/usr/share/${PN}/help/${i}
done
dodoc AUTHORS ChangeLog NEWS README TODO mcabberrc.example
@@ -46,15 +48,15 @@ src_install() {
# contrib themes
insinto /usr/share/${PN}/themes
- doins ${S}/contrib/themes/*
+ doins "${S}"/contrib/themes/*
# contrib generic scripts
exeinto /usr/share/${PN}/scripts
- doexe ${S}/contrib/*.{pl,py,rb}
+ doexe "${S}"/contrib/*.{pl,py,rb}
# contrib event scripts
exeinto /usr/share/${PN}/scripts/events
- doexe ${S}/contrib/events/*
+ doexe "${S}"/contrib/events/*
}
pkg_postinst() {
@@ -72,10 +74,12 @@ pkg_postinst() {
elog
elog "As of MCabber version 0.8.2, there is also a wizard script"
elog "with which you can create all necessary configuration options."
- elog "To use it, simply execute the following command:"
+ elog "To use it, simply execute the following command (please note that you need"
+ elog "to have dev-lang/ruby installed for it to work!):"
elog
elog " ${ROOT}usr/share/${PN}/scripts/mcwizz.rb"
elog
+ elog
elog "See the CONFIGURATION FILE and FILES sections of the mcabber"
elog "manual page (section 1) for more information."
elog