summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-10-26 23:44:03 +0000
committerAli Polatel <hawking@gentoo.org>2008-10-26 23:44:03 +0000
commitef4d8f270f7736d71b8a74dac41a033c3e1a141b (patch)
treeeae8647814e8d7d620b108e8d5e73ac7e35d4458 /net-im/msnlib/msnlib-3.6-r1.ebuild
parentRevbump. Use EAPI=2 and use dependencies. (diff)
downloadhistorical-ef4d8f270f7736d71b8a74dac41a033c3e1a141b.tar.gz
historical-ef4d8f270f7736d71b8a74dac41a033c3e1a141b.tar.bz2
historical-ef4d8f270f7736d71b8a74dac41a033c3e1a141b.zip
Revbump. Use EAPI=2 and use dependencies.
Package-Manager: portage--svn/cvs/Linux 2.6.26-gentoo x86_64
Diffstat (limited to 'net-im/msnlib/msnlib-3.6-r1.ebuild')
-rw-r--r--net-im/msnlib/msnlib-3.6-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-im/msnlib/msnlib-3.6-r1.ebuild b/net-im/msnlib/msnlib-3.6-r1.ebuild
new file mode 100644
index 000000000000..532d163d7cd7
--- /dev/null
+++ b/net-im/msnlib/msnlib-3.6-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/msnlib/msnlib-3.6-r1.ebuild,v 1.1 2008/10/26 23:44:03 hawking Exp $
+
+EAPI="2"
+inherit python multilib distutils
+
+DESCRIPTION="A Python MSN messenger protocol library and client"
+HOMEPAGE="http://auriga.wearlab.de/~alb/msnlib/"
+SRC_URI="http://auriga.wearlab.de/~alb/msnlib/files/${PV}/${P}.tar.bz2"
+
+LICENSE="OSL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="tk"
+
+DEPEND=">=dev-lang/python-2.2.2[tk?]"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ distutils_src_install
+
+ dodoc doc/* || die "dodoc failed."
+ dobin msn
+ dobin msnsetup
+ use tk && dobin utils/msntk
+
+ insinto /usr/share/doc/${PF}
+ doins msnrc.sample
+}
+
+pkg_postinst() {
+ local module
+ python_version
+ python_mod_compile /usr/$(get_libdir)/python${PYVER}/site-packages/msn{cb,lib}.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}