summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-13 09:52:18 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-13 09:52:18 +0000
commit154e5c40226ffec4ee6199256f9bd2bcf8a0a7a6 (patch)
tree763a8903f0f778291fea402ebc5652cd01e47b54 /net-im/telepathy-mission-control/telepathy-mission-control-5.10.1.ebuild
parentAdd MPL-1.0 to OSI-APPROVED: http://www.opensource.org/licenses/mozilla1.0 (diff)
downloadhistorical-154e5c40226ffec4ee6199256f9bd2bcf8a0a7a6.tar.gz
historical-154e5c40226ffec4ee6199256f9bd2bcf8a0a7a6.tar.bz2
historical-154e5c40226ffec4ee6199256f9bd2bcf8a0a7a6.zip
Bump, port to EAPI4, drop old. Notable changes: better gnome-shell-3.2 support, can use upower to automatically disconnect if the computer is about to suspend, can use networkmanager to track network connectivity. Theoretically can support connman, but I have no way of testing it.
Package-Manager: portage-2.2.0_alpha74/cvs/Linux x86_64
Diffstat (limited to 'net-im/telepathy-mission-control/telepathy-mission-control-5.10.1.ebuild')
-rw-r--r--net-im/telepathy-mission-control/telepathy-mission-control-5.10.1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/net-im/telepathy-mission-control/telepathy-mission-control-5.10.1.ebuild b/net-im/telepathy-mission-control/telepathy-mission-control-5.10.1.ebuild
new file mode 100644
index 000000000000..d3f1b656e828
--- /dev/null
+++ b/net-im/telepathy-mission-control/telepathy-mission-control-5.10.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/telepathy-mission-control/telepathy-mission-control-5.10.1.ebuild,v 1.1 2011/11/13 09:52:18 tetromino Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2:2.5"
+
+inherit python
+
+DESCRIPTION="An account manager and channel dispatcher for the Telepathy framework."
+HOMEPAGE="http://telepathy.freedesktop.org/wiki/Mission%20Control"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
+IUSE="gnome-keyring networkmanager +upower"
+# IUSE="test"
+
+# Fixme: connman support
+RDEPEND=">=net-libs/telepathy-glib-0.13.14
+ >=dev-libs/dbus-glib-0.82
+ gnome-keyring? ( gnome-base/libgnome-keyring )
+ networkmanager? ( >=net-misc/networkmanager-0.7 )
+ upower? ( sys-power/upower )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-libs/libxslt"
+# test? ( dev-python/twisted-words )"
+
+# Tests are broken, see upstream bug #29334
+# upstream doesn't want it enabled everywhere
+RESTRICT="test"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
+src_configure() {
+ # creds is not available and no support mcd-plugins for now
+ econf --disable-static\
+ --disable-mcd-plugins \
+ --disable-schemas-compile \
+ $(use_enable gnome-keyring) \
+ $(use_with networkmanager connectivity nm) \
+ $(use_enable upower)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -exec rm -f '{}' + || die
+}