summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-05-19 23:48:05 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-05-19 23:48:05 +0000
commit573e06704daa450e7a5cca1917ec9559ca68e9b9 (patch)
tree2b5ebd860c10beb6e1e8f5a0b97046f2677b2e0c /net-im
parentfix aclocal-1.6 (diff)
downloadhistorical-573e06704daa450e7a5cca1917ec9559ca68e9b9.tar.gz
historical-573e06704daa450e7a5cca1917ec9559ca68e9b9.tar.bz2
historical-573e06704daa450e7a5cca1917ec9559ca68e9b9.zip
Updated package
Diffstat (limited to 'net-im')
-rw-r--r--net-im/silc-client/ChangeLog8
-rw-r--r--net-im/silc-client/files/digest-silc-client-0.9.11
-rw-r--r--net-im/silc-client/silc-client-0.9.1.ebuild59
3 files changed, 67 insertions, 1 deletions
diff --git a/net-im/silc-client/ChangeLog b/net-im/silc-client/ChangeLog
index 7bbc04015e0d..6f81db8fc78a 100644
--- a/net-im/silc-client/ChangeLog
+++ b/net-im/silc-client/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-im/silc-client/ChangeLog,v 1.1 2002/04/12 19:53:33 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/silc-client/ChangeLog,v 1.2 2002/05/19 23:48:05 rphillips Exp $
+
+*silc-client-0.9.1 (19 May 2002)
+
+ 19 May 2002; Ryan Phillips <rphillips@gentoo.org> silc-client-0.9.1.ebuild :
+
+ Updated package to new version
*silc-client-0.7.6.2 (11 Apr 2002)
11 Apr 2002; Spider <spider@gentoo.org>
diff --git a/net-im/silc-client/files/digest-silc-client-0.9.1 b/net-im/silc-client/files/digest-silc-client-0.9.1
new file mode 100644
index 000000000000..67aac5b7360e
--- /dev/null
+++ b/net-im/silc-client/files/digest-silc-client-0.9.1
@@ -0,0 +1 @@
+MD5 b1b4166adead5cd5534c90f20cd325ec silc-client-0.9.1.tar.bz2 1393411
diff --git a/net-im/silc-client/silc-client-0.9.1.ebuild b/net-im/silc-client/silc-client-0.9.1.ebuild
new file mode 100644
index 000000000000..aa43ef8d074c
--- /dev/null
+++ b/net-im/silc-client/silc-client-0.9.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Stein Magnus Jodal <stein.magnus@jodal.no>
+# Updated by Phil Bordelon <phil@lsu.edu> to sync up to v0.9
+# Maintainer: Chris Houser <chouser@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/net-im/silc-client/silc-client-0.7.6.2.ebuild,v 1.3 2002/04/12 18:54:01 spider Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Secure Internet Live Conferencing"
+SRC_URI="http://www.silcnet.org/download/client/sources/${P}.tar.bz2"
+HOMEPAGE="http://silcnet.org"
+SLOT="0"
+DEPEND="virtual/glibc
+ =dev-libs/glib-1.2*
+ perl? ( sys-devel/perl )
+ sys-libs/ncurses"
+
+src_compile() {
+
+ myconf="--with-ncurses"
+
+ if [ "`use ipv6`" ]; then
+ myconf="${myconf} --enable-ipv6"
+ fi
+
+ if [ "`use socks5`" ]; then
+ myconf="${myconf} --with-socks5"
+ fi
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/silc \
+ --with-helpdir=/usr/share/silc/help \
+ --with-docdir=/usr/share/doc/${P} \
+ --with-simdir=/usr/lib/silc/modules \
+ --with-logsdir=/var/log/silc \
+ ${myconf} || die "./configure failed"
+
+ make || die "make failed"
+}
+
+src_install () {
+ myflags=""
+ if [ "`use perl`" ]
+ then
+ R1="s/installsitearch='//"
+ R2="s/';//"
+ perl_sitearch="`perl -V:installsitearch | sed -e ${R1} -e ${R2}`"
+ myflags="${myflags} INSTALLPRIVLIB=${D}/usr"
+ myflags="${myflags} INSTALLARCHLIB=${D}/${perl_sitearch}"
+ myflags="${myflags} INSTALLSITELIB=${D}/${perl_sitearch}"
+ myflags="${myflags} INSTALLSITEARCH=${D}/${perl_sitearch}"
+ fi
+
+ make DESTDIR=${D} ${myflags} install || die "make install failed"
+ rmdir ${D}/usr/include
+}
+