summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-09-30 17:52:27 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-09-30 17:52:27 +0000
commit6d26a719edcb419defa3a4ef40620927eb888097 (patch)
treea7d2c8ef75be0bb30e2aed7db954cbe9dcf70670 /net-im
parentEncryption is back (diff)
downloadhistorical-6d26a719edcb419defa3a4ef40620927eb888097.tar.gz
historical-6d26a719edcb419defa3a4ef40620927eb888097.tar.bz2
historical-6d26a719edcb419defa3a4ef40620927eb888097.zip
Encryption is back
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gaim/Manifest4
-rw-r--r--net-im/gaim/files/digest-gaim-0.70-r12
-rw-r--r--net-im/gaim/gaim-0.70-r1.ebuild75
3 files changed, 79 insertions, 2 deletions
diff --git a/net-im/gaim/Manifest b/net-im/gaim/Manifest
index 53142d158d16..44e768407fff 100644
--- a/net-im/gaim/Manifest
+++ b/net-im/gaim/Manifest
@@ -1,12 +1,12 @@
MD5 ee85fc80d1fff82c4685bec57769b9fe gaim-0.67.ebuild 2166
-MD5 fbc45768390a291d469f6473b471aaae gaim-0.70-r1.ebuild 2114
+MD5 17ed20caf9b257a875031de4532e34fc gaim-0.70-r1.ebuild 2211
MD5 c8d30850b6d67308ab0ebc7b38985bb1 gaim-0.67-r1.ebuild 2160
MD5 732ec4a141392279f7984b5e2dc73fc3 gaim-0.66-r4.ebuild 1971
MD5 d0e86a7e30272d53c1ae434ebf0d2592 gaim-0.69.ebuild 2226
MD5 836e337188a5f0b1fe7e0de396bec8b9 gaim-0.70.ebuild 2338
MD5 a08cec351051cad09f7b16f12adf5a3a gaim-0.68-r2.ebuild 2395
MD5 b2ac9eb41db9100a22760f81282f388b gaim-0.66-r3.ebuild 1968
-MD5 fcf296c728ef47807f5da603339d41ae ChangeLog 13453
+MD5 c2301bcbd7e7c4ad70f4f1544fd60f83 ChangeLog 13575
MD5 dc9ef26d3efea7cbe38cbe534cdeaa53 metadata.xml 510
MD5 5993641de8d56c2c433f252997c3c39c files/digest-gaim-0.67 135
MD5 dd643cd5d3960ea86bc0107cb9bdbb50 files/digest-gaim-0.69 135
diff --git a/net-im/gaim/files/digest-gaim-0.70-r1 b/net-im/gaim/files/digest-gaim-0.70-r1
new file mode 100644
index 000000000000..07147fab80bb
--- /dev/null
+++ b/net-im/gaim/files/digest-gaim-0.70-r1
@@ -0,0 +1,2 @@
+MD5 13ea95aa040ac5a58c3384709e495329 gaim-0.70.tar.bz2 3178790
+MD5 93abc8274dbe3fcf5702cf5be5731ba9 gaim-encryption-2.13.tar.gz 315903
diff --git a/net-im/gaim/gaim-0.70-r1.ebuild b/net-im/gaim/gaim-0.70-r1.ebuild
new file mode 100644
index 000000000000..8dd7aa9b128b
--- /dev/null
+++ b/net-im/gaim/gaim-0.70-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-0.70-r1.ebuild,v 1.1 2003/09/30 17:52:25 lostlogic Exp $
+
+IUSE="nls perl spell nas ssl"
+
+DESCRIPTION="GTK Instant Messenger client"
+HOMEPAGE="http://gaim.sourceforge.net/"
+EV=2.13
+SRC_URI="mirror://sourceforge/gaim/${P}.tar.bz2
+ ssl? ( mirror://sourceforge/gaim-encryption/gaim-encryption-${EV}.tar.gz )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+DEPEND="=sys-libs/db-1*
+ >=x11-libs/gtk+-2.0
+ >=dev-libs/glib-2.0
+ nas? ( >=media-libs/nas-1.4.1-r1 )
+ sys-devel/gettext
+ media-libs/libao
+ >=media-libs/audiofile-0.2.0
+ perl? ( >=dev-lang/perl-5.6.1
+ >=sys-apps/sed-4.0.0 )
+ dev-libs/nss
+ spell? ( >=app-text/gtkspell-2.0.2 )"
+
+src_unpack() {
+ unpack ${A} || die
+ use ssl && {
+ cd ${S}/plugins
+ unpack gaim-encryption-${EV}.tar.gz
+ }
+}
+
+src_compile() {
+
+ local myconf
+ use perl || myconf="${myconf} --disable-perl"
+ use spell || myconf="${myconf} --disable-gtkspell"
+ use nls || myconf="${myconf} --disable-nls"
+ use nas && myconf="${myconf} --enable-nas" || myconf="${myconf} --disable-nas"
+
+ econf ${myconf} || die "Configuration failed"
+ use perl && sed -i -e 's:^\(PERL_MM_PARAMS =.*PREFIX=\)\(.*\):\1'${D}'\2:' plugins/perl/Makefile
+ emake || MAKEOPTS="${MAKEOPTS} -j1" emake || die "Make failed"
+
+ use ssl && {
+ cd ${S}/plugins/gaim-encryption-${EV}
+ econf || die "Configuration failed for encryption"
+ emake || die "Make failed for encryption"
+ }
+}
+
+src_install() {
+ einstall || die "Install failed"
+ use ssl && {
+ cd ${S}/plugins/gaim-encryption-${EV}
+ einstall || die "Install failed for encryption"
+ cd ${S}
+ }
+ dodoc ABOUT-NLS AUTHORS COPYING HACKING INSTALL NEWS PROGRAMMING_NOTES README ChangeLog VERSION
+}
+
+pkg_postinst() {
+ if [ `use ssl` ]; then
+ ewarn
+ ewarn "You have chosen (by selecting 'USE=ssl') to install"
+ ewarn "the gaim-encryption plugin ( http://gaim-encryption.sf.net/ )"
+ ewarn "this plugin is NOT supported by the Gaim project, and if you"
+ ewarn "expierence problems related to it, contact the Gentoo project"
+ ewarn "via http://bugs.gentoo.org/ or the gaim-encryption project."
+ fi
+}