summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2003-07-23 01:09:43 +0000
committerDon Seiler <rizzo@gentoo.org>2003-07-23 01:09:43 +0000
commit8b4c4596581e764c7b32253277cba2fc6daae51f (patch)
treeb9085d8f2cf223dcfb7737727d41149558ba398e /net-im
parentBump for gaim-encryption bugfix (2.02) (diff)
downloadhistorical-8b4c4596581e764c7b32253277cba2fc6daae51f.tar.gz
historical-8b4c4596581e764c7b32253277cba2fc6daae51f.tar.bz2
historical-8b4c4596581e764c7b32253277cba2fc6daae51f.zip
Bump for gaim-encryption bugfix (2.02)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gaim/Manifest4
-rw-r--r--net-im/gaim/files/digest-gaim-0.66-r22
-rw-r--r--net-im/gaim/gaim-0.66-r2.ebuild70
3 files changed, 74 insertions, 2 deletions
diff --git a/net-im/gaim/Manifest b/net-im/gaim/Manifest
index b1fe1f4bdef0..53861537f670 100644
--- a/net-im/gaim/Manifest
+++ b/net-im/gaim/Manifest
@@ -3,8 +3,8 @@ MD5 b37b9ba4e508160c4a5f837dab2bad94 gaim-0.66-r1.ebuild 1953
MD5 563bfa3942598d75f097aaf618e9bfe3 gaim-0.66.ebuild 2163
MD5 c312c7f2f86088e2cbae1c306fb009ee gaim-0.59.9-r1.ebuild 2173
MD5 75b5b8d5565abeeca9fdad904cc765d6 gaim-0.65-r1.ebuild 2167
-MD5 6c6e4b722f707740b95103dce150653f ChangeLog 10904
-MD5 55e9f4eeec17349bdfbadd3d27f3deb3 gaim-0.66-r2.ebuild 1953
+MD5 d112d725fb383f8768202cf704a138e0 ChangeLog 10904
+MD5 1555034c22ce079183040f20941a434c gaim-0.66-r2.ebuild 1953
MD5 07beb4e67f5dd8cafed146e45b919144 files/digest-gaim-0.59.9-r1 128
MD5 ee8fb28717ed5fd8bdfce0b4c0611d75 files/digest-gaim-0.66 126
MD5 908f7feabba8c8b1d74510f1f2b7706d files/digest-gaim-0.63-r1 126
diff --git a/net-im/gaim/files/digest-gaim-0.66-r2 b/net-im/gaim/files/digest-gaim-0.66-r2
new file mode 100644
index 000000000000..23880debebfc
--- /dev/null
+++ b/net-im/gaim/files/digest-gaim-0.66-r2
@@ -0,0 +1,2 @@
+MD5 80c52fc8c969a65ea7bbd6444142fe5f gaim-0.66.tar.bz2 2744562
+MD5 03d3bdfe9eb1a73c44b0aa097513b10a encrypt-2.02.tar.gz 75136
diff --git a/net-im/gaim/gaim-0.66-r2.ebuild b/net-im/gaim/gaim-0.66-r2.ebuild
new file mode 100644
index 000000000000..8efd42e60c61
--- /dev/null
+++ b/net-im/gaim/gaim-0.66-r2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/gaim/gaim-0.66-r2.ebuild,v 1.1 2003/07/23 01:09:38 rizzo Exp $
+
+IUSE="nls perl spell nas ssl cjk"
+
+DESCRIPTION="GTK Instant Messenger client"
+HOMEPAGE="http://gaim.sourceforge.net/"
+EV=2.02
+SRC_URI="mirror://sourceforge/gaim/${P}.tar.bz2
+ ssl? ( mirror://sourceforge/gaim-encryption/encrypt-${EV}.tar.gz )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc"
+
+DEPEND="=sys-libs/db-1*
+ >=x11-libs/gtk+-2.0
+ >=dev-libs/glib-2.0
+ nas? ( >=media-libs/nas-1.4.1-r1 )
+ sys-devel/gettext
+ media-libs/libao
+ >=media-libs/audiofile-0.2.0
+ perl? ( >=dev-lang/perl-5.6.1 )
+ ssl? ( dev-libs/nss )
+ spell? ( >=app-text/gtkspell-2.0.2 )"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ cd ${P}
+ use ssl && {
+ cd ${S}/plugins
+ unpack encrypt-${EV}.tar.gz
+ cd encrypt
+ epatch patchfile.0.66
+ }
+ use cjk && {
+ cd ${S}/src
+ epatch ${FILESDIR}/gaim_gtkimcontext_patch.diff
+ }
+}
+
+src_compile() {
+
+ local myconf
+ use perl || myconf="${myconf} --disable-perl"
+ use spell || myconf="${myconf} --disable-gtkspell"
+ use nls || myconf="${myconf} --disable-nls"
+ use nas && myconf="${myconf} --enable-nas" || myconf="${myconf} --disable-nas"
+
+ econf ${myconf} || die "Configuration failed"
+ emake || MAKEOPTS="${MAKEOPTS} -j1" emake || die "Make failed"
+}
+
+src_install() {
+ einstall || die "Install failed"
+ dodoc ABOUT-NLS AUTHORS HACKING INSTALL NEWS README TODO ChangeLog
+}
+
+pkg_postinst() {
+ if [ `use ssl` ]; then
+ ewarn
+ ewarn "You have chosen (by selecting 'USE=ssl') to install"
+ ewarn "the gaim-encryption plugin ( http://gaim-encryption.sf.net/ )"
+ ewarn "this plugin is NOT supported by the Gaim project, and if you"
+ ewarn "expierence problems related to it, contact the Gentoo project"
+ ewarn "via http://bugs.gentoo.org/ or the gaim-encryption project."
+ ewarn
+ fi
+}