summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2008-06-08 03:50:11 +0000
committerTony Vroon <chainsaw@gentoo.org>2008-06-08 03:50:11 +0000
commitdeb87c2ebd10809d91cd13fefb32617702d40098 (patch)
tree0b0158b46a3397b6ce48db0cb35b21df26437929 /net-irc/conspire/conspire-0.20_beta1.ebuild
parentamd64 stable, bug #224387 (diff)
downloadhistorical-deb87c2ebd10809d91cd13fefb32617702d40098.tar.gz
historical-deb87c2ebd10809d91cd13fefb32617702d40098.tar.bz2
historical-deb87c2ebd10809d91cd13fefb32617702d40098.zip
Version bump. Properly separate out DEPENDs.
Package-Manager: portage-2.1.5.4
Diffstat (limited to 'net-irc/conspire/conspire-0.20_beta1.ebuild')
-rw-r--r--net-irc/conspire/conspire-0.20_beta1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-irc/conspire/conspire-0.20_beta1.ebuild b/net-irc/conspire/conspire-0.20_beta1.ebuild
new file mode 100644
index 000000000000..1232e710db41
--- /dev/null
+++ b/net-irc/conspire/conspire-0.20_beta1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/conspire/conspire-0.20_beta1.ebuild,v 1.1 2008/06/08 03:50:11 chainsaw Exp $
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="A high quality IRC client which uses a multitude of interfaces"
+HOMEPAGE="http://www.nenolod.net/conspire/"
+SRC_URI="http://distfiles.atheme.org/${MY_P}.tbz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86"
+IUSE="python gnutls ipv6 nls mmx socks5 dbus"
+DEPEND="nls? ( dev-util/intltool )"
+RDEPEND=">=dev-libs/libmowgli-0.6.0
+ >=x11-libs/gtk+-2.10
+ >=dev-libs/glib-2.14
+ x11-libs/libsexy
+ dbus? ( >=dev-libs/dbus-glib-0.60 )
+ python? ( >=dev-lang/python-2.2 )"
+
+src_compile() {
+ econf \
+ $(use_enable socks5 socks) \
+ $(use_enable ipv6) \
+ $(use_enable gnutls) \
+ $(use_enable python) \
+ $(use_enable mmx) \
+ $(use_enable nls) \
+ $(use_enable dbus) \
+ --enable-spell=libsexy \
+ --enable-regex \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc NEWS TODO
+}