summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-09-30 04:52:03 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-09-30 04:52:03 +0000
commitbbddb44e0e92763db8d3eb3462418c25c509c45a (patch)
treece04f266f2ba77933ba1d35fcb2937890cb3656f /net-irc/xchat
parentvim patches 1-200... Fixes #8400. Submitted by Bret Towe (diff)
downloadhistorical-bbddb44e0e92763db8d3eb3462418c25c509c45a.tar.gz
historical-bbddb44e0e92763db8d3eb3462418c25c509c45a.tar.bz2
historical-bbddb44e0e92763db8d3eb3462418c25c509c45a.zip
Added Bret Towe's fix regarding gnome and perl support within xchat
Diffstat (limited to 'net-irc/xchat')
-rw-r--r--net-irc/xchat/ChangeLog7
-rw-r--r--net-irc/xchat/files/digest-xchat-1.8.10-r11
-rw-r--r--net-irc/xchat/xchat-1.8.10-r1.ebuild107
3 files changed, 114 insertions, 1 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index a04fe8db88df..3ee051dc46ef 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for net-irc/xchat
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.18 2002/09/06 04:36:42 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.19 2002/09/30 04:52:03 rphillips Exp $
+*xchat-1.8.10-r1 (29 Sep 2002)
+
+ 29 Sep 2002; Ryan Phillips <rphillips@gentoo.org> xchat-1.8.10-r1.ebuild :
+
+ Bret Towe reimplemented the xchat perl/gnome ebuild
*xchat-1.8.10 (05 Sep 2002)
05 Sep 2002; Spider <spider@gentoo.org> xchat-1.8.10.ebuild :
diff --git a/net-irc/xchat/files/digest-xchat-1.8.10-r1 b/net-irc/xchat/files/digest-xchat-1.8.10-r1
new file mode 100644
index 000000000000..dfe9b6320489
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-1.8.10-r1
@@ -0,0 +1 @@
+MD5 9295830df5d040d7723620322a65f89c xchat-1.8.10.tar.bz2 824407
diff --git a/net-irc/xchat/xchat-1.8.10-r1.ebuild b/net-irc/xchat/xchat-1.8.10-r1.ebuild
new file mode 100644
index 000000000000..9f14b255c7ca
--- /dev/null
+++ b/net-irc/xchat/xchat-1.8.10-r1.ebuild
@@ -0,0 +1,107 @@
+# Copyrigth 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-1.8.10-r1.ebuild,v 1.1 2002/09/30 04:52:03 rphillips Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="X-Chat is a graphical IRC client for UNIX operating systems."
+SRC_URI="http://www.xchat.org/files/source/1.8/${P}.tar.bz2"
+HOMEPAGE="http://www.xchat.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc sparc64"
+
+RDEPEND="=x11-libs/gtk+-1.2*
+ python? ( >=dev-lang/python-2.2-r7 )
+ perl? ( >=sys-devel/perl-5.6.1 )
+ gnome? ( <gnome-base/gnome-panel-1.5.0
+ >=media-libs/gdk-pixbuf-0.11.0-r1 )
+ ssl? ( >=dev-libs/openssl-0.9.6a )"
+
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.10.38 )"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+
+ patch -p1 <${FILESDIR}/xc1810fixme3.diff
+ cp configure configure.orig
+
+ use python && ( \
+ local mylibs=`/usr/bin/python-config`
+ sed -e 's:PY_LIBS=".*":PY_LIBS="'"$mylibs"'":' \
+ configure.orig > configure
+ )
+}
+
+src_compile() {
+
+ local myopts myflags
+
+ if [ ! `use perl` ]; then
+ use gnome \
+ && myopts="${myopts} --enable-gnome --enable-panel" \
+ CFLAGS="${CFLAGS} -I/usr/include/orbit-1.0" \
+ || myopts="${myopts} --enable-gtkfe --disable-gnome --disable-zvt --disable-gdk-pixbuf"
+ else
+ myopts="${myopts} --disable-gnome"
+ fi
+
+ use gtk \
+ || myopts="${myopts} --disable-gtkfe"
+
+ use ssl \
+ && myopts="${myopts} --enable-openssl"
+
+ use perl \
+ || myopts="${myopts} --disable-perl"
+
+ use nls \
+ && myopts="${myopts} --enable-hebrew --enable-japanese-conv" \
+ || myopts="${myopts} --disable-nls"
+
+ if use x86
+ then
+ use mmx \
+ && myopts="${myopts} --enable-mmx" \
+ || myopts="${myopts} --disable-mmx"
+ fi
+
+ use ipv6 \
+ && myopts="${myopts} --enable-ipv6"
+
+ use python \
+ && myflags="`python-config`" \
+ && myopts="${myopts} --enable-python"
+
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ ${myopts} || die
+
+ emake || die
+}
+
+src_install() {
+
+ use kde && ( \
+ make \
+ prefix=${D}/usr \
+ utildir=${D}${KDEDIR}/share/applnk/Internet \
+ install || die
+ ) || ( \
+ make \
+ prefix=${D}/usr \
+ install || die
+ )
+
+ use gnome && ( \
+ insinto /usr/share/gnome/apps/Internet
+ doins xchat.desktop
+ )
+
+ dodoc AUTHORS COPYING ChangeLog README
+}