summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-10-11 15:01:47 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-10-11 15:01:47 +0000
commitc29ff216e0a528efcff3936ffedcbab142061a4b (patch)
tree5d7248ee618fa8bbec8d7ec136eed827858fc88f /net-irc/xchat
parentversion bump, use keyword masking for now (diff)
downloadhistorical-c29ff216e0a528efcff3936ffedcbab142061a4b.tar.gz
historical-c29ff216e0a528efcff3936ffedcbab142061a4b.tar.bz2
historical-c29ff216e0a528efcff3936ffedcbab142061a4b.zip
new masked gtk2 version
Diffstat (limited to 'net-irc/xchat')
-rw-r--r--net-irc/xchat/ChangeLog8
-rw-r--r--net-irc/xchat/files/digest-xchat-1.9.31
-rw-r--r--net-irc/xchat/xchat-1.9.3.ebuild94
3 files changed, 102 insertions, 1 deletions
diff --git a/net-irc/xchat/ChangeLog b/net-irc/xchat/ChangeLog
index 700456444ee6..4a59415d6412 100644
--- a/net-irc/xchat/ChangeLog
+++ b/net-irc/xchat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-irc/xchat
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.21 2002/10/01 00:27:25 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/ChangeLog,v 1.22 2002/10/11 15:01:47 lostlogic Exp $
+
+*xchat-1.9.3.ebuild (11 Oct 2002)
+
+ 11 Oct 2002; Brandon Low <lostlogic@gentoo.org> xchat-1.9.3.ebuild/xchat-1.9.3.ebuild:
+
+ Add another masked version in the gtk2 series.
*xchat-1.8.10-r1 (29 Sep 2002)
diff --git a/net-irc/xchat/files/digest-xchat-1.9.3 b/net-irc/xchat/files/digest-xchat-1.9.3
new file mode 100644
index 000000000000..634374dec87b
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-1.9.3
@@ -0,0 +1 @@
+MD5 7fbb3d96ab4b288343a6d9cf9e597d25 xchat-1.9.3.tar.bz2 701422
diff --git a/net-irc/xchat/xchat-1.9.3.ebuild b/net-irc/xchat/xchat-1.9.3.ebuild
new file mode 100644
index 000000000000..c87193c8cd97
--- /dev/null
+++ b/net-irc/xchat/xchat-1.9.3.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-1.9.3.ebuild,v 1.1 2002/10/11 15:01:47 lostlogic Exp $
+
+IUSE="ssl nls gnome ipv6 mmx python gtk perl"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="X-Chat is a graphical IRC client for UNIX operating systems."
+SRC_URI="http://www.xchat.org/files/source/1.9/${P}.tar.bz2"
+HOMEPAGE="http://www.xchat.org/"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="x86 ppc sparc sparc64"
+
+RDEPEND=">=dev-libs/glib-2.0.4
+ >=x11-libs/gtk+-2.0.5
+ perl? ( >=sys-devel/perl-5.6.1 )
+ gnome? ( >=x11-libs/libzvt-2.0.1
+ >=gnome-base/libgnome-2.0.1
+ >=gnome-base/gnome-applets-2.0.0
+ >=gnome-base/gnome-panel-2.0.1 )
+ ssl? ( >=dev-libs/openssl-0.9.6d )"
+
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.10.38 )"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+
+# From the xchat 1.9.2 README_FIRST file:
+# (one of the) REMAINING PROBLEMS:
+# * can't compile with gnome, panel and zvt support *
+# stroke
+
+src_compile() {
+
+ local myopts myflags
+
+ if [ ! `use perl` ] ; then
+ use gnome \
+ && myopts="${myopts} --enable-gnome --enable-panel" \
+ || myopts="${myopts} --enable-gtkfe --disable-gnome --disable-zvt"
+
+ use gnome \
+ && CFLAGS="${CFLAGS} -I/usr/include/orbit-2.0" \
+ || myopts="${myopts} --disable-gnome"
+ fi
+
+ use gtk \
+ || myopts="${myopts} --disable-gtkfe"
+
+ use ssl \
+ && myopts="${myopts} --enable-openssl"
+
+ use perl \
+ || myopts="${myopts} --disable-perl"
+
+ use python \
+ || myopts="${myopts} --disable-python"
+
+ use nls \
+ && myopts="${myopts} --enable-hebrew --enable-japanese-conv" \
+ || myopts="${myopts} --disable-nls"
+
+ use mmx \
+ && myopts="${myopts} --enable-mmx" \
+ || myopts="${myopts} --disable-mmx"
+
+ use ipv6 \
+ && myopts="${myopts} --enable-ipv6"
+
+
+ econf \
+ --program-suffix=-2 \
+ ${myopts} || die "Configure failed"
+
+ MAKEOPTS="-j1" emake || die "Compile failed"
+}
+
+src_install() {
+
+ einstall utildir=${D}${KDEDIR}/share/applnk/Internet install || die "Install failed"
+
+ use gnome &&
+ ( insinto /usr/share/gnome/apps/Internet
+ doins xchat.desktop )
+
+ dodoc AUTHORS COPYING ChangeLog README
+}