summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-17 17:28:59 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-17 17:28:59 +0000
commit41f0c3782f2fc77ee66bcc151eea7cb6fa468b5a (patch)
tree06b78e002ee4b2c79e5eaee5e8ed6502c380f813 /net-irc
parentAdded -- to the start-stop-daemon line (diff)
downloadhistorical-41f0c3782f2fc77ee66bcc151eea7cb6fa468b5a.tar.gz
historical-41f0c3782f2fc77ee66bcc151eea7cb6fa468b5a.tar.bz2
historical-41f0c3782f2fc77ee66bcc151eea7cb6fa468b5a.zip
Added experimental python support
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/xchat/files/digest-xchat-1.6.4-r11
-rw-r--r--net-irc/xchat/xchat-1.6.4-r1.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/net-irc/xchat/files/digest-xchat-1.6.4-r1 b/net-irc/xchat/files/digest-xchat-1.6.4-r1
new file mode 100644
index 000000000000..6d1083a57ca1
--- /dev/null
+++ b/net-irc/xchat/files/digest-xchat-1.6.4-r1
@@ -0,0 +1 @@
+MD5 995c02b43454ba76bb641792503c669a xchat-1.6.4.tar.bz2
diff --git a/net-irc/xchat/xchat-1.6.4-r1.ebuild b/net-irc/xchat/xchat-1.6.4-r1.ebuild
new file mode 100644
index 000000000000..6a2395f574bb
--- /dev/null
+++ b/net-irc/xchat/xchat-1.6.4-r1.ebuild
@@ -0,0 +1,89 @@
+# Copyrigth 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-irc/xchat/xchat-1.6.4-r1.ebuild,v 1.1 2001/06/17 17:28:59 achim Exp $
+
+A=${P}.tar.bz2
+S=${WORKDIR}/${P}
+DESCRIPTION="xchat"
+SRC_URI="http://www.xchat.org/files/source/1.6/"${A}
+HOMEPAGE="http://www.xchat.org/"
+
+DEPEND=">=gnome-base/gdk-pixbuf-0.11.0
+ perl? ( sys-devel/perl )
+ python? ( dev-lang/python )
+ nls? ( >=sys-devel/gettext-0.10.38 )
+ gnome? ( >=gnome-base/gnome-core-1.2.2.1 )
+ ssl? ( >=dev-libs/openssl-0.9.6a )"
+
+RDEPEND=">=gnome-base/gdk-pixbuf-0.11.0
+ gnome? ( >=gnome-base/gnome-core-1.2.2.1 ) ssl? ( >=dev-libs/openssl-0.9.6a )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/po
+ cp zh_TW.Big5.po zh_TW.Big5.po.orig
+ sed -e 's:\\\\:\\:' zh_TW.Big5.po.orig > zh_TW.Big5.po
+}
+
+src_compile() {
+
+ local myopts
+ local myflags
+
+ if [ "`use gnome`" ]
+ then
+ myopts="--enable-gnome --enable-panel --prefix=/opt/gnome"
+ else
+ myopts="--enable-gtkfe --disable-gnome --prefix=/usr/X11R6"
+ fi
+ if [ "`use ssl`" ] ; then
+ myopts="$myopts --enable-openssl"
+ fi
+ if [ -z "`use perl`" ] ; then
+ myopts="$myopts --disable-perl"
+ fi
+ if [ "`use python`" ] ; then
+ myflags="-lz"
+ if [ "`use berkdb`" ] ; then
+ myflags="$myflags -ldb-3.2 -lndbm"
+ fi
+ if [ "`use readline`" ] ; then
+ myflags="$myflags -lreadline -lncurses -lcrypt"
+ fi
+ else
+ myopts="$myopts --disable-python"
+ fi
+ if [ -z "`use nls`" ] ; then
+ myopts="$myopts --disable-nls"
+ fi
+ try ./configure --host=${CHOST} ${myopts}
+ if [ "$myflags" ] ; then
+ for i in src/fe-gtk src/fe-text
+ do
+ if [ -e $i/Makefile ] ; then
+ cp $i/Makefile $i/Makefile.orig
+ sed -e "s:-lpython2.0:-lpython2.0 $myflags:" \
+ $i/Makefile.orig > $i/Makefile
+ fi
+ done
+ fi
+ try pmake
+}
+
+src_install() {
+ cd ${S}
+ if [ -n "`use gnome`" ]
+ then
+ try make prefix=${D}/opt/gnome install
+ else
+ try make prefix=${D}/usr/X11R6 install
+ fi
+ dodoc AUTHORS COPYING ChangeLog README
+}
+
+
+
+
+
+