summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-02-26 01:24:16 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-02-26 01:24:16 +0000
commitb38cb41e3d99f313ddb0aff3a48ac3e786002b76 (patch)
treef660fecf3a15a5dcf2c8e81d92689e836ee179ef /net-irc
parentMask quassel Alphas. (diff)
downloadhistorical-b38cb41e3d99f313ddb0aff3a48ac3e786002b76.tar.gz
historical-b38cb41e3d99f313ddb0aff3a48ac3e786002b76.tar.bz2
historical-b38cb41e3d99f313ddb0aff3a48ac3e786002b76.zip
Initial import of Quassel, with a flag to enable/disable build of GUI client.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/quassel/ChangeLog10
-rw-r--r--net-irc/quassel/Manifest14
-rw-r--r--net-irc/quassel/metadata.xml16
-rw-r--r--net-irc/quassel/quassel-0.2.0_alpha1.ebuild50
4 files changed, 90 insertions, 0 deletions
diff --git a/net-irc/quassel/ChangeLog b/net-irc/quassel/ChangeLog
new file mode 100644
index 000000000000..22369ff95788
--- /dev/null
+++ b/net-irc/quassel/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-irc/quassel
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/ChangeLog,v 1.1 2008/02/26 01:24:16 flameeyes Exp $
+
+*quassel-0.2.0_alpha1 (26 Feb 2008)
+
+ 26 Feb 2008; Diego Pettenò <flameeyes@gentoo.org> +metadata.xml,
+ +quassel-0.2.0_alpha1.ebuild:
+ Initial import of Quassel, with a flag to enable/disable build of GUI client.
+
diff --git a/net-irc/quassel/Manifest b/net-irc/quassel/Manifest
new file mode 100644
index 000000000000..289dc2358e87
--- /dev/null
+++ b/net-irc/quassel/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST quassel-0.2.0-alpha1.tar.bz2 919272 RMD160 8ebb61f525a49b2dc91d8985273e844d3e7b8879 SHA1 c437026f7db02548507a101d37e8f00d54439000 SHA256 3b64f29922fe8720488d9b22d8db49df72ba23a40aa46182cbd4813c14cdf525
+EBUILD quassel-0.2.0_alpha1.ebuild 1223 RMD160 a9155661ecb55ba547264b21a8ba82e4c3abb81f SHA1 5a32ca0563c45128e6535d1d646980c6719a3640 SHA256 8b1f5d6ceb9eccf50dbff5a007069421bd7186c86fe05f4f9d8895c410fa5349
+MISC ChangeLog 424 RMD160 2285a991f7bb741998415100a56ede994d241ba7 SHA1 5f85ede3f58b313f2b6bcd19d0127c5057105d5d SHA256 49b9176be7db359ff5fa2bbbfe21921d9c0fec9b6722aa9d03b4e86d75620fe2
+MISC metadata.xml 505 RMD160 c1e365560a7938ea6ce218f3624b8c96a738d7ca SHA1 66c409b535ea77b7fbe1301210bcb3f17124d3a3 SHA256 496b4e75e14a40eacfbeebc935089e7fbfb35965289d987e966a3a97531bc12a
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.7 (GNU/Linux)
+
+iD8DBQFHw2pGAiZjviIA2XgRAiqWAKC+5Ki+x8vY8XW+4gED/lG1slSR9gCgmLVl
+eTCtHm8O3ce1gc+efOLA590=
+=h+7+
+-----END PGP SIGNATURE-----
diff --git a/net-irc/quassel/metadata.xml b/net-irc/quassel/metadata.xml
new file mode 100644
index 000000000000..560ac06831f2
--- /dev/null
+++ b/net-irc/quassel/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-irc</herd>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="X">
+ Also build the Qt 4 GUI client for quassel. If this USE flag is
+ disabled, only the core (server) binary is built. You might want
+ to disable this on the server, but you need it enabled on the
+ client.
+ </flag>
+ </use>
+</pkgmetadata>
diff --git a/net-irc/quassel/quassel-0.2.0_alpha1.ebuild b/net-irc/quassel/quassel-0.2.0_alpha1.ebuild
new file mode 100644
index 000000000000..31b78ef57539
--- /dev/null
+++ b/net-irc/quassel/quassel-0.2.0_alpha1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/quassel/quassel-0.2.0_alpha1.ebuild,v 1.1 2008/02/26 01:24:16 flameeyes Exp $
+
+EAPI=1
+
+inherit qt4
+
+MY_P="${P/_alpha/-alpha}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Core/client IRC client."
+HOMEPAGE="http://quassel-irc.org/"
+SRC_URI="http://quassel-irc.org/system/files/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+
+KEYWORDS="~amd64"
+
+SLOT="0"
+
+IUSE="X debug"
+
+RDEPEND="$(qt4_min_version 4.0)"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if ! built_with_use x11-libs/qt:4 sqlite3; then
+ eerror "Quassel require Qt 4 built with SQLite support"
+ eerror "Please rebuild x11-libs/qt:4 with sqlite3 USE flag enabled."
+ die "Missing sqlite3 support in x11-libs/qt:4"
+ fi
+}
+
+src_compile() {
+ local BUILD="core"
+ use X && BUILD="${BUILD} qtclient"
+
+ eqmake4 ${PN}.pro BUILD="${BUILD}" || die "eqmake4 failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ local targets="build/targets/quasselcore"
+ use X && targets="${targets} build/targets/quasselclient"
+ dobin $targets || die "quasselcore install failed"
+
+ dodoc ChangeLog README README.Qtopia dev-notes/paulk-notes.txt \
+ dev-notes/ROADMAP
+}