summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-11-02 18:19:33 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-11-02 18:19:33 +0000
commitda4684098d8567b23b2d332117d20b3398c4a6d5 (patch)
treef22238068af127327d587646fefbd8776e16e65b /net-libs/daq
parentAutomated update of use.local.desc (diff)
downloadhistorical-da4684098d8567b23b2d332117d20b3398c4a6d5.tar.gz
historical-da4684098d8567b23b2d332117d20b3398c4a6d5.tar.bz2
historical-da4684098d8567b23b2d332117d20b3398c4a6d5.zip
Bump
Package-Manager: portage-2.2.0_alpha3/cvs/Linux x86_64
Diffstat (limited to 'net-libs/daq')
-rw-r--r--net-libs/daq/ChangeLog7
-rw-r--r--net-libs/daq/Manifest4
-rw-r--r--net-libs/daq/daq-0.3.ebuild61
3 files changed, 70 insertions, 2 deletions
diff --git a/net-libs/daq/ChangeLog b/net-libs/daq/ChangeLog
index b25d1bc43a28..5db0dce9688e 100644
--- a/net-libs/daq/ChangeLog
+++ b/net-libs/daq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/daq
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/daq/ChangeLog,v 1.1 2010/11/02 18:11:18 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/daq/ChangeLog,v 1.2 2010/11/02 18:19:33 patrick Exp $
+
+*daq-0.3 (02 Nov 2010)
+
+ 02 Nov 2010; Patrick Lauer <patrick@gentoo.org> +daq-0.3.ebuild:
+ Bump
*daq-0.2 (02 Nov 2010)
diff --git a/net-libs/daq/Manifest b/net-libs/daq/Manifest
index 73669be71c01..ebc54a6e2bef 100644
--- a/net-libs/daq/Manifest
+++ b/net-libs/daq/Manifest
@@ -1,4 +1,6 @@
DIST daq-0.2.tar.gz 448581 RMD160 0df9c623652be04339a8862d9329fb8fe4fbbb28 SHA1 add11b15ba43cbcbb9f444ae557723294e156596 SHA256 005658baf4295e094e1a829ddb12758e1d43072e523674a8e1eaca8264c28501
+DIST daq-0.3.tar.gz 437018 RMD160 6b24da7ecaa26461af34b58d024885aeb10134d7 SHA1 5177e8d7b5c4255590c7bfc228fe844b3e65b351 SHA256 60157fb25f4f6967b8fa095ce19366d7e38bde0990d3d7df99b99078b3afd563
EBUILD daq-0.2.ebuild 1625 RMD160 30c25dd5ae90b4d8419877b0db10cf318ec5b8e0 SHA1 8b6b68f0acb4964026b870d69fe747a9444dec9c SHA256 45900dfe3ccd688aec9728ed052e201151a61eae7de0eb590ff7661b9970f6ec
-MISC ChangeLog 366 RMD160 815ade6d1742e3fe47c84e53ae100138c9d942c3 SHA1 678068aa8660a2d7c32abbd2a52419425a77d4a4 SHA256 990cf8d2c690cc59b208660ee38d8b38523b7d569f84b1783241a716b86da2ca
+EBUILD daq-0.3.ebuild 1625 RMD160 16cd91e95d535bb686d218cb3ec19265767ecbd8 SHA1 b1b6fba624c50b47a739799100c03bad707ab670 SHA256 724d8e740883d22c89b342c46c4c372b30b972e6d963f5fb0fa02524cba9a9ec
+MISC ChangeLog 465 RMD160 33933bcc7773bb0716f4e1ef3109659cb69aa249 SHA1 d57cbb60c03f0a0113ba14793631d6c71d4be83c SHA256 594f5982cc67500f6b93153b99c90ed746cbf8260ff0cbe470950b3368f19b23
MISC metadata.xml 687 RMD160 ef5da732cb42fd66f9c448bc7eb69f4528ba709a SHA1 bc3d053c080d3024b0ec71fe3542896bc0a2d39a SHA256 7b15cac86b35562d64c48fed494c8ceb98b0f0f1abd2f39725f11771fcda9480
diff --git a/net-libs/daq/daq-0.3.ebuild b/net-libs/daq/daq-0.3.ebuild
new file mode 100644
index 000000000000..3e47283d4050
--- /dev/null
+++ b/net-libs/daq/daq-0.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/daq/daq-0.3.ebuild,v 1.1 2010/11/02 18:19:33 patrick Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Data Acquisition library, for packet I/O"
+HOMEPAGE="http://www.snort.org/"
+SRC_URI="http://www.snort.org/downloads/302 -> ${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ipv6 afpacket dump +pcap"
+
+DEPEND="pcap? ( >=net-libs/libpcap-1.0.0 )
+ dump? ( >=net-libs/libpcap-1.0.0 )"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+
+ econf \
+ $(use_enable ipv6) \
+ $(use_enable pcap pcap-module) \
+ $(use_enable afpacket afpacket-module) \
+ $(use_enable dump dump-module) \
+ --disable-ipfw-module \
+ --disable-bundled-modules
+
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc ChangeLog README
+
+}
+
+pkg_postinst() {
+
+ elog
+ elog "The Data Acquisition library (DAQ) for packet I/O replaces direct"
+ elog "calls to PCAP functions with an abstraction layer that facilitates"
+ elog "operation on a variety of hardware and software interfaces without"
+ elog "requiring changes to application such as Snort."
+ elog
+ elog "The only DAQ modules supported with this ebuild are AFpacket, PCAP,"
+ elog "and Dump. IPQ and NFQ will be supported in future versions of this"
+ elog "package."
+ elog
+ elog "Please see the README file for DAQ for information about specific"
+ elog "DAQ modules."
+ ewarn
+ ewarn "If you are reinstalling this package, you should also reinstall"
+ ewarn "packages that use this library for packet capture."
+ ewarn
+
+}