summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-11-14 13:43:50 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-11-14 13:43:50 +0000
commit470613c0c51a2734af109bf8d43b25b633835b1c (patch)
treed3624adec13401f9414585bcdf8482fb25a61e25 /net-libs/gloox/gloox-1.0.ebuild
parentQA: Drop old masked version since newer is around. (diff)
downloadhistorical-470613c0c51a2734af109bf8d43b25b633835b1c.tar.gz
historical-470613c0c51a2734af109bf8d43b25b633835b1c.tar.bz2
historical-470613c0c51a2734af109bf8d43b25b633835b1c.zip
QA: Version bump to latest stable release to drop need for pmask entry.
Package-Manager: portage-2.2_rc49/cvs/Linux x86_64
Diffstat (limited to 'net-libs/gloox/gloox-1.0.ebuild')
-rw-r--r--net-libs/gloox/gloox-1.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-libs/gloox/gloox-1.0.ebuild b/net-libs/gloox/gloox-1.0.ebuild
new file mode 100644
index 000000000000..aa79ec4eebb3
--- /dev/null
+++ b/net-libs/gloox/gloox-1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/gloox-1.0.ebuild,v 1.1 2009/11/14 13:43:50 scarabeus Exp $
+
+EAPI=2
+
+inherit autotools
+
+MY_P=${P/_/-}
+DESCRIPTION="A portable high-level Jabber/XMPP library for C++"
+HOMEPAGE="http://camaya.net/gloox"
+SRC_URI="http://camaya.net/download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug gnutls idn ssl zlib"
+
+DEPEND="idn? ( net-dns/libidn )
+ gnutls? ( net-libs/gnutls )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ econf \
+ $(use_enable debug debug) \
+ $(use_with idn libidn) \
+ $(use_with gnutls gnutls) \
+ $(use_with ssl openssl) \
+ $(use_with zlib zlib)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}